Defect - Selecting text from the end with caret not working (duckduckgo.com)

RESOLVED DUPLICATE of bug 904960

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 904960
6 years ago
5 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
Selecting text from the end of a text box isn't working. When you drag the caret monocle from the end of a word in a text box, it will disappear and will not select anything when dragging it through the text.

Tried this with an older build and it worked without any issues.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to duckduckgo.com
3) Insert MozillaFirefox into the search field and then tap near the end of the word (a caret monocle should appear at the end of the word)
4) Drag the caret monocle and attempt to select some of the text (You'll notice that the monocle will disappear and nothing will be selected)

Current Behavior:

- Attempting to select text from the end of a text box doesn't work. The monocle will disappear while you are dragging and nothing will be selected

Expected Behavior:

- When dragging the monocle, it should be visible and at the same time selecting the correct text when a user is dragging it.

Used build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-07-17-03-02-07-mozilla-central/
Hmm, I'm not able to reproduce. Maybe there's a quirk in your STR that I'm missing?
Summary: Defect - Selecting text from the end with caret not working → Defect - Selecting text from the end with caret not working (duckduckgo.com)
Reporter

Comment 2

6 years ago
Try to make sure that the cursor is all the way at the end of the search text, then try to slide the monocle. It will disappear and nothing will be selected.

If you put the cursor and monocle in the middle of the last and second last letter, you will be able to select everything by sliding the monocle.

Example:

firefox| <- cursor and monocle at the end, sliding it over to the left will not work
firefo|x <- cursor and monocle between the last and second last letters will work correctly
Priority: -- → P3
No longer blocks: metrov2defect&change

Updated

6 years ago
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904960
No longer blocks: metrobacklog, caret-sel, 854070
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=0
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.