Closed Bug 903969 Opened 6 years ago Closed 6 years ago

[Homescreen] Entering edit mode/ moving an app icon causes device to freeze for several seconds

Categories

(Core :: Graphics: Layers, defect, blocker)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla26
blocking-b2g koi+
Tracking Status
firefox26 --- fixed

People

(Reporter: zcampbell, Assigned: nical)

References

Details

(Keywords: hang, regression, Whiteboard: [fromAutomation])

Attachments

(2 files)

Entering edit mode on the homescreen causes the device to freeze and become completely unresponsive.

STR
1. Unlock phone
2. Swipe to first page of homescreen icons
3. Long press, drag and then drop an icon
4. Device will freeze.

This first started on this build:
Gecko  http://hg.mozilla.org/mozilla-central/rev/c5946a8bcd5b
Gaia  2814f1df7dd77590250aef0035704e60428765ff
BuildID 20130810040220
Version 26.0a1
Do you have a log?
Keywords: hang, stackwanted
Hardware: Other → ARM
Flags: needinfo?(zcampbell)
Attached file logcat_moveapp.log
Ah filing bugs first thing on Monday morning..!

Here is a logcat. Line #1466 is where we perform the long press, wait, and then mouse up to trigger the context menu event.

There is no crash report. The device just freezes.
Flags: needinfo?(zcampbell)
Keywords: stackwanted
Component: Gaia::Homescreen → General
The device is freezing likely due to a GENLOCK error.

E/Adreno200-EGLSUB(  760): LockImage() genlock_lock_buffer GENLOCK_READ_LOCK failed
E/libgenlock(  760): perform_lock_unlock_operation: GENLOCK_IOC_LOCK failed (lockType0x0, err=Invalid argument fd=146)
We need a regression window here to find out when the GENLOCK error started happening that leads to freezing the phone.
In comment #0 I stated the first build it started on. The 20130809 build was fine. 20130810 and 20130811 are affected. I worked this out from our automated test failure logs.
(In reply to Zac C (:zac) from comment #5)
> In comment #0 I stated the first build it started on. The 20130809 build was
> fine. 20130810 and 20130811 are affected. I worked this out from our
> automated test failure logs.

That probably won't be enough however to identify the regressing patch. Then again, we can't go deeper given that we don't have builds down to a changeset to a bisection.
Gabrielle - I recall you working on a bug similar to this a while back. Do you have any ideas why this GENLOCK error is happening?
Flags: needinfo?(gsvelto)
From what I could gather this is a side-effect of bug 858914 and I could find no way around it save disabling gralloc'd textures which causes a significant hit to both performance and power usage :( You could try and test with the patch-set from bug 858914 applied but it looks big... and scary.
Flags: needinfo?(gsvelto)
Depends on: 858914
blocking-b2g: --- → koi?
Keywords: smoketest
Looks like this might have been caused by bug 900012.
Duplicate of this bug: 906787
Duplicate of this bug: 907263
Duplicate of this bug: 909663
Assignee: nobody → bgirard
I can reproduce this on hamachi. I don't see a crash, just a several temporary several second long freeze.

I also see the genlock failures.
Summary: [Homescreen] Entering edit mode/ moving an app icon causes device to crash → [Homescreen] Entering edit mode/ moving an app icon causes device to freeze for several seconds
Attached file backtrace
hardware/qcom/display/libgenlock/genlock.h has a hard timeout of 1 second for genlock. I don't understand why that's describable. But in any case we should avoid waiting so long on it.
Looks like this unagi-specific - we aren't seeing this on buri. As such, we aren't doing smoketests on unagi anymore, so pulling the smoketest keyword.
Keywords: smoketest
I see this on the hamachi so it's not unagi sepcific.
(In reply to Benoit Girard (:BenWa) from comment #18)
> I see this on the hamachi so it's not unagi sepcific.

Hmm okay. Interesting that this isn't showing up in daily smoketests then.
No longer blocks: b2g-central-dogfood
Duplicate of this bug: 910362
Component: General → Graphics: Layers
Product: Boot2Gecko → Core
(In reply to Jason Smith [:jsmith] from comment #19)
> (In reply to Benoit Girard (:BenWa) from comment #18)
> > I see this on the hamachi so it's not unagi sepcific.
> 
> Hmm okay. Interesting that this isn't showing up in daily smoketests then.

I've just updated b2g and it's no longer showing up. I have the new texture forced enabled, see bug 907745.
Duplicate of this bug: 913429
This still is reproducing on :
Reproducing on:
Gecko  http://hg.mozilla.org/mozilla-central/rev/aa9ec17cf912
Gaia  41f9daeca07b230ca2e5f824ed80f7dcfbc93815
BuildID 20130905143608
Version 26.0a1

See logcat on:
https://bug913429.bugzilla.mozilla.org/attachment.cgi?id=800741
Bug 907745 just landed. Is this still reproducible?
Keywords: qawanted
QA Contact: sarsenyev
Confirming the issue on the latest Buri 1.2 master build,
after moving an icon the device hangs for about 10sec

Environmental  Variables:
Build ID: 20130906040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/ab5f29823236
Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
Platform Version: 26.0a1
Keywords: qawanted
This needs to be tested on tomorrow's build or later - the patches in question landed today at 8am.
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #26)
> This needs to be tested on tomorrow's build or later - the patches in
> question landed today at 8am.

I've got a local build with that pref flipped on hamachi with HWComposer and the genlock failures are gone so the signs are good. I'll try again tomorrow with exactly what we see on trunk.
This issue is no longer reproducing on Buri 1.2 Build ID: 20130910040201

Gecko: http://hg.mozilla.org/mozilla-central/rev/be1053dc223b
Gaia: 6deda9d7c51f278443f704217eaed722044a03e7
Platform Version: 26.0a1
RIL Version: 01.01.00.019.211 

Drag and Dropping icons no longer hangs or freezes.
Keywords: qawanted
Sounds like we can now close this as fixed by bug 907745.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: bgirard → nical.bugzilla
Depends on: 907745
Target Milestone: --- → mozilla26
Verified
Status: RESOLVED → VERIFIED
No longer blocks: GFXB2G1.2
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.