Closed Bug 910293 Opened 6 years ago Closed 5 years ago

TEST-UNEXPECTED-FAIL | newmailaccount/test-newmailaccount.js | test-newmailaccount.js::test_can_display_providers_in_other_languages

Categories

(Thunderbird :: Account Manager, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 37.0

People

(Reporter: standard8, Assigned: hiro)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(2 files, 1 obsolete file)

Since on the trunk Ubuntu 64 opt builders, since we switched, not sure about elsewhere yet.

TEST-START | /builds/slave/test/build/mozmill/newmailaccount/test-newmailaccount.js | test_can_display_providers_in_other_languages
Step Pass: {"function": "controller.waitFor()"}
Step Pass: {"function": "controller.waitFor()"}
Step Pass: {"function": "controller.click()"}
Test Failure: Timed out waiting for element with ID=otherLangDesc to become invisible
Step Pass: {"function": "controller.click()"}
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/newmailaccount/test-newmailaccount.js | test-newmailaccount.js::test_can_display_providers_in_other_languages
Heisenbug ... Once I add more debug outputs, the bug disappears:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=04aaac9eb90a

$("#otherLangDesc").click event handler called.
Step Pass: {"function": "controller.click()"}
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
fadeOut animation completed.
CSS visibility property for element with ID=otherLangDesc is: visible
Step Pass: {"function": "utils.waitFor()"}

But what I find strange is that apparently the element becomes invisible between my debug print of the visibility CSS property and the actual test for is(":visible") ...
Blocks: 929608
Assignee: nobody → blog
Hiroyuki, I saw your try build regarding this bug. Do you have any "hot" idea about the reason of the problem, or are you just trying out random ideas? In any case, it might be helpful if you could document here what you have already tried, in order to prevent needless double efforts ...
I was guessing that $("#otherLangDesc").fadeOut() is started before fadeIn() is finished but it was wrong.
(In reply to Jens Müller (:tessarakt) from comment #23)
> Heisenbug ... Once I add more debug outputs, the bug disappears:
> 
> https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=04aaac9eb90a

I tried to re-run it and it failed several times.

$("#otherLangDesc").click event handler called.
Step Pass: {"function": "controller.click()"}
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
CSS visibility property for element with ID=otherLangDesc is: visible
Test Failure: Timed out waiting for element with ID=otherLangDesc to become invisible

The log shows us that fadeOut() is invoked but not completed. Or checking is(":visible") is broken.
(In reply to Hiroyuki Ikezoe (:hiro) from comment #27)
> (In reply to Jens Müller (:tessarakt) from comment #23)
> > Heisenbug ... Once I add more debug outputs, the bug disappears:
> > 
> > https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=04aaac9eb90a
> 
> I tried to re-run it and it failed several times.

And in the 2nd-to-last orange: https://tbpl.mozilla.org/php/getParsedLog.php?id=30170065&tree=Thunderbird-Try, we have Bug 891745 (or something similar) again ... :-(
Assignee: blog → nobody
Strange. I don't see this in my local DEBUG BUILD at all.
Can it be that there is a difference of LANG, LC_ALL, and other environment variable setting?
(In reply to ISHIKAWA, Chiaki from comment #33)
> Strange. I don't see this in my local DEBUG BUILD at all.
> Can it be that there is a difference of LANG, LC_ALL, and other environment
> variable setting?

I forgot to mention. I am testing DEBUG BUILD of TB.
So this might mean I have different timing issues because of added printing of various warning and error messages (I see ton of JavaScript strict errors caused by the execution of jquery.js, which I did not bother
to report before.)
This timing difference may cause the "Heisenberg" noted in comment 23.

TIA
Can it be that mozmill 2.0 does not have this issue?
(I have upgraded mozmill package on my local test PC, and do not see this bug at all during 
|make mozmill|. )

TIA
Something has been changed since comment #57. Before that there is no failure on debug build, but now there are lots of failures on debug build. We could reproduce this failure on local, hopefully.
A long shot.

What is the locale setting of the test environment (tryserver) just
before |make mozmill| is invoked?

LANG
LC_TYPE
LC_ALL
LC_DATE
etc.

I am now running 
LANG=C.UTF-8
LC_TYPE=C.UTF-8
LC_ALL=C
LC_DATE=C
Setting and exporting order may matter.
Whatever value LANG may have, the later LC_TYPE setting will overwrite it, etc.

TIA
I am quoting the excerpt from  the local log of invoking |make mozmill| of DEBUG build of TB.

Aside from many warnings from jquery.js,
and several WARNING lines, I don't see suspicious errors.

OTOH, I am not so sure if the newmailaccount test in general is running
successfully in my local setup in the sense that

 - TB seems to try to access some remote DB that contains ISP information,
   but that part does not seem to succeed on my PC: I see the graphical symbol indicating
   network activity rotating until the test proceeds, suggesting
   that the ISP setup never seems to obtained successfully. Maybe there
   is some local hostname resolver issues or something.

 - If so, then the line marked by (**) at the beginning of the line
 [ in TWO (2) places ]
   may indicate different behavior on my PC from the one on TryServer
   (wild guess, not sure where the
   failure to obtain the ISP info can be correlated.)

 - If, as the test name suggests, TB is supposed to receive a configuration information
   containing non-ASCII character, etc., then TB can NEVER fail here on my PC because
   it DOES NOT receive the information on my local PC (Debian GNU/Linux 64-bit) at all, so
   merrily take a different unexpected error path to its completion.
   [On the other hand, another PC (Debian GNU/Linux 32-bit) does 
   not seem to have this network failure problem, and
   |make mozmill| seems to proceed well to fetch the ISP info, 
   but I don't think I have seen the error reported here.]

cf. 
This is the order of setting environmental variable in my setup before invoking |make mozmill|,
taken from my shell script (typo included):

LC_ALL=C.UTF-8
LC_DATE=C
LC_TIME=C

export LC_ALL

# set LANG and export AFTER LC_ALL on Jan 24, 2014
# Setting LANG to C  may be the causse of
# DEBUG: native_charset = <<ANSI_X3.4-1968>>
# in LazyInit() 
# in mozilla/xpcom/io/nsNativeCharsetUtils.cpp
# LANG=ja_JP.UTF-8 did not work.
# Trying LANG=C.UTF-8 


export LANG=ja_JP.UTF-8 
export LC_DATE LC_TIME

Note: you need a patch posted lately to bug 
[Bug 960957] Remove support for *nix systems whose char* APIs for file names don't use UTF-8
so that "C" is recognized as valid language code.

Excerpted log for test_can_display_providers_in_other_languages

TEST-START | /REF-COMM-CENTRAL/comm-central/mail/test/mozmill/newmailaccount/test-newmailaccount.js | test_can_display_providers_in_other_languages
Step Pass: {"function": "controller.waitFor()"}
Step Pass: {"function": "controller.waitFor()"}
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: reference to undefined property a.returnValue
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: reference to undefined property c.result
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property a.liveFired
Step Pass: {"function": "controller.click()"}
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: reference to undefined property d.queue
--DOCSHELL 0x50fc920 == 15 [pid = 7032] [id = 21]
--DOCSHELL 0x2809680 == 14 [pid = 7032] [id = 20]
--DOCSHELL 0x5921680 == 13 [pid = 7032] [id = 19]
--DOCSHELL 0x5c4c520 == 12 [pid = 7032] [id = 18]
--DOMWINDOW == 44 (0x5546f08) [pid = 7032] [serial = 27] [outer = (nil)] [url = chrome://messenger/content/msgAccountCentral.xul]
--DOMWINDOW == 43 (0x2f48e28) [pid = 7032] [serial = 39] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 42 (0x6409598) [pid = 7032] [serial = 33] [outer = (nil)] [url = http://localhost:43336/registration.html?product=personalized_email&quote=b28acb3c0a464d33af22]
--DOMWINDOW == 41 (0x55bbe88) [pid = 7032] [serial = 28] [outer = (nil)] [url = chrome://messenger/content/msgAccountCentral.xul]
--DOMWINDOW == 40 (0x5f89828) [pid = 7032] [serial = 30] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 39 (0x43f9048) [pid = 7032] [serial = 42] [outer = (nil)] [url = http://localhost:43336/registration.html?product=personalized_email&quote=b28acb3c0a464d33af22]
--DOMWINDOW == 38 (0x29747f8) [pid = 7032] [serial = 37] [outer = (nil)] [url = chrome://messenger/content/msgAccountCentral.xul]
--DOMWINDOW == 37 (0x5acd358) [pid = 7032] [serial = 34] [outer = (nil)] [url = http://localhost:43336/config.xml?firstname=Green&lastname=Llama&email=da.green.llama%40foo.invalid]
--DOMWINDOW == 36 (0x38c9c78) [pid = 7032] [serial = 36] [outer = (nil)] [url = about:blank]
Step Pass: {"function": "controller.waitFor()"}


(**) CI comment: can the following line indicate a network error?

JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property a.nodeType
Step Pass: {"function": "controller.click()"}
++DOCSHELL 0x50f6f20 == 13 [pid = 7032] [id = 23]
++DOMWINDOW == 37 (0x4a44288) [pid = 7032] [serial = 59] [outer = (nil)]
++DOMWINDOW == 38 (0x2699848) [pid = 7032] [serial = 60] [outer = 0x4a44288]
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: function cf does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: function ce does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: function bZ does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: function L does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property f.valHooks[this]
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 17: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 22: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 22: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 28: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 65: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 71: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 97: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 109: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 109: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 116: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 125: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 159: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 159: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 159: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 160: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 160: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 219: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 224: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 235: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 247: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 248: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 248: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 248: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 249: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 271: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 272: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 273: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 276: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 286: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 302: test for equality (==) mistyped as assignment (=)?
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 328: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 330: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 330: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 359: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 357: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 366: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 377: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 383: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 389: anonymous function does not always return a value
JavaScript strict warning: chrome://messenger/content/jquery-ui.js, line 390: anonymous function does not always return a value

(**) CI comment: the next few lines may indicate a network failure and the failure to load the
     ISP information (?)

JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: reference to undefined property h[j]
[7032] WARNING: NS_ENSURE_TRUE(ParseTypeAttribute(type, &version)) failed: file /REF-COMM-CENTRAL/comm-central/mozilla/content/base/src/nsScriptLoader.cpp, line 508
[7032] WARNING: NS_ENSURE_TRUE(ParseTypeAttribute(type, &version)) failed: file /REF-COMM-CENTRAL/comm-central/mozilla/content/base/src/nsScriptLoader.cpp, line 508
JavaScript strict warning: chrome://messenger/content/jquery.js, line 3: reference to undefined property i.sizcache
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: reference to undefined property d.cache
[7032] WARNING: NS_ENSURE_TRUE(currentURI) failed: file /REF-COMM-CENTRAL/comm-central/mozilla/content/base/src/ThirdPartyUtil.cpp, line 96
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property a[f.expando]
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property a.selector
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property a.nodeType
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property a[0]
JavaScript strict warning: chrome://messenger/content/jquery.js, line 2: reference to undefined property f.event.triggered
[7032] WARNING: Must complete empty transaction when compositing!: file /REF-COMM-CENTRAL/comm-central/mozilla/layout/base/nsPresShell.cpp, line 5788
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: reference to undefined property e.queue
JavaScript strict warning: chrome://messenger/content/jquery.js, line 4: reference to undefined property e.queue
TEST-PASS | /REF-COMM-CENTRAL/comm-central/mail/test/mozmill/newmailaccount/test-newmailaccount.js | test-newmailaccount.js::test_can_display_providers_in_other_languages

PS: I hate to see such many warnings and errors from jquery.js.
Wait.
I see that the error is essentially a timeout error of a sort.

Another long shot:

I have lengthened various timeout in the python script |make mozmill|
can it explain that I don't see the error mentioned?

Come to think of it, the timeout error in javascript is order of a few seconds at most
while the timeout in python scripts that are used by mozmill is order of maginitude longer
(I am setting them to 3 minutes = 180 seconds, or even 500 seconds lately). So
they may not be related at all. 

This can be Ubuntu-specific even.

TIA
(In reply to TBPL Robot from comment #111)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=34279591&tree=Thunderbird-
> Trunk
> Ubuntu VM 12.04 comm-central opt test mozmill on 2014-02-07 04:07:13
> revision: 2e4699e14f86
> slave: tst-linux32-spot-361
> 
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/message-header/test-message-header.js |
> test-message-header.js::test_a11y_attrs
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/newmailaccount/test-newmailaccount.js |
> test-newmailaccount.js::test_show_tos_privacy_links_for_selected_providers
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run

Interesting. 
Ever notice the WARNNIGS that look like this around the error?:

 signal name `selection_changed' is invalid for instance `0x9b10fa00': 'glib warning', file ../../../../mozilla/toolkit/xre/nsSigHandlers.cpp, line 127

I wonder if these warnings are related to the test failure itself: I have seen these on my local PC and
wondered what it is: See
Bug 927337 - WARNING: /build/glib2.0-Ot8bbC/glib2.0-2.36.4/./gobject/gsignal.c:3429: signal name `selection_changed' is invalid for instance `0xc5db018' of type `MaiAtkType3': 'glib warning', file ...../mozilla/toolkit/xre/nsSigHan

However, I have not seen this particular error (below) itself on my local PC (I have not updated my local C-C source directory for the last couple of weeks so it may be the reason. *IF* so, then the bug
may have been introduced in the last couple of weeks.)

Test Failure: headerAccessible.name for Subject was 'null'; expected 'Subjec: This is a really, really, really, really, really, really, really, really, long subject.'

TIA
See Also: → 927337
(In reply to TBPL Robot from comment #225)
> submit_timestamp: 2014-10-25T18:07:58
> log:
> https://treeherder.mozilla.org/ui/logviewer.html#?repo=comm-
> central&job_id=1427
> repository: comm-central
> who: Pidgeot18[at]gmail[dot]com
> machine: tst-linux32-spot-047
> buildname: Ubuntu VM 12.04 comm-central opt test mozmill
> revision: 0ea5fe2ba57c
> 
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/message-header/test-message-header.js |
> test-message-header.js::test_clicking_star_opens_inline_contact_editor
> TEST-UNEXPECTED-FAIL |

This was failing 
due to the following error (from a log using DEBUG BUILD of TB)

TEST-START | /REF-COMM-CENTRAL/comm-central/mail/test/mozmill/message-header/test-message-header.js | test_clicking_star_opens_inline_contact_editor

Step Pass: {"function": "controller.click()"}

JavaScript strict warning: chrome://messenger/content/editContactOverlay.js, line 166: ReferenceError: reference to undefined property Components.interfaces.nsIPopupBoxObject

JavaScript error: chrome://messenger/content/editContactOverlay.js, line 166: TypeError: Components.interfaces.nsIPopupBoxObject is undefined


 above is FIXED by the patch in

Bug 1086605

> /builds/slave/test/build/mozmill/message-header/test-message-header.js |
> test-message-header.js::
> test_address_book_switch_disabled_on_contact_in_mailing_list
> TEST-UNEXPECTED-FAIL | (runtestlist.py) | Exited with code 1 during
> directory run
> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/newmailaccount/test-newmailaccount.js |
> test-newmailaccount.js::test_can_display_providers_in_other_languages

The original bug reported here.
I am sorry that I have not seen this error on my local PC using locally created
DEBUG BUILD of C-C TB.
I have no idea why.


> TEST-UNEXPECTED-FAIL |
> /builds/slave/test/build/mozmill/newmailaccount/test-newmailaccount.js |
> test-newmailaccount.js::test_show_tos_privacy_links_for_selected_providers

This one also has not failed on my local PC somehow.
My |make mozmill| log using locally built DEBUG BUILD of C-C TB
does not have a FAIL line for this test. (going back 12 months almost.)
Assignee: nobody → hiikezoe
Attachment #8528145 - Flags: review?(mkmelin+mozilla)
The root cause of this failure was a bug in jquery.

https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=c8ffa7e7b4fc

This try consists of three changesets. attachment 8528145 [details] [diff] [review], attachment 8528147 [details] [diff] [review] and another one:
The another one is just a cleanup patch in test-newmailaccount.js so it's not related to this issue.
Anyway there was no failures for this issue!
Comment on attachment 8528145 [details] [diff] [review]
Part 1 Remove jquery methods in test-newmailaccount-helpers.js.

Review of attachment 8528145 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thx Hiro!

::: mail/test/mozmill/shared-modules/test-newmailaccount-helpers.js
@@ +79,5 @@
>               + " to be enabled");
>  }
>  
>  /* Wait for a particular element to become fully invisible.  Assumes that
>   * jQuery is available in the controller's window.

this comment should be removed now
Attachment #8528145 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 8528147 [details] [diff] [review]
Part 2: Replace fadeIn/fadeOut for #otherLandDesc with CSS animation

Review of attachment 8528147 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. But it's ridiculous to have have 4 identical copies of accountProvisioner.css. I'll file a bug about that.
Attachment #8528147 - Flags: review?(mkmelin+mozilla) → review+
carrying over review+
Attachment #8528145 - Attachment is obsolete: true
Attachment #8528601 - Flags: review+
(In reply to Magnus Melin from comment #246)
> Comment on attachment 8528147 [details] [diff] [review]
> Part 2: Replace fadeIn/fadeOut for #otherLandDesc with CSS animation
> 
> Review of attachment 8528147 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good. But it's ridiculous to have have 4 identical copies of
> accountProvisioner.css. I'll file a bug about that.

Thanks!
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/5bc3a836fbc6
https://hg.mozilla.org/comm-central/rev/6cf79524832e
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
Target Milestone: Thunderbird 38.0 → Thunderbird 37.0
Blocks: 1014609
You need to log in before you can comment on or make changes to this bug.