Closed Bug 911158 Opened 6 years ago Closed 6 years ago

Remove "URL Protocol" from FirefoxURL key by FireFox 24 Windows Installer cause jumplist pinned shortcut unuseable

Categories

(Firefox :: General, defect)

24 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox24 --- wontfix
firefox25 + verified
firefox26 + verified
firefox27 + verified
firefox-esr24 --- verified

People

(Reporter: hunreal, Assigned: bbondy)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.62 Safari/537.36

Steps to reproduce:

Installed FireFox 24 beta(1-7) on Windows 7.
1. pin URL shortcut to pinned list by click "Pin to this list" button in frequent list, or just drag and drop firefox bookmark item to jumplist.
2. Click pinned shortcut

This Bug came from Bug 882624 - Remove "URL Protocol" from FirefoxURL key


Actual results:

Windows error dialog: Unable to open this Internet Shortcut. The protocol "FirefoxURL" does not have a registered program.


Expected results:

Firefox open pinned URL shortcut
Add some picture for this problem.
http://i41.tinypic.com/nqtgsj.png
http://i39.tinypic.com/2qj9mrr.png
Blocks: 882624
Component: Untriaged → General
It works for me on both win8 and win7. We could backout that bug as a precaution. CC'ing rstrong and jimm in case they have extra ideas on the subject.
 
hunreal, have you tried uninstalling your FF23 build, and then installing a new one. Can you still reproduce it? I'm wondering if you have something else messed up in your registry.
I tried uninstall FF23 before posting this bug.

If I delete or rename "URL Protocol" value under HKEY_CLASSES_ROOT\FirefoxURL, issue reproduced. This value is not there after installed or upgraded FF24. So I have to add this value manually to make pinned shortcut works on FF 24, that's only registry difference between FF23 and 24.

I found sameone have this problem too by google, so i decide post this.
We know that MS sets those keys on earlier versions and I hate straying from what MS does due to those paths being tested less and therefore being more prone to edgecases. I would prefer if we just had the same settings as IE as applicable for the windows version.
Edit: Please try drag and drop firefox bookmark item to jumplist to pin it.
I tested pin from frequent list is working.
I confirm this bug. Reverted to 23.0.1 while this is not fixed.
Are betas or nightly builds affected?
This has also affected some, but not all, of my pinned web sites.  It appears to affect secure sites from what I have observed.  My online time sheet site gives the (Unable to open this Internet Shortcut. The protocol "FirefoxURL" does not have a registered program.) error.  I am hopeful that this will be fixed shortly.  It does work in IE, however I loathe the thought of using that program.

Using Win 7 Home
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is a partial backout of the original bug (bug 882624).
I left the param value "delete" handling in common.nsh because it's still in use in suite. I'll post a bug to fix suite after this gets reviewed.

It seems like some Home OS need the key but not Pro OS, but I'm not sure in which cases it needs the key and in which cases it doesn't.  I believe it is best to just revert back to how it worked before.
Assignee: nobody → netzen
Status: NEW → ASSIGNED
Attachment #807049 - Flags: review?(robert.bugzilla)
It's not limited to Home installations. I can reproduce this with pinned sites on Windows 7 64-bit Professional. (Upgrade installation over Firefox 23.0.1.)

Other kinds of shortcuts (desktop .url file, links in external emails), and the Frequent portion of the jump list, are not affected, only the Pinned section of the jump list.

SuMo Thread: https://support.mozilla.org/en-US/questions/967606 (problem was identified around August 10th)
I've tested on a variety of OS by the way, and each one for me doesn't need the string value.

See my previous comment:

> I'm not sure in which cases it needs the key and in which cases it doesn't. 

The proposed fix will still work no matter what the answer is.
Have you tried drag and drop item from FF bookmark menu to jumplist to pinned?

@(In reply to Brian R. Bondy [:bbondy] from comment #10)
> I've tested on a variety of OS by the way, and each one for me doesn't need
> the string value.
> 
> See my previous comment:
> 
> > I'm not sure in which cases it needs the key and in which cases it doesn't. 
> 
> The proposed fix will still work no matter what the answer is.
Yeps that's how I was testing.
Attachment #807049 - Flags: review?(robert.bugzilla) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/43b3fdb859b0
Accidentally put r=jimm but it is actually r=rstrong.
Target Milestone: --- → Firefox 27
https://hg.mozilla.org/mozilla-central/rev/43b3fdb859b0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 807049 [details] [diff] [review]
bug911158_urlprotocol.diff

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 882624
User impact if declined: Shortcut clicks can lead to class not registered error
Testing completed (on m-c, etc.): local build of installer w/ m-c
Risk to taking this patch (and alternatives if risky): Very low
String or IDL/UUID changes made by this patch: none
Attachment #807049 - Flags: approval-mozilla-beta?
Attachment #807049 - Flags: approval-mozilla-aurora?
Attachment #807049 - Flags: approval-mozilla-beta?
Attachment #807049 - Flags: approval-mozilla-beta+
Attachment #807049 - Flags: approval-mozilla-aurora?
Attachment #807049 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 923579
Duplicate of this bug: 923178
Why does 24ESR not get this bugfix?
Comment on attachment 807049 [details] [diff] [review]
bug911158_urlprotocol.diff

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
Regression on fx24.

User impact if declined: Shortcut clicks can lead to class not registered error

Fix Landed on Version: Fixed on 25+ already, original bug caused by bug 882624

Risk to taking this patch (and alternatives if risky): 
Very low

String or UUID changes made by this patch: 
None

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Attachment #807049 - Flags: approval-mozilla-esr24?
(In reply to elbart from comment #19)
> Why does 24ESR not get this bugfix?

Thanks for checking, I think it should. I requested that this be the case.
I'm not able to reproduce this issue with Firefox 24 beta 2 (or by installing 23.0.1 and upgrading it to 24 beta 2) by pinning an URL to pinned list by click "Pin to this list" button in frequent list.

Could you please give me some guidelines describing the "just drag and drop firefox bookmark item to jumplist" method?
I can't see the jumplist after I drag & drop an item from the bookmark list.

Thanks!
Flags: needinfo?(netzen)
Sorry I'm not able to reproduce myself, could someone who can reproduce try it out? I think this is the build to try with:
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-beta/win32/en-US/Firefox%20Setup%2025.0b6.exe
Flags: needinfo?(netzen)
I found this bug report after seeing the problem on Firefox 24.0 release.  After upgrading to 25.0b6 the problem for me is resolved.  Tested both with the original pinned link as created from 24.0 and then with a new pinned link created with 25.0b6.

Windows 7 x64 SP1 Enterprise

Thanks!
Thanks Peter, could you tell me if you tested via a software update or an install? I'd like to cover testing both cases.
Attachment #807049 - Flags: approval-mozilla-esr24? → approval-mozilla-esr24+
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:27.0) Gecko/20100101 Firefox/27.0

Reproduced the initial issue on Firefox 24 beta 1. Verified as fixed on Firefox 25 beta 11 (buildID: 20131022211721), Firefox 24.1.0ESR (buildID: 20131021230807), latest Aurora 26.0a2 (buildID: 20131023004005) and latest Nightly 27.0a1 (buildID: 20131023030205). This builds were fresh installed.

I also upgraded (software update on beta and betatest channel) from 24 beta 1 to 25 beta 10 and beta 11 but the issue is still present. Any thoughts on this?
Flags: needinfo?(netzen)
Sounds like there's an edge case here if you set your default within Firefox 24.
If you set your default before Firefox 24 you're fine.
If you set your default after Firefox 24 you'll be fine.

Please post a new issue for this and CC me in it, I'll take a look. 

Users that are affected by this can work around it by simply setting their default on Firefox 25.
I think it's best to fix that edge case for Firefox 26.
Flags: needinfo?(netzen)
Setting this as verified fixed. For the edge case from comment 27 and comment 28 please see bug 930539.
You need to log in before you can comment on or make changes to this bug.