Open Bug 912159 Opened 7 years ago Updated 5 months ago

[DUPE BUGS HERE] Layout of some web sites breaks if fonts are enlarged because of "minimum font size" or text zoom-in [font size increased/made bigger/larger; sites for full-page zoom only]

Categories

(Firefox :: Disability Access, defect)

defect
Not set

Tracking

()

People

(Reporter: Aleksej, Unassigned)

References

(Depends on 3 open bugs)

Details

Attachments

(1 file)

There are many bugs being filed about the layout of a website breaking (usually various elements overlapping) if the browser forces some text on the website to be larger than that with which the website has been tested, usually either when
* a minimum font size is set in Preferences/Options → Content → Advanced; or
* the user has increased it on the particular page using Text-only zoom.

These bugs are considered Tech Evangelism bugs, but as most browsers use Full-page zoom now, and text-only zoom and minimum font size are "advanced" settings, they are often just resolved INVALID.

I propose that, instead of resolving such bugs INVALID, or just leaving them untriaged, we mark them DUPLICATE of this bug.  If a bug is decided to be a valid standalone bug, it can be reopened.  The rest will point here, where the explanation and links (depends/blocks) to bugs that propose solutions are.
Duplicate of this bug: 791552
As a workaround, the "NoSquint" extension https://addons.mozilla.org/firefox/addon/nosquint/ can help somewhat.
Depends on: 143869, 481371, 535639
OS: Linux → All
Hardware: x86_64 → All
Duplicate of this bug: 791289
Duplicate of this bug: 724655
Duplicate of this bug: 911360
Users probably select a minimum font size depending on the largely constant quality of their eyes and screens. They would hence like the pixel unit to be interpreted physically, independent of OS, page or text zoom. Implementing this interpretation would enable users to remedy most layout errors by increasing page zoom, as suggested in Bug 535639, with the minor(?) drawback of repeated font re-scaling. I would welcome this solution.
Duplicate of this bug: 965766
I am having this problem as well. mail.yahoo.com is just one of many. I force the fonts to be size 17 and get overlays AND button sizes too big for the page. When I tell FF to use my font size instead of letting the site pick their sizes things get worse.
Hi,

I just started using Chrome (Google). They seem to get it right. Perhaps the FireFox team can do so as well?

George...
Summary: [DUPE BUGS HERE] Layout of some web sites breaks if fonts are enlarged because of "minimum font size" or text zoom-in [font size increased/made bigger/larger] → [DUPE BUGS HERE] Layout of some web sites breaks if fonts are enlarged because of "minimum font size" or text zoom-in [font size increased/made bigger/larger; sites for full-page zoom only]
Depends on: 816948
Duplicate of this bug: 1488293
Duplicate of this bug: 1280479
Attachment #9003994 - Attachment is patch: false
Attachment #9003994 - Flags: checkin+
You need to log in before you can comment on or make changes to this bug.