Closed Bug 913385 Opened 6 years ago Closed 6 years ago

Hardware testing app

Categories

(Firefox OS Graveyard :: Gaia, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+)

RESOLVED FIXED
1.3 Sprint 4 - 11/8
blocking-b2g 1.3+

People

(Reporter: tjao, Assigned: tjao)

References

Details

(Whiteboard: [ft:system-platform])

Attachments

(2 files, 1 obsolete file)

This app should integrates several hardware tests like:
LCD colors, Vibrator, Physical buttons, Touch screen and etc.
Please check https://etherpad.mozilla.org/gaia-manual-test-items for the complete list.

The current implementation is based on the UITest in gaia/test_apps.
Blocks: eng-mode
Attachment #800702 - Flags: review?
Attachment #800702 - Flags: review? → review?(ehung)
Thanks for the patch, but sorry I don't have time to review it this week. Since it's not an urgent patch, I will review it next week.
Comment on attachment 800702 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/11989

r=me, please follow our coding convention. Fix the following problems and r? me again. Thanks.
* no inline style
* gjslint
* add bug number on fail cases.
Attachment #800702 - Flags: review?(ehung)
Tom, you need to flag review again after your update.
Assignee: nobody → tjao
Depends on: 919364
Attachment #800702 - Flags: review?(ehung)
Comment on attachment 800702 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/11989

r=me, there are a lot details we can polish for this test app, but I think the patch is huge so I'd like to have some follow-up bugs. Good job, thanks for your excellent work.
Attachment #800702 - Flags: review?(ehung) → review+
Attachment mime type: text/plain → text/x-github-pull-request
Depends on: 929313
Depends on: 929315
Depends on: 929318
merged to gaia-master https://github.com/mozilla-b2g/gaia/commit/5cbabfd0447bae12d87fd5e520e245943f847c7e

Congrats Tom!

Though the uitest still fail, hope you can help to fix/mentor those issues seems you are quite familiar with uitest now :)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer depends on: 919364, 929313, 929315, 929318
I had to back this out since it introduced a regression in a UI test.

https://github.com/mozilla-b2g/gaia/commit/c4d56c6eeb8f2aeef7f71975683c9aca11bb17b4

You can see the output at https://travis-ci.org/mozilla-b2g/gaia/jobs/12864230#L1774
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #800702 - Attachment is obsolete: true
Attachment #820919 - Flags: review?(zcampbell)
Thanks for the comments. Because of the change of the layout, some test cases failed. So I modified the test cases to fit the new layout.

There's something weird about test_number_keyboard.py. This test failed in my local test (it's stuck when clicking on number field, keyboard not showing up) but passed on Travis. I'm still testing it.
Comment on attachment 820919 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/13024

Test changes look OK. just waiting on a Green on Travis now :)
Attachment #820919 - Flags: review?(zcampbell) → review+
Blocks: 925673
Target Milestone: --- → 1.3 Sprint 4 - 11/8
blocking-b2g: --- → 1.3+
Whiteboard: [ft:system-platform]
re-land to gaia master: https://github.com/mozilla-b2g/gaia/commit/1229ba24a5477a1ae0655b04bcae779bf3166a17
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Attachment #823235 - Flags: review?(ehung)
reopen since there is some problem on attachment 820919 [details] [review]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 823235 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/13129

follow up patch for fixing a small issues in attachment 820919 [details] [review].
Attachment #823235 - Flags: review?(ehung) → review+
(In reply to Evelyn Hung [:evelyn] from comment #15)
> Comment on attachment 823235 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/13129
> 
> follow up patch for fixing a small issues in attachment 820919 [details] [review].

land to gaia master: https://github.com/mozilla-b2g/gaia/commit/31c260b5c853fe78d6bf44c6aeec52a651c3f025
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
This bug's change made some tests in 'UI test' do not work. like 'Inser fake contacts'. Paths to files under ./data/ were not updated. By locally update the some paths, I confirmed 'Inser fake contacts' became work again.
Thanks for the comment. That's right, and I filed it as bug 931727. Because this patch is rather big (sorry my fault.) We decided to land it first and followed with several smaller bug fixes. Other bugs to be fix can be found in the dependency of bug 883714.
You need to log in before you can comment on or make changes to this bug.