Closed Bug 929318 Opened 6 years ago Closed 6 years ago

[HW test] Radio test

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+)

RESOLVED FIXED
1.3 Sprint 5 - 11/22
blocking-b2g 1.3+

People

(Reporter: tjao, Assigned: tjao)

References

Details

(Whiteboard: [ft:system-platform])

Attachments

(1 file)

We need a test display some radio information, e.g., WiFi MAC, signal strength, current network, CID/LAC, IMEI, etc.
Assignee: nobody → tjao
Blocks: 913385
No longer blocks: 913385
Blocks: eng-mode
Blocks: 925673
Target Milestone: --- → 1.3 Sprint 5 - 11/22
blocking-b2g: --- → 1.3+
Whiteboard: [ft:system-platform]
I'm almost done with this patch. But these information maybe too much to be displayed in one test. Maybe I should merge Bluetooth with WiFi because they are similar? Or just create another WiFi information test?
Attachment #832711 - Flags: review?(gasolin)
I decide to move Wi-Fi info to another bug 938966
Comment on attachment 832711 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/13727

after some quick test I found the Data sector are not update once you change the data option from quick settings menu.

Please take a look and set review again, thanks
Attachment #832711 - Flags: review?(gasolin)
Attachment #832711 - Flags: review?(gasolin)
There's a weird problem that navigator.MozMobileConnection.onvoicechange/ondatachange are not fired when I switch on/off airplane mode. I searched the code of system/statusBar and found that it used navigator.mozIccManager.oniccinfochange. Sounds weird but it works.

I know some parts of navigator.MozMobileConnection are moved to navigator.mozIccManager. Maybe that the reason.
Since it's merged, marked as fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 935424
You need to log in before you can comment on or make changes to this bug.