The default bug view has changed. See this FAQ.

Auto Cc filling for Reply isn't working if Cc email address is same like sender

RESOLVED FIXED in Thunderbird 27.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: BlackDex, Assigned: Magnus Melin)

Tracking

(Blocks: 1 bug, {regression})

24 Branch
Thunderbird 27.0
regression
Dependency tree / graph
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(thunderbird25 fixed, thunderbird26 fixed, thunderbird_esr2425+ fixed)

Details

(Whiteboard: [workaround: comment #10])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.16

Steps to reproduce:

Have my account set-up so that it will automatically fill-in/add a Cc mail address.
Click on a mail which is received.
Click on the reply button.


Actual results:

Only the To is filled in, no Cc field with the configured Cc mail address for that mail account/identity.


Expected results:

The Cc field should have been filled with the configured mail address for that specific account/identity.
Does it also fail in safe mode?
https://support.mozillamessaging.com/en-US/kb/safe-mode
(always good to test safe mode and mention it in bug report)
(Reporter)

Comment 2

4 years ago
Yes i have tested in safe mode :).

I Also just tested it with the 24.0b3 Windows build, and it also happens there.

Then i thought of something, what happens if i enter an different mail address then which is used as sender.
For example i have user@domain.com as account and enter user@domain.com as a default Cc, this won't work.
When i add user2@domain.com it does..

So somewhere there is a check to see if it matches the sender.
Maybe this can be turned on or off if with a special setting??
anything in Tools -> Error console when this happens ?
(Reporter)

Comment 4

4 years ago
Checked the Tools > Error console, also nothing.
Tested a few other versions, and for some strange reason it works only on the 17 build for me...
After that it stops working.
Tried every build since 17, including the daily 26 build.
All with a clean profile.

Am i missing some "hidden" setting?
Confirming with Thunderbird 24.0b3 build 1 on Windows XP SP3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Auto Cc filling for Reply isn't working → Auto Cc filling for Reply isn't working if Cc email address is same like sender
Doesn't happen with Thunderbird 17.0.8 on same machine -> regression.

This seems to be a regression from the fix for bug 250187. Replying to a mail runs through http://hg.mozilla.org/comm-central/annotate/24c9b80011a2/mailnews/compose/src/nsMsgCompose.cpp#l2774

A few lines below at http://hg.mozilla.org/comm-central/diff/931f0547903c/mailnews/compose/src/nsMsgCompose.cpp , the "duplicate" CC mail address get removed.

Requesting blocking-thunderbird24 because this affects many setups where people share a mail address and use the auto cc to make each other aware of replies (e.g. in voluntary organizations).
tracking-thunderbird24: --- → ?
Keywords: regression
Magnus, was this part of the change intentional?
tracking-thunderbird24: ? → ---
tracking-thunderbird_esr24: --- → ?
Flags: needinfo?(mkmelin+mozilla)
(Assignee)

Comment 8

4 years ago
No, just and overlooked edge-case.
Assignee: nobody → mkmelin+mozilla
Flags: needinfo?(mkmelin+mozilla)

Comment 9

4 years ago
Archaeopteryx [:aryx] 2013-09-17 05:47:21 PDT is correct.
>> Requesting blocking-thunderbird24 because this affects many setups where people share a mail address and use the auto cc to make each other aware of replies (e.g. in voluntary organizations).

This is important to us.  Had I known about this bug, I would not have installed Tbird 24.0 for our group.

Comment 10

4 years ago
It appears that only the "Cc" field is affected, not though the "Bcc" entry. Switching the checkboxes in the Copies & Folders Account Settings and making my own address "Bcc" to works on a reply, whereas using the "Cc" version fails to fill it in. So, this might serve as a suitable workaround for the time being.
Whiteboard: [workaround: comment #10]

Comment 11

4 years ago
Possible work around?

Enter your address in the Settings menu, as a cc with a different case.
instead of abc@sample.com use ABC@sample.com

Uses one Thunderbird bug to compensate for another :-)

IMO, it is a bug that TBird considers emails with a different case to be different email addresses, but that bug is useful here !
(Assignee)

Comment 12

4 years ago
FWIW, i think i have fixed this locally. Still need to test, write tests, and clean it up.
(Assignee)

Comment 13

4 years ago
Created attachment 814497 [details] [diff] [review]
proposed fix

This fixes it, and cleans things up a bit + tests for auto-cc.
I resisted cleaning up the prevalent if(mIdentity) nonsense for now...
Attachment #814497 - Flags: review?(mbanner)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Comment 14

4 years ago
Successful try @ https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=efdb816dd464
Comment on attachment 814497 [details] [diff] [review]
proposed fix

Review of attachment 814497 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=Standard8
Attachment #814497 - Flags: review?(mbanner) → review+
Pushed to trunk to get landed for branches:

https://hg.mozilla.org/comm-central/rev/e44c6f5273a0
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 27.0
Attachment #814497 - Flags: approval-comm-beta+
Attachment #814497 - Flags: approval-comm-aurora+
Attachment #814497 - Flags: approval-comm-esr24?
https://hg.mozilla.org/releases/comm-aurora/rev/2aff7e8d1d0a
https://hg.mozilla.org/releases/comm-beta/rev/cf3890521f2b
status-thunderbird25: --- → fixed
status-thunderbird26: --- → fixed
tracking-thunderbird_esr24: ? → 25+
(Assignee)

Updated

4 years ago
Duplicate of this bug: 923759
(Assignee)

Updated

4 years ago
Blocks: 250187
Flags: in-testsuite+

Comment 19

4 years ago
See also Bug 759018, which explains the problems with Reply-All in terms of sorting out the To: and Cc: lines.  Truly a problem with TB that I still need to fix with EVERY E-mail I send.  Honestly, I don't care about the IDN E-mail addresses and all the other stuff that gets added.  This To/Cc rewriting (as I explained in Bug 759018, also known as Eudora style) is the MOST IMPORTANT feature to me because I need to workaround this on EVERY E-mail.
Attachment #814497 - Flags: approval-comm-esr24? → approval-comm-esr24+
https://hg.mozilla.org/releases/comm-esr24/rev/abcc755bafd9
status-thunderbird_esr24: --- → fixed
Duplicate of this bug: 928129
It's great that this will be going out, because I'm sure many enterprisy folks use this.
Blocks: 564148
(Assignee)

Updated

3 years ago
Depends on: 933555
You need to log in before you can comment on or make changes to this bug.