Unable to scroll PDF document via touch in metro firefox

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: jbecerra, Unassigned)

Tracking

Trunk
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-integration])

(Reporter)

Description

5 years ago
Tested on 2013-09-30 with latest nightly. While testing bug 919303 I noticed that I wasn't able to touch scroll in a PDF document, the way you can touch scroll a web page.

You can use the arrow keys on your keyboard, or touch on the content to bring up the scrollers where you can type and scroll, but that's not as intuitive.

Steps:
1. In Metro Firefox go to http://www.irs.gov/pub/irs-pdf/f1040ez.pdf
2. Try to scroll down with touch scrolling

Expected: You can scroll down using touch.

Actual: You are not able to scroll down using touch, except by tapping on the scroll bars.

Compare this to the desktop version where you can do this without a problem.

Comment 1

5 years ago
This is known. I proposed long ago that we disable PDF.js in Metro and let the capable Windows 8 viewer app handle them. I think we need to do that, at least for the initial release. I believe we have a bug on file.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859579

Updated

5 years ago
Status: RESOLVED → REOPENED
Component: General → PDF Viewer
Product: Firefox for Metro → Firefox
Resolution: DUPLICATE → ---
Summary: defect - unable to scroll PDF with touch → Unable to scroll PDF document via touch in metro firefox

Comment 3

5 years ago
See bug 859579 for enabling to test in local/try builds.
Blocks: 923594

Updated

5 years ago
OS: Windows 8 Metro → Windows 8.1
Juan, are you able to reproduce on our viewer web page at http://mozilla.github.io/pdf.js/web/viewer.html ?
Flags: needinfo?(jbecerra)
Whiteboard: [pdfjs-c-integration]

Comment 5

5 years ago
(In reply to Brendan Dahl [:bdahl] from comment #4)
> Juan, are you able to reproduce on our viewer web page at
> http://mozilla.github.io/pdf.js/web/viewer.html ?

Hard to say, the document erases when you try to scroll via touch. The UI is still visible though. Probably an interaction problem with apzc scrolling.

Comment 6

5 years ago
(In reply to Jim Mathies [:jimm] from comment #5)
> (In reply to Brendan Dahl [:bdahl] from comment #4)
> > Juan, are you able to reproduce on our viewer web page at
> > http://mozilla.github.io/pdf.js/web/viewer.html ?
> 
> Hard to say, the document erases when you try to scroll via touch. The UI is
> still visible though. Probably an interaction problem with apzc scrolling.

The scroll thumb is there and doesn't move, so I'd say it's likely scrolling it isn't working yet.
(Reporter)

Updated

4 years ago
Flags: needinfo?(jbecerra)
Metrofx is no more, and scrolling PDF.js via touch works fine if APZ/touch is enabled (as it is on nightly if e10s is force-enabled). There is an outstanding issue with scrolling in presentation mode via touch which is tracked over in bug 1300878.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.