Closed Bug 922658 Opened 6 years ago Closed 6 years ago

[Settings] Lazy load subpanels

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 973432

People

(Reporter: vingtetun, Assigned: kgrandon)

References

Details

(Keywords: perf, Whiteboard: [c=progress p= s=2014.06.06.t u=])

With bug 920623 the transition in the settings apps are coming back, but currently in settings when a panel is opened all subpanels are loaded at the same time. It ends up beeing very heavy and prevent the animation happens the first time it is opened and it also ends up consuming unuseful resources since some panels may never be used.

So changing the current panel loading logic to load one panel at a time and don't load the subpanels until the user try to access it should make the situation much better.
Most panels put the logic of sub panels in one script file. We should also separate the scripts and lazy load/execute them.
Keywords: perf
Whiteboard: [c= p= s= u=]
I'll take this one. Seems like it may be a non-trivial amount of work to split up all of the panels, so I may end up turning this into a meta bug and opening a bug for each panel.
Assignee: nobody → kgrandon
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Depends on: 929813
Depends on: 930404
Depends on: 930405
Depends on: 930406
Blocks: 924409
Depends on: 931430
Depends on: 931742
Depends on: 937768
Whiteboard: [c= p= s= u=] → [c= p= s= u=][ucid:SystemPlatform30, 1.4:p2, ft:system-platform]
Depends on: 957913
Depends on: 964180
Remove whiteboard keyword for user story since we no longer use this one for settings app refactoring. Please refer to bug 969265 for more detail
Whiteboard: [c= p= s= u=][ucid:SystemPlatform30, 1.4:p2, ft:system-platform] → [c= p= s= u=]
No longer blocks: 1.4-system-platform
Whiteboard: [c= p= s= u=] → [c=progress p= s= u=]
Settings is being handled differently now, so we should be good.
No longer blocks: 924409
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 973432
Whiteboard: [c=progress p= s= u=] → [c=progress p= s=2014.06.06.t u=]
You need to log in before you can comment on or make changes to this bug.