Setup should remember installation options between installs

RESOLVED WONTFIX

Status

SeaMonkey
Installer
--
enhancement
RESOLVED WONTFIX
17 years ago
7 years ago

People

(Reporter: Jeffrey Drake, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
First note this isn't #43595, that was to do with the same install this being
different.

I like to update my mozilla every day to every couple days, and it would be a
huge convenience if I didn't have to reselect my installation options every time
I goto reinstall it. I think a solution to this would be to store a copy of the
installation options and use that as the default options the next time the
installation program is ran.
marking NEW

Reporter: 
Workaround: You can use the .zip build and create a batch file 
(This is very easy: delete the old build directory, unzip via command-line
unzip, copy the plugins in the plugin directory)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Setup should remember installation options between installs → [RFE]Setup should remember installation options between installs

Comment 2

17 years ago
good point. I always use HTTP as the download protocol and have to select it 
every time.
Perhaps we(Sean) could just save some of the options in the reg.db.

Comment 3

17 years ago
There is already a solution for remembering a particular installation "profile".  
The installers (specially the win32 version) was designed to be automatable.

all you have to do is:

1) create a .ini file with the changes/settings that you want to have.  As an 
example, lets set the default of the download protocol from FTP to HTTP.  So 
create a try.ini file in an empty dir with the following:

  [Dialog Advanced Settings]
  Use Protocol=HTTP

2) from this now not empty dir, run: mozilla-win32-installer.exe -u

3) run the attached initool.exe as follow:

  initool.exe try.ini config.ini

What this will do is apply the settings from try.ini to config.ini.  initool.exe 
is a simple app that just reads all the sections and keys from try.ini and 
overwrites/creates it in config.ini.

4) from this dir, run setup.exe.  Advance to the dialog where you normally would 
change the download protocol from FTP to HTTP.  HTTP should be the default now.

Take a look at config.ini.  There are settings that are obvious as to what they 
will affect.  If you have any specific changes that you want to make, feel free 
to ask me or post to the netscape.public.mozilla.xpinstall newsgroup.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 4

17 years ago
Created attachment 43644 [details]
app to aid in automating the win32 installer.

Comment 5

17 years ago
If you want to run setup.exe in an hands free mode, you can do:
  setup.exe -ma

-ma stands for Mode Auto, which means that it will only show the dialogs that do 
not require user intervention.  For a list of all the command line options, run:
  setup.exe -? (or mozilla-win32-installer.exe -?)

Comment 6

17 years ago
ok...
a bit annoying that you cant always use the same config.ini file to just 
downloade the test browser. The config.ini has both the useragent and download 
path in it.

Sometimes it could be nice if the installer just always downloaded the *latest* 
mozilla browser.
Status: RESOLVED → VERIFIED

Comment 7

17 years ago
That's not possible because the "latest" path on ftp.mozilla.org does not 
contain a xpi subdir.  If it did, all you have to do is have the try.ini also 
contain:

  [Site Selector]
  Domain0=ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/xpi
*** Bug 103136 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
shouldn't this be relnoted?

Comment 10

17 years ago
*** Bug 114894 has been marked as a duplicate of this bug. ***
*** Bug 138956 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
I tried to work out the "work around" for this bug. Thanks to Sean Su for
helping. I made this a web page (I hope this is useful to people who read this
bug): http://piology.org/mozilla/of-the-day.html

There are still some open problems (please e-mail me if you have suggestions).
And it is not trivial to set this up for most people. Even then this is very
limited. Using this:

Actual results:
Installing over an existing version is troublesome. You still have to do some
work to get it going.

Expected result:
Like most other installation program for Windows you should be able to install a
new version (including nightlies) *over* an existing version, thereby keeping
all properties.

So I suggest to REOPEN this bug. Better Target=Future than simply ignoring the
need for this.

pi

Comment 13

16 years ago
*** Bug 144952 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 145026 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 212836 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

12 years ago
Duplicate of this bug: 168239

Comment 17

12 years ago
REOPENing due to yet another dupe which was open. Over the years SeaMonkey has received more users which are less computer literate. They really have a hard time. Upgrading should be as easy as one click.

pi
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---

Comment 18

12 years ago
this is reopen?? i do not think so this is new path of old bug with new defined attack methods. If you want to check this try new system from start otherewise this gonna give us big trouble. WE HAVE TO MAKE THIS BUG CONVERT WITH OUR REFERENCE TO USE AS OUR TOOL FOR SECURITY. 
Sean,
Are you still working on this ?
QA Contact: bugzilla → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old
bug, please reopen if you still get this with the new installer

and we have an automatic update...
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago10 years ago
Resolution: --- → WONTFIX

Comment 21

10 years ago
> please reopen if you still get this with the new installer

I think you'd meant to resolve this as FIXED, not WONTFIX.  In any case, it's still not working.

I installed a 2/15 build.  The optional components were all checked, so I unchecked all but "Debug and QA UI".  Later on in the install wizard, all 3 create icons options were checked - I unchecked them all.

After the installation, I ran it again.  There was no difference in what was selected.  It did not remember my previous options and retain them for me so that I could just click on Next through the wizard - instead I had to uncheck everything again.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Status: REOPENED → NEW
QA Contact: installer → xpi-packages
Summary: [RFE]Setup should remember installation options between installs → Setup should remember installation options between installs

Updated

8 years ago
Assignee: ssu0262 → installer

Comment 22

8 years ago
The SeaMonkey team will not spend time on this specifically.
Status: NEW → RESOLVED
Last Resolved: 10 years ago8 years ago
Resolution: --- → WONTFIX

Comment 23

8 years ago
Agreed. Actually both SM and FF already preserve all settings when upgrade installation is being performed. Also an Update feature works fine.

Comment 24

8 years ago
> already preserve all settings

Settings, perhaps, but not installation options.  Every time I install, I have to deselect all but the QA/Debug menu from those things I want to install.
You need to log in before you can comment on or make changes to this bug.