Closed Bug 9240 Opened 21 years ago Closed 20 years ago

[FEATURE] Appearance | Fonts prefs

Categories

(SeaMonkey :: Preferences, defect, P1, blocker)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: erik, Assigned: matt)

References

Details

The font prefs panel needs to be completed. It needs to call the nsIPref APIs
to set the font prefs. Font prefs UE to be based on 4.X, with some minor
changes, to be discussed with me (erik@netscape.com).
Blocks: 7586
Priority: P3 → P1
Summary: preferences - appearance | fonts to be completed → [FEATURE] preferences - appearance | fonts to be completed
Target Milestone: M9
Matt, how much work is this?  Is it possible to do in M9?
Blocks: 10575
Status: NEW → ASSIGNED
Target Milestone: M9 → M10
Won't get in for m9
Blocks: 11439
Adding to 11439 dependency tree.
Summary: [FEATURE] preferences - appearance | fonts to be completed → [FEATURE] Appearance | Fonts prefs
Whiteboard: Need to be completed
Severity: normal → blocker
marking as blocker per jevering, I18N needs it.
Matt, can you actually get this done for M10?
Blocks: 12656
Depends on: 8801
waiting on internationalization
Target Milestone: M10 → M11
Whiteboard: Need to be completed → Waiting on erik to fix bug #8801
Blocks: 14744
*** Bug 15962 has been marked as a duplicate of this bug. ***
Target Milestone: M11 → M12
Blocks: 20870
FYI, Matt really, really wants to get this into M12.
Target Milestone: M12 → M13
Moving off to M13.
I've been following this bug for some time -- it's the main reason I'm using
NS 4.7 rather than Mozilla -- and was pleased that it was marked as a "blocker"
for M12.  It's rather irksome that this label is apparently arbitrary.
Blocks: 21564
Blocks: 22176
*** Bug 18393 has been marked as a duplicate of this bug. ***
QA Contact: cpratt → sairuh
reassiging qa contact to me...
No longer blocks: 10575
No longer blocks: 12656
Blocks: 24206
Whiteboard: Waiting on erik to fix bug #8801
Cleared Status Whiteboard since bug 8801 has been fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed, filing a new bug for the slow refresh.
okay, this panel has been completed, so verifying as such. individual bugs
pertaining to Appearance > Fonts can be [and have been] filed separately.
Status: RESOLVED → VERIFIED
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
No longer blocks: 20870
No longer blocks: 21564
No longer blocks: 22176
No longer blocks: 24206
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.