[BETA] [FEATURE] font prefs: work with owner to finalize spec and impl

VERIFIED FIXED in M13

Status

SeaMonkey
Preferences
P2
major
VERIFIED FIXED
18 years ago
12 years ago

People

(Reporter: Erik van der Poel, Assigned: Erik van der Poel)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

18 years ago
Figure out who owns the font picker, and work with that person to finalize the
spec and get it implemented, with all I18N issues in mind.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 1

18 years ago
That would be Eric Vaughan, evaughan
(Assignee)

Updated

18 years ago
Summary: font picker: work with owner to finalize spec and impl → font prefs: work with owner to finalize spec and impl
(Assignee)

Comment 2

18 years ago
Sorry, when I saw the term "font picker" in XPToolkit docs, I assumed it was
talking about the font prefs dialog under Edit.Preferences. In this bug report,
I'm really referring to the font prefs, so I've changed the Summary above. The
front end of the prefs is owned by Matt Fisher.
(Assignee)

Updated

18 years ago
Target Milestone: M10 → M9
(Assignee)

Comment 3

18 years ago
Matt said he'd do font prefs by M9, so marking this M9.
(Assignee)

Updated

18 years ago
Blocks: 9332
(Assignee)

Updated

18 years ago
Target Milestone: M9 → M10
(Assignee)

Updated

18 years ago
Target Milestone: M10 → M11
(Assignee)

Comment 4

18 years ago
Won't make M10, marking M11.

Updated

18 years ago
Blocks: 6827

Updated

18 years ago
Blocks: 9240

Updated

18 years ago
Blocks: 13465

Comment 5

18 years ago
trudell told me they will drop font selector widget (which have both font face
selection and size selection in one widget) for M11. I told him it is ok since
we can use font face selection widget + a size menu to work around.
(Assignee)

Updated

18 years ago
Target Milestone: M11 → M12

Updated

18 years ago
Blocks: 14744
(Assignee)

Updated

18 years ago
No longer blocks: 14744

Updated

18 years ago
Blocks: 16950
(Assignee)

Updated

18 years ago
Severity: normal → major
Priority: P3 → P2
Target Milestone: M12 → M11

Updated

18 years ago
Blocks: 17432
(Assignee)

Updated

18 years ago
Target Milestone: M11 → M12

Updated

18 years ago
Blocks: 17907

Updated

18 years ago
Blocks: 18471

Updated

18 years ago
Blocks: 18951

Updated

18 years ago
Blocks: 20203

Updated

18 years ago
Summary: font prefs: work with owner to finalize spec and impl → [BETA] font prefs: work with owner to finalize spec and impl

Updated

18 years ago
Blocks: 7586
(Assignee)

Updated

18 years ago
Blocks: 15989
I tried hooking up something like this the other day, for fun. I used
nsIFontEnumerator. Unfortunately, I have 388 fonts (not really that many, but
still quite a lot of DOM appends to be doing on a select widget) and it hung
mozilla every time I tried to load the font list -_-

Some people say that we need a "modern" font picking system like that
recommended at verso.com (can't remember the url, braden@endoframe.com has it)
- one that lets you pick default serif, sans-serif, monospace, fantasy, dingbats
etc.

Comment 7

18 years ago
i have the font panel in my tree with
the fontenumerator pretty much working.
I was going to try to check it in today
but i got a damn pdt+ treewidget bug.
(Assignee)

Comment 8

18 years ago
rgoodger, the font prefs panel that Matt is working on will have all of the CSS
generic fonts (serif, sans-serif, monospace, cursive and fantasy).

Matt, it's good to hear that you got it pretty much working. I hope you got my
email about the font pref name change. The naming scheme that I am using in the
backend code that has already been checked in is:

  user_pref("font.name.serif.x-western", "Times New Roman");
  user_pref("font.size.monospace.ja", 10);

However, the backend code does not currently dynamically update the fonts when
the prefs change. You need to quit the browser, and re-start, to take effect.
(Assignee)

Comment 9

18 years ago
*** Bug 7586 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
Need to add default fonts to the default prefs file for each platform.
(Assignee)

Comment 11

18 years ago
*** Bug 19486 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
checkin log show erik has checked in a fix for this in
nsPresContext.cpp

marking fixed to get on the testing radar.

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 13

18 years ago
Reopened.
This bug is not completely fixed.  There is additional work needed to
complete this feature.  Erik (and Frank for Mac) have incrementally
checked in parts to allow QA to test parts and to provide the pieces
needed to hook up the XUL pref dialog work that Matt is working on.

Updated

18 years ago
Resolution: FIXED → ---

Updated

18 years ago
Status: REOPENED → ASSIGNED

Updated

18 years ago
Target Milestone: M12 → M13

Comment 14

18 years ago
moving the rest of the work off to m13.

Updated

18 years ago
Blocks: 21564
(Assignee)

Comment 15

18 years ago
Montse, could you let me know which font names are used for the default fonts
in the various localized versions of Communicator 4.X? Thanks!
(Assignee)

Comment 16

18 years ago
Created attachment 3545 [details] [diff] [review]
Patch to get Mozilla to update font prefs dynamically.
(Assignee)

Comment 17

18 years ago
Matt, I just attached a patch to this bug to get Mozilla to update font prefs
dynamically. So, to test your font prefs dialog in XUL/JS, you can use this
patch in your local tree, and make sure that the fonts change when you hit the
OK button in prefs. I tried it already, and it sorta works, but there is a bug
in the layout engine where the new fonts are not immediately displayed, and you
need to hide and show the window. It also doesn't relayout properly until you
do View.Reload. Anyway, this patch may help you test your XUL/JS while I'm on
vacation 12/18 to 1/5.
(Assignee)

Comment 18

18 years ago
Created attachment 3546 [details] [diff] [review]
Patch to get font prefs to work on Unix.
(Assignee)

Comment 19

18 years ago
All, I just attached a patch to get font prefs to work on Unix. If anybody
wants to test font prefs on Unix while I'm on vacation 12/18 to 1/5, please
apply this patch to your local tree.

Updated

18 years ago
Blocks: 22176

Updated

18 years ago
Summary: [BETA] font prefs: work with owner to finalize spec and impl → [BETA] [FEATURE] font prefs: work with owner to finalize spec and impl

Updated

18 years ago
No longer blocks: 13465
QA Contact: cpratt → sairuh
spam: in my testing realm, so reassigning qa contact to me, en masse.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

18 years ago
Created bug 24172 for adding default font names to default pref files. Closing
this bug for M13. If there are any specific bugs in this feature, please open
separate bug reports.
(Assignee)

Updated

18 years ago
No longer blocks: 7586
(Assignee)

Updated

18 years ago
No longer blocks: 9332
verif.
Status: RESOLVED → VERIFIED

Comment 23

17 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences

Updated

17 years ago
No longer blocks: 17432

Updated

17 years ago
No longer blocks: 17907

Updated

17 years ago
No longer blocks: 18471

Updated

17 years ago
No longer blocks: 18951

Updated

17 years ago
No longer blocks: 20203

Updated

17 years ago
No longer blocks: 21564

Updated

17 years ago
No longer blocks: 22176
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.