Closed Bug 929279 Opened 6 years ago Closed 6 years ago

Starred messages (with black star) much harder to see in Thunderbird 24

Categories

(Thunderbird :: Theme, defect)

24 Branch
x86
macOS
defect
Not set

Tracking

(thunderbird28 fixed, thunderbird29 fixed, thunderbird_esr2428+ fixed)

RESOLVED FIXED
Thunderbird 29.0
Tracking Status
thunderbird28 --- fixed
thunderbird29 --- fixed
thunderbird_esr24 28+ fixed

People

(Reporter: davidfstr, Assigned: Paenglab)

References

()

Details

(Keywords: regression, Whiteboard: [regression:TB22][gs])

Attachments

(3 files, 2 obsolete files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/536.30.1 (KHTML, like Gecko) Version/6.0.5 Safari/536.30.1

Steps to reproduce:

Star a message.


Actual results:

A black star appears by the message. It is difficult to distinguish from the new-message indicater and medium black dots that appear when there is no star.

This new behavior first observed in Thunderbird 24.0.1. Screenshot attached.


Expected results:

A yellow or other kind of distinct colored star appears by the message. The additional color serves to make the star stand out from the new-message and no-star states.

This old behavior last observed in Thunderbird 17.0.8. Screenshot attached.

At that time there was actually call for *more* constrast in bug 764348, not less.
Do you see this also in safe mode?
https://support.mozillamessaging.com/en-US/kb/safe-mode
Flags: needinfo?(davidfstr)
Keywords: regression
I've said it before, and I'll say it again: grayscale icons are perfectly fine for things that don't move around much (e.g. toolbar buttons), but for things whose position varies or which represent state, we should use color. If we do it that way, the color actually stands out and lets people identify things more quickly. Star icons in the thread pane are a good example of this.
(In reply to Wayne Mery (:wsmwk) from comment #1)
> Do you see this also in safe mode?
> https://support.mozillamessaging.com/en-US/kb/safe-mode

Yes this issue is present in safe mode too.
I failed to mention that I searched last 8 months of fixed and open bug reports, and didn't find what might have affected this.
Confirmed that this issue is present in safe mode.

This issue is present on a fresh install of Thunderbird 24.1.1 in a clean OS X 10.7.5 VM. I just checked.
Flags: needinfo?(davidfstr)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [regression:TB2??]
Whiteboard: [regression:TB2??] → [regression:TB2??][gs]
Best guess for regression cause: bug 781333
http://hg.mozilla.org/comm-central/rev/5a0c56e7e9a7#l47.137

this patch switched the dedicated flaggedmail.png icon with the monochrome column version of threadpane-col.png, thus apparently causing the change in style.
The monochrome icons have been introduced by bug 781333.
Blocks: 781333
Whiteboard: [regression:TB2??][gs] → [regression:TB22][gs]
Attached patch Give back the yellow star (obsolete) β€” β€” Splinter Review
This patch gives the yellow star back on normal Mac and on Retina Mac.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8351552 - Flags: ui-review?(josiah)
Attachment #8351552 - Flags: review?(josiah)
Josiah, what do you think, should I also add the orange Junk icon instead of the monochrome? Then Junk is also better identifiable. This could then fix also bug 845377.
This one adds a orange Junk icon like we have for Windows and Linux.

I'll let you decide through ui-r+ and - which one should be used.
Attachment #8351633 - Flags: ui-review?(josiah)
Attachment #8351633 - Flags: review?(josiah)
Comment on attachment 8351633 [details] [diff] [review]
Give back the yellow star and make Junk orange

Review of attachment 8351633 [details] [diff] [review]:
-----------------------------------------------------------------

So I'm fine with the colored icons actually and I think we should color the junk icon too. However, the star icon when not in retina mode looks a little fuzzy and doesn't look as sharp as I'd like it to be. If possible, we should try to clean it up a bit. r+, but ui-r- because of the start icon.

However, I understand it's possible we can't really fix it, and since we like a designer, we may have to land it as-is.
Attachment #8351633 - Flags: ui-review?(josiah)
Attachment #8351633 - Flags: ui-review-
Attachment #8351633 - Flags: review?(josiah)
Attachment #8351633 - Flags: review+
Comment on attachment 8351552 [details] [diff] [review]
Give back the yellow star

Review of attachment 8351552 [details] [diff] [review]:
-----------------------------------------------------------------

Let's use the other patch.
Attachment #8351552 - Flags: ui-review?(josiah)
Attachment #8351552 - Flags: review?(josiah)
Attached patch New patch β€” β€” Splinter Review
As I remember I used the star from flag-col.png. Now I scaled the flaggedmail.png star down and this looks better. I also added a new flag-col.png which should look sharper.
Attachment #8351552 - Attachment is obsolete: true
Attachment #8351633 - Attachment is obsolete: true
Attachment #8356167 - Flags: ui-review?(josiah)
Attachment #8356167 - Flags: review+
Comment on attachment 8356167 [details] [diff] [review]
New patch

Review of attachment 8356167 [details] [diff] [review]:
-----------------------------------------------------------------

That looks a lot nicer, yes. Thanks!
Attachment #8356167 - Flags: ui-review?(josiah) → ui-review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/ffe3d8c378ad
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
This is wanted on the branches, I'd assume. Are you going to set the respective requests?
Ping for requesting approval-comm-esr24 per recent http://gsfn.us/t/49vmi comment, or does this not qualify for the branches?
Flags: needinfo?(richard.marti)
Comment on attachment 8356167 [details] [diff] [review]
New patch

[Approval Request Comment]
User impact if declined: It's harder for the user to see the starred and junk messages.
Testing completed (on c-c, etc.): On c-c since a month.
Risk to taking this patch (and alternatives if risky): Low, only CSS and image change.
Attachment #8356167 - Flags: approval-comm-esr24?
Attachment #8356167 - Flags: approval-comm-beta?
Attachment #8356167 - Flags: approval-comm-aurora?
Flags: needinfo?(richard.marti)
Comment on attachment 8356167 [details] [diff] [review]
New patch

This is only needed on beta and esr24, it implicitly landed on aurora with the last merge = https://hg.mozilla.org/releases/comm-aurora/rev/ffe3d8c378ad
Attachment #8356167 - Flags: approval-comm-aurora?
Attachment #8356167 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #8356167 - Flags: approval-comm-esr24? → approval-comm-esr24+
You need to log in before you can comment on or make changes to this bug.