Closed Bug 938039 Opened 8 years ago Closed 7 years ago

[Keyboard][Zhuyin][TW] Add more punctuation marks to Zhuyin Keyboard

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1019472

People

(Reporter: petercpg, Unassigned, Mentored)

References

Details

(Whiteboard: [mentor-lang=zh][lang=js])

In Bug 908577 we finally got a wonderful Zhuyin Keyboard for FxOS which fulfills the need of inputting Trad Chinese using Bopomofo. 

However, the current implementation contains only couple of punctuation symbols (comma, period, ellipsis) and four tonal marks. We should definitely support more punctuation marks (and maybe some more symbols/emoji?) for the daily communication use.
Adding David to this discussion
Hi Peter,
I like to work on this bug.Can you assign this to me? Is it necessary to know this language(perhaps chinese..)? Can you provide those puntuation marks and symbols?
Thanks
Flags: needinfo?(petercpg)
Hi Kumar, you do need to know the language in order to know which symbol to put into the codebase. It would take some time to sort this out so you might want to move to other mentor bug first :)

It is unclear to me whether or not the localizer (Peter) or Mozilla UX working on Keyboard (Carrie) to produce the spec of Traditional Chinese Zhuyin layout & symbol layout, given the current support status of this feature (read: community supported, not shipped in any release).

How about Peter to produce a recommendation and Carrie to give it a look and maybe do a rubber-stamp review?
Assignee: nobody → rishav006
Flags: needinfo?(cawang)
Whiteboard: [mentor=timdream][mentor=rudyl][mentor-lang=zh] → [mentor=timdream][mentor=rudyl][mentor-lang=zh][lang=js]
Tim, Kumar,

Unfortunately I'm quite busy before lunar new year... Is there any sample/templates of Keyboard spec so maybe we can probably let fellows at MozTW to finish the non-coding works?
(I've read https://wiki.mozilla.org/Gaia/System/Keyboard but it seems doesn't help for Chinese Keyboard)

Thanks :)
Flags: needinfo?(petercpg)
Hi Tim, 

We've got some idea on this and are very willing to help for the Zhuyin kb improvement. 
Omega will take care of this and produce a layout spec. Thanks!
Flags: needinfo?(cawang)
Hi Tim,
Is Zhuyin kb layout is available now?
Thanks
Hi Carrie,

Do we have the layout spec ready so Kumar could follow-up? Do we need to invite Taiwanese community for the layout spec work to offload us? Thanks!
Flags: needinfo?(cawang)
Hey Tim, 

We've got some materials to share on this one. We'll sync with you guys next week when we back from SFO.
Thanks!
Flags: needinfo?(cawang)
Hi all,
Any Update on this ?
Thanks
Carrie, can you provide the specs for Kumar to work on?
Flags: needinfo?(cawang)
Omega is in charge of this. ni? him for the spec. Thanks!
Flags: needinfo?(cawang) → needinfo?(ofeng)
Assignee: rishav006 → nobody
Hi Tim
I am unassigning this bug.If anybody want,they can take it.I think i am not the right person to work on this.Also i will be busy in coming days.
Thanks
That's ok. Thank you for your interest.
See bug 983043 for the UX spec update.
Flags: needinfo?(ofeng)
Mentor: timdream rlu
Mentor: rlu, timdream
Whiteboard: [mentor=timdream][mentor=rudyl][mentor-lang=zh][lang=js] → [mentor-lang=zh][lang=js]
Mentor: rlu, timdream
It would be a great pleasure for me to work on this bug. But I am unable to understand what kind of punctuantion marks need to be added. Can anyone provide me any info? Asking needinfo from mentors.
Flags: needinfo?(timdream)
Flags: needinfo?(rlu)
Comment 15 links to https://bug983043.bugzilla.mozilla.org/attachment.cgi?id=8454327#20 and ask the Zhuyin use the symbol panel somewhere similar to Pinyin, don in bug 900907.

You can looks at the code first and see if you can take the bug. Thanks!
Flags: needinfo?(timdream)
Flags: needinfo?(rlu)
Sorry, the correct bug to link on previous comment was bug 1021505.
Thanks :timdream for your info. Currently I am cloning gaia. I Will build for flame to test what needs to be fixed. Then start working on it. For this reason I need some time. Cause, I net connections is kinda slow & unstable.
(In reply to Rabbi Hossain from comment #19)
> Thanks :timdream for your info. Currently I am cloning gaia. I Will build
> for flame to test what needs to be fixed. Then start working on it. For this
> reason I need some time. Cause, I net connections is kinda slow & unstable.

This is a Gaia only bug, it's unlikely you need to build the entire phone just to update the keyboard app.

To work and try on the Desktop only without a phone, you can download B2G Desktop only and create a Gaia profile to run on it. Simply clone Gaia, and run

$ make b2g
$ make

The profile will be in ./profile, and the runtime should be available somewhere in ./b2g, depend on the OS. Run it with

$ ./b2g -profile $GAIA/profile

If you phone is already updated with the latest B2G build, you can update the keyboard packaged app only from your working directory by running

$ APP=keyboard make install-gaia
Duping this bug to the one with activity: bug 1019472
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1019472
You need to log in before you can comment on or make changes to this bug.