Closed Bug 939832 Opened 6 years ago Closed 6 years ago

[tracker] Simplify and focus localization dashboard

Categories

(support.mozilla.org :: Knowledge Base Software, task, P2)

Tracking

(Not tracked)

RESOLVED FIXED
2013Q4

People

(Reporter: atopal, Unassigned)

References

Details

Attachments

(2 files)

I as a localizer want to know what are the most impactful articles to translate so that I can get them done first and help more people.

To that end we should simplify the contributor dashboard that today fill several pages when printed out. The proposal:

* Have a tabbed interface that is divided between Localization and Review.
* On the Localization tab show most visited 20 articles that need attention right now. 
* Get rid of separate Untranslated, Immediate Updates Needed, Updates Needed and Navigation Articles
* Add link below most visited 20 articles that need attention to link to all articles list.

Mockup coming up.
Attached image localization dashboard
Several things to point out here:

* We have a product selector on top. Might be necessary to use a slider to fit all products
* There should be an "All products" tab
* There should be a "Firefox" tab, that combines Firefox for desktop, Android and OS.
* We don't have navigation articles in the overview anymore
* We have a tabbed interface to separate localization and review workflows.
* The localization tabs holds the most visited 20 articles that need attention.
** This is a copy of of the view at localization/most-visited-translations with the difference that we only show things that need attention, not those that are green.
* The link below Needs Attention leads to localization/most-visited-translations
One more thing: "templates" from the overview should link to localization/template-translations There doesn't seem to be a good way to sort templates, so showing 10 sorted alphabetically doesn't make much sense.

Rosana, does the mockup and text match what we discussed last week? If yes, let's open this up for discussion.
Flags: needinfo?(rardila)
This is a pretty big change. On the plus side, it should allow us to delete a lot of code and simplify things.

I'm making this a tracker to separate out into 2-3 bugs.
Summary: Simplify and focus localization dashboard → [tracker] Simplify and focus localization dashboard
Exciting!!!

One question: what's the point of having a big product selector instead of something a little bit more streamlined as a radio button? The core of this page are the articles, using too much space for the selector feels counter-productive.
This is a tracker, removing sprint info. We need to file the blockers.
Whiteboard: u=contributor c=wiki p= s=2013.24
Ibai,

I think that the current drop down wasn't really broadly understood. I agree with you that the space the product selector takes in the mock up is too much. Bu t I think we need a solution that is a bit more visual. The best solution would be to have a smaller product picker or a radio button with the small logos.

- Rosana
Flags: needinfo?(rardila)
Kadir, I think the text explains well what we talked about, but maybe we need to update the mockup. Also the discussions around how to present the templates under their corresponding articles is interesting from a UX perspective.

As we will be keeping the pages with the lists (all articles, need review, templates, etc.) I think that we also need to figure out how we will display it on the dashboard. We can make them clickable but I'm not sure they would be "discoverable" enough. We have some great features at SUMO that aren't that easy to discover (like the product dashboards) and therefore don't get used. So I think we could focus on that by making them discoverable.

Thanks,

- Rosana
To summarize the changes we need. 

* The product picker that is currently a drop down becomes a visual product picker. The product icons should be rather small though, to make sure people can see as much of the L10n dashboard above the fold as possible. 

* The overview section is slimmed down by removing the "administration" articles and the explanatory text. We oversize the progress bar for the top 20 articles, so that updated articles lead to visible changes. The logic of orange -> green stays the same. We then remove the explanatory text and add it to the overview section items as tooltips. The now free space is used for bigger progress bars.

* The actual content section is separated into Localization and Review

* The Localization tab has a list of articles that need attention, where need attention is defined as "needs translation, needs update, and needs immediate update". The list is ordered by most views in the last 30 days.

* Each article in the "needs attention" list shows below it the templates that are included in the article that need attention. Same rules for "need attention" as before.

* The review tab has a list of top 20 articles needing review with a link to all articles needing review. The templates are listed the same way as on the localization tab, only templates that need review or "need attention" are listed.
(In reply to Kadir Topal [:atopal] from comment #8)
> Created attachment 8340022 [details]

> * The actual content section is separated into Localization and Review

Love this idea. It will be helpful for the both localizers and the reviewer.
Thanks for letting us to give our opinion.
I am drawing my opinion below.
1. In the dashboard page, there should be only 10 articles of "need attention". If anyone click to see more, he/she can see all the 20 article.
2. The sorting of in this 10 articles list should be "Need translate>need immediate upadate>need update"
3. In the time of seeing top 20 articles, the sort should be according to the number of visit.
4. When a article completely translated and reviewed, it must be go down of the list.

This all I would like to see in changes of the dashboard.
Regards
I think this design which is in attached image is good, but i have requests for fix some feature problems:

1- I want take control on changes of article titles. Many spamers chnge the title of translated article, for example the title of article is Install firefox on Linux, they change the title of that article to their name or other words(In their language). I can control the unwanted changes in content of articles by disapprove them, but the title and slug of article is changable without nedding to approve! It's very bad!! Most of articles doesn't have not correct title in Persian, because these unwanted changes! It's more important than redisgning!

2-When I write in the froums, and I writre multiline text in thread, forum shows that lines in one line and tandem. Please Fix it.

3-When i write tags in articles(such as {for fx17} and others, which are left-to right, this tags don't show correctly in right-to-left text.

4-I translated the Ui of sumo to Persian(Right to left language), but the text goes under the picture. It's because the picture in right-to-left language must be goes to left, but it's in right. Now you cant see here https://support.mozilla.org/fa/get-involved you can see the title(large) text is under the Fox and man picture! Please fix it.
I haven't any more request!!
I remembered one other request, It's merge the sumo account with Persona.
Also i want request updating the content of translated text update weekly, monthly. Because we can see the result of UI translation faster, and it will be accessible to visitors, faster.
(In reply to Safwan from comment #10)
> Thanks for letting us to give our opinion.
> I am drawing my opinion below.
> 1. In the dashboard page, there should be only 10 articles of "need
> attention". If anyone click to see more, he/she can see all the 20 article.
> 2. The sorting of in this 10 articles list should be "Need translate>need
> immediate upadate>need update"
> 3. In the time of seeing top 20 articles, the sort should be according to
> the number of visit.
> 4. When a article completely translated and reviewed, it must be go down of
> the list.
> 
> This all I would like to see in changes of the dashboard.
> Regards

Hi Safwan, thanks for the feedback. It's not clear from the mocku-up, but we are doing away with the top 20 list. The list that you can see in the mock-up has the 20 articles that need attention right now. When an article is up to date it is removed from that list.
Thanks for the feedback, Amir. Let me address your points individually.

1. Normal users should never be able to edit the title of the articles. On an already localized article they don't even see that option. Only on articles that have never been localized can they set the title, but the article needs to be reviewed before anyone can see that. Let me know please, if you are seeing a different behavior and we can fix any bugs around that.

2. Are you talking about the case where you press "enter" to switch to a new line? Do you still see the issue when you leave a blank line between paragraphs? 

3. We are currently rewriting our showfor-code, and we'll look into this issue. Thanks for the info!

4. Thanks for the info, I filed bug 944738

5. We already have Persona integration on SUMO, but it's currently only on our stating server: http://support.allizom.org We are only waiting for one issue to be closed before we'll roll out Persona on SUMO proper. You can follow that bug here: https://github.com/mozilla/browserid/issues/4003

6. We are updating Verbatim with new strings about once a week. Feel free to request an update when you see something not being localizable yet. Unfortunately this is a shortcoming of Verbatim. We have plans to automatically update strings on Verbatim though. Once that is done, you'll see new strings appear on Verbatim right away. To be clear though: Things you have localized in Verbatim are updated on SUMO almost every day (from Monday to Thursday)
Hello Kadir, Thank you for your attention.
1. As well as you said, normal users can edit title of untranslated articles now. It's very bad feature. Because those articles have invalid title. They must be can edit the title and contribute to articles without any more action, but the edited titles must not observable on sumo without approve. My problem is editing title of untranslated articles by normal users and those are observable on sumo for all users. This thing make sumo articles incomprehensible.

2.My problem is when i press enter to switch new line. I understood you think this is not problem! You think users must press enter twice for make new paragraph! But in all forums pressing enter for making new line is common. Anyway i think sumo forum will is not user friendly for normal users with this thing.

3.I said that problem is for format of any left to right text in right to left texts(specially for codes, urls, tags, xml and...) this problem in verbatim is much more... I have problems in verbatim and sumo editor. The verbatim shows XML tag error.


Thanks again.
Dear users in your opinion, sumo forums, must be have smile and emogi? (small face pictures for showing Emotions in text) which are on most common forums for common users.
This is really a good idea. I' giving my opinion below,

1. The dashboard will show only the article that needs changes. but the must be an extra section for Templates.
2. When someone is localizing an article, the dashboard will show the localizer's name beside the article. So, that will get notified about the article localization and we will not touch the article to translate until the localizer complete the translation. 
3. I think the drop down product picker is much better that the visual product picker.
The system showing contributor's username under the article, it think it will be better if it shows contributor Full name under the article.
(In reply to Amir Farsi from comment #15)
> 2.My problem is when i press enter to switch new line. I understood you
> think this is not problem! You think users must press enter twice for make
> new paragraph! But in all forums pressing enter for making new line is
> common. Anyway i think sumo forum will is not user friendly for normal users
> with this thing.

https://bugzilla.mozilla.org/show_bug.cgi?id=570425
(In reply to Amir Farsi from comment #15)
> My problem is editing title of untranslated articles by normal users and
> those are observable on sumo for all users. This thing make sumo articles
> incomprehensible.

Hi Amir, I'm not sure what you mean by this. Unless an articles is approved nothing is shown to end users. End users never see titles that the locale leader/reviewer has not approved


> 3.I said that problem is for format of any left to right text in right to
> left texts(specially for codes, urls, tags, xml and...) this problem in
> verbatim is much more... I have problems in verbatim and sumo editor. The
> verbatim shows XML tag error.

I'm sorry, I wasn't able to reproduce this. Can you point me to an article or page where you can see this? We are striving to fix all RTL issues. 

(In reply to me from comment #17)
> This is really a good idea. I' giving my opinion below,
> 
> 1. The dashboard will show only the article that needs changes. but the must
> be an extra section for Templates.

Yes, this is a good point. We'll keep the templates in the overview and we'll link to the all-templates page from there.


> 2. When someone is localizing an article, the dashboard will show the
> localizer's name beside the article. So, that will get notified about the
> article localization and we will not touch the article to translate until
> the localizer complete the translation. 

While we don't have exactly that today, we have something that is similar: When you want to translate an article that somebody else is already working on, you do get a message and a warning who else is already working on the article.


> 3. I think the drop down product picker is much better that the visual
> product picker.

Unfortunately a lot of people were not even aware that we had a product picker :/
Depends on: 951783
Depends on: 967051
Depends on: 967053
Moving 2013Q4 bugs to the Future since we didnt care enough about them in 2014Q1.
Target Milestone: 2013Q4 → Future
Everything is fixed here.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: Future → 2013Q4
You need to log in before you can comment on or make changes to this bug.