Closed Bug 940379 Opened 6 years ago Closed 6 years ago

Bookmarks panel isn't aligned with other panels (such as the downloads panel, the main menu panel, etc.)

Categories

(Firefox :: Bookmarks & History, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: roman.rellum, Assigned: jaws)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131118094134

Steps to reproduce:

After new update of FF 28 (new Australis UI) download panel is misaligned compared to bookmarks panel. See screenshot:

Download panel: http://fii.cz/vwqns - arrow is just touching download button.
Bookmarks panel: http://fii.cz/sxdmthm - there is space between arrow and bookmarks button.



Expected results:

These two panels, and probably all other (don't know if there are more similar panels, I'm using just these two) should be aligned. I personally don't care which is correct, with space it seems little bit better tho.
Component: Untriaged → Downloads Panel
Note that the Firefox menu (and other menus if you add them, eg developer tools menu) is at the same height as the downloads panel. The bookmarks menu is the odd one out.
This might be related to bug 940148 and bug 940265.
Component: Downloads Panel → Bookmarks & History
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:P4]
Also note that it's strange to have this panel appears in the right direction instead of left like all other panels in this area.
That's true, tho you need to have these icons where panel has enough space to appear in its native position. Otherwise all panels appear to left side when there is not enough place on the right side (icons at right edge of the corner).
Duplicate of this bug: 948653
Duplicate of this bug: 963605
The download panel appears a few pixels higher than the bookmarks panel on Mac as well. 

When testing, the download panel's anchor (the button) is five pixels higher than the bookmarks anchor (the dropmarker). However, the download panel anchor is only 20 pixels high while the bookmarks dropmarker is 30 pixels high, so this makes the bookmarks arrow appear 5 pixels lower. The bookmarks panel itself also has a one pixel top margin that the download panel does not have that pushes it down one pixel more.

I don't know enough about the styling of these specific element to know why this is but perhaps this will help clue someone in on what is happening here.
Duplicate of this bug: 971868
I think we should try to fix this for 29.
Summary: Download panel is not aligned with new bookmarks panel. → Bookmarks panel isn't aligned with other panels (such as the downloads panel, the main menu panel, etc.)
Whiteboard: [Australis:P4] → [Australis:P3]
Version: 28 Branch → 29 Branch
Should a new bug be opened about the panel orientation (currently to the right unlike every other panels) ?
(In reply to Guillaume C. [:ge3k0s] from comment #10)
> Should a new bug be opened about the panel orientation (currently to the
> right unlike every other panels) ?

I suspect we can deal with that in here.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
Attachment #8375162 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8375162 [details] [diff] [review]
Patch

Review of attachment 8375162 [details] [diff] [review]:
-----------------------------------------------------------------

This looks OK to me (I'm assuming you've tested the alignment everywhere), but I don't understand the Linux hunk.

::: browser/themes/linux/browser.css
@@ +1470,5 @@
>    margin-bottom: -16px;
>  }
>  
> +#nav-bar .toolbarbutton-1 > menupopup[side="top"].cui-widget-panel,
> +#nav-bar .toolbarbutton-1 > menupopup[side="bottom"].cui-widget-panel {

Can you explain why this is the same for both top and bottom?
Attachment #8375162 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs Kruitbosch from comment #13)
> ::: browser/themes/linux/browser.css
> @@ +1470,5 @@
> >    margin-bottom: -16px;
> >  }
> >  
> > +#nav-bar .toolbarbutton-1 > menupopup[side="top"].cui-widget-panel,
> > +#nav-bar .toolbarbutton-1 > menupopup[side="bottom"].cui-widget-panel {
> 
> Can you explain why this is the same for both top and bottom?

I can't really explain, just that when I tested it if I used `margin-bottom: -4px;` then the panel was moved in the opposite direction than you may expect.

I needed to add the [side="top]/[side="bottom"] attribute references due to the preceding rules that define a different margin based on the side=left/side=right.
https://hg.mozilla.org/mozilla-central/rev/4d5b1351ce2d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Depends on: 973217
The Bookmarks panel still displays 1px below the other panels. See attached screenshot. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Jose, please file a new bug for this. Tracking multiple fixes and landings in one bug gets quite cumbersome, especially with aurora-uplift.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #18)
> Jose, please file a new bug for this. Tracking multiple fixes and landings
> in one bug gets quite cumbersome, especially with aurora-uplift.

Sorry about that. Filed new bug 974237.
Depends on: 974237
Comment on attachment 8375162 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new bookmarks button/panel implementation
User impact if declined: menu offset off when compared to other panels/menus
Testing completed (on m-c, etc.): on m-c for a while now
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: no
Attachment #8375162 - Flags: approval-mozilla-aurora?
Attachment #8375162 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: cornel.ionce
Verified as fixed on Firefox 29 beta 4 and latest Aurora using Windows 7 64bit, Windows XP 32bit, Ubuntu 12.04 32bit and Mac OS X 10.9.2.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.