If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Create a start in-app payment transaction API

RESOLVED FIXED

Status

Marketplace
API
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: andym, Assigned: jkerim)

Tracking

x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

4 years ago
This API will allow the purchase of product, price, app combination as created in bug 944487. The API will

- check the domain matches that of an app
- check that we've got a valid product, price combination
- check that the app is public etc.
- start the transaction in the marketplace
- creates the JWT
- returns the JWT
(Reporter)

Updated

4 years ago
Component: Developer Pages → Payments/Refunds
(Reporter)

Updated

4 years ago
Duplicate of this bug: 944518
(Reporter)

Comment 2

4 years ago
Setting priority, will ping teams involved when are ready to go on this.
Priority: -- → P5
Priority: P5 → P2
This will be very similar to the /webpay/prepare API http://firefox-marketplace-api.readthedocs.org/en/latest/topics/payment.html#preparing-payment

As for checking the domain of the app, not sure how we'll do that. If it gets complicated let's break that into a separate bug.
To be clear, this API should accept a product ID that was created in bug 956334.
The API should be public; it will be called from an app where we have no Marketplace/Webpay session. It could be called from a packaged app where there is no server.
Duplicate of this bug: 956351
Component: Payments/Refunds → API
(Assignee)

Updated

4 years ago
Assignee: nobody → jkerim
(Assignee)

Updated

4 years ago
Blocks: 979551
(Assignee)

Updated

4 years ago
Blocks: 980092
(Assignee)

Comment 7

4 years ago
This is completed in https://bugzilla.mozilla.org/show_bug.cgi?id=980092
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.