Closed Bug 947616 Opened 6 years ago Closed 5 years ago

Existing SeaMonkey/outlook/oexpress/eudora profile is no longer offered for migration to Thunderbird (import in a first-run situation)

Categories

(Thunderbird :: Migration, defect, major)

defect
Not set
major

Tracking

(thunderbird29+, thunderbird35 fixed, thunderbird36 fixed, thunderbird_esr24 unaffected, thunderbird_esr3135+ fixed)

RESOLVED FIXED
Thunderbird 37.0
Tracking Status
thunderbird29 + ---
thunderbird35 --- fixed
thunderbird36 --- fixed
thunderbird_esr24 --- unaffected
thunderbird_esr31 35+ fixed

People

(Reporter: rsx11m.pub, Assigned: mkmelin)

References

Details

(Keywords: regression, Whiteboard: [regression:TB26][workaround:use TB24])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #918853 +++

Steps to reproduce:

 1. Make sure to have a SeaMonkey 2.x profile folder in AppData (Windows)
    or ~/.mozilla/seamonkey (Linux)

 2. Rename the Thunderbird (~/.thunderbird) folder to trigger first-run
    situation

 3. Start Thunderbird

Expected behavior:

 4. Import Wizard shows up, offering import of the SeaMonkey 2.x profile

Actual behavior:

 4. 3-pane window with account central shows up directly without the
    Import Wizard being invoked

This regression may have been introduced along with bug 918853 affecting SeaMonkey's ability to import Thunderbird profiles in turn, thus a similar solution may be successful here.
Reproducible in TB 26.0b1 as well but not in the 24.2.0 candidates.
A precise regression window would be nice.
Using thunderbird-26.0a1.en-US.linux-x86_64.tar.bz2:

 - last good nightly build   2013-08-28
 - first broken build        2013-08-29

http://hg.mozilla.org/comm-central/pushloghtml?startdate=2013-08-28+03%3A00&enddate=2013-08-29+03%3A00
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2013-08-28+03%3A00&enddate=2013-08-29+03%3A00

There has been some bustage fixing from bug 906841 during that time frame which deals with manifest packaging, so that may be a potential candidate.
Removing dependencies to SeaMonkey as it's evidently a different reason.
It would probably be worth poking around in:

http://hg.mozilla.org/comm-central/annotate/96da5e8ea9e0/mail/components/migration/src/nsSeamonkeyProfileMigrator.cpp#l206

to see if we're actually finding a profile or not. Then working out from there to see if there's something else broken.
Mark: Did you mean to set tracking-thunderbird29+ rather than tracking-thunderbird-esr24:29+ given that 24.x isn't actually affected?
Flags: needinfo?(mbanner)
Yes thanks, missed the regression range.
Flags: needinfo?(mbanner)
So we need Bug 715099 - Convert nsProfileMigrator to JS so we can use JS modules on migration - like was done in bug 918853?
See Also: → 918853
Summary: Existing SeaMonkey profile is no longer offered for import in a first-run situation → Existing SeaMonkey profile is no longer offered for migrate (import in a first-run situation)
Whiteboard: [regression:TB26][workaround:use TB24]
"is no longer offered for migrate" - shouldn't that be "migration" or "to be migrated"?
Whatever makes this better searchable...
If we fix it quick it will hardly matter :).  But true.
Summary: Existing SeaMonkey profile is no longer offered for migrate (import in a first-run situation) → Existing SeaMonkey profile is no longer offered for migration to Thunderbird (import in a first-run situation)
The MOZ_PROFILE_MIGRATOR variable was added in bug 686466, didn't investigate exactly why things would have been working without it as long as the regression range suggests.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8536204 - Flags: review?(bwinton)
Comment on attachment 8536204 [details] [diff] [review]
bug947616_seamonkey_migration.patch

Review of attachment 8536204 [details] [diff] [review]:
-----------------------------------------------------------------

Well, I also don't understand why this was working without this variable, but as long as this fixes it, I guess r=me…
Attachment #8536204 - Flags: review?(bwinton) → review+
https://hg.mozilla.org/comm-central/rev/430d75d3e7fa -> FIXED
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Summary: Existing SeaMonkey profile is no longer offered for migration to Thunderbird (import in a first-run situation) → Existing SeaMonkey/outlook/oexpress/eudora profile is no longer offered for migration to Thunderbird (import in a first-run situation)
Target Milestone: --- → Thunderbird 37.0
Comment on attachment 8536204 [details] [diff] [review]
bug947616_seamonkey_migration.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: migration is not enabled for any profiles
Testing completed (on c-c, etc.): landed on trunk
Risk to taking this patch (and alternatives if risky): not risky, just a setting a conf variable
Attachment #8536204 - Flags: approval-comm-esr31?
Attachment #8536204 - Flags: approval-comm-beta?
Attachment #8536204 - Flags: approval-comm-aurora?
For anyone who wants to test this, if you have an existing profile and start up with
 A) "thunderbird -migration" or 
 B) no thunderbird profile at all set up (e.g. you moved it elsewhere for testig)

... you should be presented with the migration dialog on startup.
Attachment #8536204 - Flags: approval-comm-esr31?
Attachment #8536204 - Flags: approval-comm-esr31+
Attachment #8536204 - Flags: approval-comm-beta?
Attachment #8536204 - Flags: approval-comm-beta+
Attachment #8536204 - Flags: approval-comm-aurora?
Attachment #8536204 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.