Closed Bug 948303 Opened 6 years ago Closed 5 years ago

[User Story] Rocketbar: URL History Search

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1, b2g-v2.0 wontfix, b2g-v2.1 affected)

RESOLVED FIXED
2.1 S1 (1aug)
feature-b2g 2.1
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.1 --- affected

People

(Reporter: pdol, Assigned: daleharvey)

References

Details

(Whiteboard: [ucid:System86, 1.4:P2][systemsfe][tako])

User Story

Search app specs for 2.1 at: https://mozilla.box.com/s/lbw2wzw3p4jvxs24k4sg
User Story:
As a user, I want Rocketbar to search and display results based on partial URLs or webpage titles that I enter for websites that I have visited in the past to make it much quicker to browse to sites I've previously visited.

Acceptance Criteria:
1. I can enter a partial string and relevant results from my history are displayed as is currently done in the Browser.
2. Selecting one of the history results loads that page.

Assumptions: 
1. UX spec to specify number of entries. 
2. Frecency algorithm is the same that is currently used in the Browser Awesome Bar. 
3. String matching with historical web pages is the same as in Browser Awesome Bar.
Duplicate of this bug: 948305
The work we are doing for this so far is in bug 952098. I've updated the 'User Story' field of that bug, and am marking this as a duplicate. Going to carry over the whiteboard tags as well.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 952098
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Component: Gaia::System → Gaia::Search
Depends on: 952098
Flags: in-moztrap?(jsmith)
No longer blocks: 1.4-systems-fe
Flags: in-moztrap?(jsmith)
Francis, should we kill this requirement based on your desire to just use autocomplete?
Flags: needinfo?(fdjabri)
Oh.  I missed seeing this.  It used to be that the history would show on an empty bar.  We currently don't have that on 2.0 and we do have that on 1.4.  See bug 1027240
Hi Naoki, I think you're referring to search term history, rather than URL history. 

Peter, WRT to the bug, I think we should probably keep this as a user story, but one potential way to solve it would be through autocomplete. Keeping myself as a NI until I have a spec for this.
Search app specs for 2.1 at: https://mozilla.box.com/s/lbw2wzw3p4jvxs24k4sg
User Story: (updated)
Flags: needinfo?(fdjabri)
Assignee: nobody → dale
feature-b2g: --- → 2.1
Whiteboard: [ucid:System86, 1.4:P2, ft:systems-fe] → [ucid:System86, 1.4:P2][systemsfe][tako]
Target Milestone: --- → 2.1 S1 (1aug)
Depends on: 1041623
Depends on: 1042116
All dependents landed
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.