If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[User Story] FxA - Support COPPA Regulations

RESOLVED FIXED in 1.4 S3 (14mar)

Status

Firefox OS
Gaia
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: arog, Assigned: On parental leave)

Tracking

(Blocks: 1 bug)

unspecified
1.4 S3 (14mar)
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.0)

Details

(Whiteboard: [ucid:FxA19, 2.0:p2, ft:FirefoxAccounts][qa+][dependency:Marketplace])

(Reporter)

Description

4 years ago
User Story:

As legal, I need Firefox accounts to verify, using acceptable means, the age of an individual creating an account. This is to comply with COPPA regulations

Acceptance Criteria

1. When setting up a new Firefox account via settings, I am presented with an age verification mechanism
2. Age verification, gaining parental consent or disallowing access should all be consistent with the regulations defined in COPPA.

Updated

4 years ago
Depends on: 936281

Updated

4 years ago
Blocks: 936281
No longer depends on: 936281

Updated

4 years ago
Depends on: 955945
(Assignee)

Updated

4 years ago
Assignee: nobody → ferjmoreno
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S3 (14mar)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 936281
First pass of manual test for acceptance criteria done, including:
- Does the COPPA dialog correctly block users under the age limit?
- Does the user get presented with verification mechanism?
Whiteboard: [ucid:FxA19, 1.4:p2, ft:FirefoxAccounts] → [ucid:FxA19, 1.4:p2, ft:FirefoxAccounts][qa+]
Manual test case is available here in MozTrap:

https://moztrap.mozilla.org/manage/case/12862/

and here:

https://moztrap.mozilla.org/manage/case/12860/
(Reporter)

Updated

3 years ago
Whiteboard: [ucid:FxA19, 1.4:p2, ft:FirefoxAccounts][qa+] → [ucid:FxA19, 2.0:p2, ft:FirefoxAccounts][qa+]

Updated

3 years ago
Whiteboard: [ucid:FxA19, 2.0:p2, ft:FirefoxAccounts][qa+] → [ucid:FxA19, 2.0:p2, ft:FirefoxAccounts][qa+][dependency:Marketplace]

Updated

3 years ago
Flags: in-moztrap?(npark)

Updated

3 years ago
Flags: in-moztrap?(npark) → in-moztrap+
(Reporter)

Updated

3 years ago
feature-b2g: --- → 2.0
You need to log in before you can comment on or make changes to this bug.