Search form entry (just below URL entry) is always one keystroke behind URL entry.

VERIFIED DUPLICATE of bug 94727

Status

SeaMonkey
Autocomplete
VERIFIED DUPLICATE of bug 94727
16 years ago
13 years ago

People

(Reporter: James Lariviere, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have noticed that when inputing keywords in the urlbar that it is ALWAYS
behind by one letter compared to what you have typed in.

Steps:

(1)type keyword in urlbar "mozilla bug"
(2)see the drop down and it says Search Google for "mozilla bu"

Mozilla should follow what you typed.  This is a recent regression.
Seen on linux and win98 build 2001-8-13-6

Sorry if this is the wrong component.
*** Bug 95223 has been marked as a duplicate of this bug. ***
*** Bug 95300 has been marked as a duplicate of this bug. ***
updating summary
Summary: Search "Your Search Engine" for "keyword" is off → Search form entry (just below URL entry) is always one keystroke behind URL entry.

Comment 4

16 years ago
Regression:

Not present in 0.9.3 (2001080104), gcc295/2001-08-06-09;

Tried 2001-08-07-06, 2001-08-07-21 (which calls itself 2001080800), 
2001-08-08-21 (2001080901), but search bar doesn't work at all in those
(white box pops up, stays in same place when window moves)

Present in 2001-08-09-10, 2001-08-09-21, gcc295/2001-08-10-21, 
2001081308, 2001081412.


All of these are on linux/i686, default build except gcc295 where marked (that
doesn't seem to be relevant, but hey).  All i686 builds in the range [08-06-09,
08-09-10] were tested; bug may have been introduced during fix to other URL bar
bug during that period?

Comment 5

16 years ago
Also tried some other versions.
The original 0.9.3 release (build 2001080110) on NT does work correctly
Build 2001081208 has this bug. 

I did not test other builds, but somewhere in between these two builds the bug
was introduced.

Comment 6

16 years ago
Bug 94727 also covers this. Marking as duplicate of that one.

*** This bug has been marked as a duplicate of 94727 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

16 years ago
verf.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.