Closed Bug 952846 Opened 6 years ago Closed 6 years ago

Don't ship unused PDF.js files in metro installer

Categories

(Firefox for Metro Graveyard :: Build Config, defect, P2)

28 Branch
x86_64
Windows 8.1
defect

Tracking

(firefox28+ verified, firefox29 verified)

VERIFIED FIXED
Firefox 29
Tracking Status
firefox28 + verified
firefox29 --- verified

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

(Keywords: memory-footprint, Whiteboard: [beta28] [defect] p=1)

Attachments

(2 files)

PDF.js is disabled in Metro Firefox (bug 859579), but we are still shipping an extra copy of the extension in Metro-enabled Windows builds (bug 952844) which adds an extra 1MB or so to our installer size.

On Aurora 28, we don't have any code that uses PDF.js, so we should just stop shipping the extension there.

On Nightly 29, PDF.js code is present but disabled by default.  We should keep that true in nightly builds, but remove the code and extension in release builds at least until the footprint issue is fixed.
Attached patch patch for AuroraSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): enabling Metro

User impact if declined: Windows installer size increased by ~1MB

Testing completed (on m-c, etc.): Aurora-only patch.  Pushed to Try:
https://tbpl.mozilla.org/?tree=Try&rev=97ad30ae511d

Risk to taking this patch (and alternatives if risky): Low risk patch that only removes unused code from the Metro package directory.

String or IDL/UUID changes made by this patch: None.
Attachment #8351037 - Flags: review?(jmathies)
Attachment #8351037 - Flags: approval-mozilla-aurora?
Attached patch patch for trunkSplinter Review
This patch builds PDF.js code for Metro only when NIGHTLY_BUILD is true.  We can remove this when PDF.js for Metro is ready to ship.

This also catches one line of Shumway code that I missed in bug 923596.
Attachment #8351038 - Flags: review?(jmathies)
Blocks: metrov1it21
No longer blocks: metrov1backlog
Priority: -- → P2
QA Contact: jbecerra
Attachment #8351037 - Flags: review?(jmathies) → review+
Attachment #8351038 - Flags: review?(jmathies) → review+
Blocks: metrov1it22
No longer blocks: metrov1it21
https://hg.mozilla.org/mozilla-central/rev/ae27b82c41ee
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Attachment #8351037 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [beta28] p=1 → [beta28] [defect] p=1
No longer depends on: 952844
I accidentally ifdef'ed the wrong lines in package-manifest.in.  Philor noticed that this broke the build when pushing m-c to Try with Aurora build config.  Push a fix to fx-team:
https://hg.mozilla.org/integration/fx-team/rev/211c36cf894a
For iteration #22, verified as fixed with latest Nightly and Aurora on Win 8.1 64-bit: .pdf files can't be viewed inline in Metro mode.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.