Not able to add bookmarks to a migrated profile

VERIFIED FIXED in M9

Status

SeaMonkey
General
P3
major
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: Grace Bush, Assigned: dbragg)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Testing Profile Migration I found that I was unable to add bookmarks or to move
to different urls (as done in new profile/bookmark testing)

Steps to Reproduce:
1) Migrate a 4.x profile (4.7 us pro)
2)Launch apprunner and try the url http://www.cnn.com
3)Try to add current page to bookmark

Actual Results: Nothing happens, apprunner stays on opening page, bookmarks are
not updated
Expected Results: Navigate to cnn.com, add url to bookmarks

Build Date & Platform Bug Found: 1999070908, WinNT (cannot test 95,98 see bug
9502) (profile migration not available on Mac or Linux yet)

Note: Menu Bookmark pulldown menu 'looks' different from the one used with new
5.0 profile, default or one created. It contains only two entries..add current
page and manage bookmarks

Don,
I am not sure this is profile migration issue-profile migrates-I am not sure
'what' reads the bookmark file or the url....the new prefs50.js file is being
read properly.
(Reporter)

Comment 1

19 years ago
see bug 9431 for similar behavior
(Assignee)

Updated

19 years ago
Assignee: dbragg → don
Component: Profile Migration → Browser-General
(Assignee)

Comment 2

19 years ago
This is a general browser error.  The browser is supposed to read/convert/write
the old bookmark.htm format.  For that reason the profile migration tool will
not do any conversion on it.  It is simply copied and it is being copied
correctly.

Reassigning to Browser-General (aka Don Melton).  I looked for a more specific
category but alas none exist.
(Reporter)

Comment 3

19 years ago
cc'ing waterson -he fixed both 7921 (bookmarks) and 9431, not sure if this is
related.

Comment 4

19 years ago
You should be able to add new bookmarks, and you can modify all bookmark
attributes _except_ for the bookmark's URL (see bug 9246). Could you please
re-verify that this is broken? If indeed it is, please reassign to me.
(Reporter)

Updated

19 years ago
Assignee: don → waterson
(Reporter)

Comment 5

19 years ago
build 1999071208 (and 1999071108)- this is still occurring.
Cannot add new bookmarks to a seamonkey launched with a migrated profile.
Launching with a newly created 5.0 profile allows me to add bookmarks

From the console window:
JavaScript error: uncaught exception: Component returned failure code: 0x8000fff
[nsIBookmarksService.AddBookmark, {file:
file://~/x86rel/res/samples/navigator.xul, line: 538}]

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: [PP]Win Using a migrated profile does not allow to add bookmarks or move to new url → write out new bookmarks.html file if none exists
Target Milestone: M9

Comment 6

19 years ago
Okay, it turns out the profile mirgration is migrating the Win32 bookmarks file
as "bookmark.htm". I'm expecting to see "bookmarks.html" (on ALL platforms), so
can we get the profile migrartion code to appropriately rename the file?
(I've opened bug 9697 for that.)

In the meantime, I will make sure that the browser will write out a new
bookmarks file if none exists. Renaming bug appropriately.

Comment 7

19 years ago
So, I think that its BAD BAD BAD to change the name of the bookmark's file!!!
Third-party utilities will be looking for the old name of the file (whatever it
is for a given platform).

INSTEAD, the 5.0 bookmark's code should handle finding a bookmark's file with
any of the older names and use the name it finds.

I have code to do exactly that, and I'm going to check it in.

Updated

19 years ago
Assignee: waterson → rjc
Status: ASSIGNED → NEW

Comment 8

19 years ago
Okay, you touched it last. For that, you win this bug!

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
Marking as fixed so QA can re-test.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 10

19 years ago
build 1999072808 WinNT
Using a migrated profile, I am not able to add bookmarks as originally noted

Bookmark menu (with migrated profile)  is different from the one appearing when
using a newly created 5.0 profile.

Migrated bookmarks file [ (4.x = bookmark.htm)(5.0 = bookmarks.html) (migrated
bookmark file = bookmark.html)

Updated

19 years ago
Resolution: FIXED → ---

Comment 11

19 years ago
Clearing FIXED resolution due to Reopen.
When migrating from 4.x to 5.0, the bookmark file should NOT be renamed.

This bug should be reassigned to whoever is working on the migration.  Who's
that?
(Reporter)

Updated

19 years ago
Summary: write out new bookmarks.html file if none exists → Not able to add bookmarks to a migrated profile
(Reporter)

Comment 13

19 years ago
Changing summary line from 'write out new bookmarks.html file if none exists' to
the above.
Also in this issue is matter of name bookmark file should have in 5.0
cc'ing dbragg on migration issue

Updated

19 years ago
Assignee: rjc → dbragg
Status: REOPENED → NEW
I'm reassigning this to Don. :)  Let's make sure that the migration code is NOT
rename the bookmarks file.

There is code in 5.0 which currently checks for "bookmarks.html" and, if that
doesn't exist, then tries "bookmark.htm".

Robert
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 15

19 years ago
I'll see your reassignment and raise you an Accept, Robert!
I removed this code when I saw your eloquent comments about how we shouldn't
change the name.  I don't think I've check it in though.  Necko doth block.
I'll mark this fixed as soon as I can check in.
Good man!  :^)



Tree is now open, too!
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

19 years ago
Fixed.  The migration code no longer changes the name of bookmarks.htm to
bookmarks.html
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

19 years ago
Aug15 build
bookmarks from migrated profile are showing in Seamonkey-file name is being
migrated properly-verifying this bug

see bug 11955 for 'unable to add bookmarks' to any profile
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.