process_bug.cgi sees blank address in cc: list (__UNKNOWN__)

RESOLVED FIXED in Bugzilla 2.14

Status

()

Bugzilla
Bugzilla-General
P1
blocker
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

({regression})

unspecified
Bugzilla 2.14
regression

Details

Attachments

(5 attachments)

(Assignee)

Description

17 years ago
process_bug.cgi appears to be parsing the cc: list such that it thinks the user
submitting changes has entered a user with a blank email address into cc: field.
 Apparently this is triggered if the user enters two commas in a row into the
cc: list field, although some users claim that it happened when they didn't do that.

Bug 95798 exacerbates this problem, as does the presence of a user on b.m.o.
with a blank login name (email address).

The following bugs are currently affected:

bug 87976
bug 82305
bug 21344
bug 92839
bug 95457
bug 95822
bug 72781
bug 95849
(Assignee)

Comment 1

17 years ago
I don't want to disable the user's account (#12852) and give them a fake email
address or integrate a fix for bug 95798 until we figure out what is causing this.
Severity: major → blocker
Keywords: regression
Priority: -- → P1
Target Milestone: --- → Bugzilla 2.14
(Assignee)

Comment 2

17 years ago
simplifying summary and adding __UNKNOWN__ to it so people find it more easily
Summary: process_bug.cgi looks for user with empty address in cc: list → process_bug.cgi sees blank address in cc: list (__UNKNOWN__)
(Assignee)

Comment 3

17 years ago
The problem is in code that was fixed by Jake's patch to bug 95747.

This is the old code:

            my @new = split(/[ ,]/, $cc_add);
            foreach my $person (@new) {

This is the new code:

        foreach my $person (split(/[ ,]/, $cc_remove)) {
            # Ignore blanks
            next unless $person;

(Assignee)

Comment 4

17 years ago
Created attachment 46303 [details] [diff] [review]
patch v1: makes the code more compact and robust
(Assignee)

Comment 5

17 years ago
Although the bug has been fixed by a previous patch, the patch I just attached
is a more compact and robust solution to the problem.
Assignee: justdave → myk
Keywords: patch, review
(Assignee)

Comment 6

17 years ago
Created attachment 46311 [details] [diff] [review]
patch v2: handles leading delimiters
r= justdave
committed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
After talking in irc, we came up with a slightly better solution.
REOPENing
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

17 years ago
Created attachment 46318 [details] [diff] [review]
patch v3: convert all delimeters to a single space before splitting.

Comment 10

17 years ago
Created attachment 46319 [details] [diff] [review]
patch v4: use the syntax that allows perl to do proper trimming

Comment 11

17 years ago
Created attachment 46320 [details] [diff] [review]
patch v5: The Bugs Strike Back
(Assignee)

Comment 12

17 years ago
works. r=myk

Comment 13

17 years ago
It's in.
(I'm just glad we didn't need a Return of the Bugfixer :)
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → unspecified
Moving to Bugzilla product
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.