doFileTransfer is not defined nfc_handover_manager.js

RESOLVED DUPLICATE of bug 966009

Status

Firefox OS
NFC
RESOLVED DUPLICATE of bug 966009
4 years ago
4 years ago

People

(Reporter: johnhu, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

E/GeckoConsole( 1835): [JavaScript Error: "doFileTransfer is not defined" {file: "app://system.gaiamobile.org/js/nfc_handover_manager.js" line: 273}]
E/GeckoConsole( 1835): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "doFileTransfer is not defined" {file: "app://system.gaiamobile.org/js/nfc_handover_manager.js" line: 273}]'[JavaScript Error: "doFileTransfer is not defined" {file: "app://system.gaiamobile.org/js/nfc_handover_manager.js" line: 273}]' when calling method: [nsIDOMSystemMessageCallback::handleMessage]" {file: "jar:file:///system/b2g/omni.ja!/components/SystemMessageManager.js" line: 97}]

I had checked the code of nfc_handover_manager.js. It uses "doFileTransfer" within an object instance without "this". The correct one should be "this.doFileTransfer.bind(this)". We still need to bind this because it uses "this" inside of this method.
Blocks: 933640
Blocks: 903253
Blocks: 948362
Blocks: 948363

Comment 1

4 years ago
Master: 869e51f87d665d66c7345e38f6cf9c42c1c52fbd

This change in Mozilla master already has the change / fix for the issue.
Could we close this bug now?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966009
You need to log in before you can comment on or make changes to this bug.