Closed Bug 903253 Opened 7 years ago Closed 6 years ago

[Gaia][Video] Video application: handle data transfer

Categories

(Firefox OS Graveyard :: Gaia::Video, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S1 (14feb)

People

(Reporter: frlee, Assigned: johnhu)

References

Details

(Whiteboard: [FT:RIL] sharing video/audio/image [fxos:media])

Attachments

(2 files)

During the video/image sharing via NFC, data transfer needs to be handle.
Depends on: 894320
Blocks: 894320
No longer depends on: 894320
Hi dale, are you available to handle this bug?
Flags: needinfo?(dale)
We arent picking up bugs individually these days, the feature requests go in the product backlog so we can properly estimate and prioritise them and will be picked up during sprints
Flags: needinfo?(dale)
blocking-b2g: --- → 1.3+
(In reply to Dale Harvey (:daleharvey) PTO - 28th Oct from comment #2)
> We arent picking up bugs individually these days, the feature requests go in
> the product backlog so we can properly estimate and prioritise them and will
> be picked up during sprints
Francis, can you please find a assignee for this bug.
Flags: needinfo?(frlee)
hi Dietrich,

are you working on Media functional team? if so, may you please let me know who can help on this issue?
Flags: needinfo?(frlee)
Flags: needinfo?(dietrich)
Hi, Candice, can you help? Thanks!
Flags: needinfo?(dietrich) → needinfo?(cserran)
Blocks: NFC-Gaia
Should we separate gallery and video into 2 different bugs(unless it belongs to the same developer)? 
Francis, what do you think?
Flags: needinfo?(frlee)
John, are you the best person to help this bug? Thanks.
Flags: needinfo?(johu)
We need to define the scope of this bug. If this is just to return the blob to the callback onpeerfound, it's me. If this is transferring the blob from onpeerfound to bluetooth, it's alive.

In NFC, I may have two parts: 1. hook onpeerfound API when our context is ready to share, 2. implement onpeerfound callback to return the context blob. Others are handled by system app.
Flags: needinfo?(johu)
hi Kevin,

i have no objection to separate it into 2 bugs, but i know gallery,Video share same section of code in this case. i think John is in a better position to comment.

hi John,

what's your opinion for comment#6 ?
Flags: needinfo?(frlee)
It seems better to finish this bug before sprint5. If you think it isn't reasonable, please update target milestone.
Target Milestone: --- → 1.3 Sprint 5 - 11/22
Sorry for late replying, I also suggest to separate this bug into two bugs.
NFC is not a committed feature for 1.3, so this should not block the release.
blocking-b2g: 1.3+ → 1.3?
Moving this over to the Video app component as the code changes being made here on the Gaia video app, not the NFC codebase.
Component: NFC → Gaia::Video
Assignee: nobody → johu
Moving this to 1.4
blocking-b2g: 1.3? → 1.4?
Duplicate of this bug: 903252
moves the dependency of 903252 to here.
Depends on: 933093, 933116
According to bug 933093, what we need to do is to put the following code at the correct place:
window.navigator.mozNfc.onpeerfound = function(nfcPeer) {
  // Negotiates WiFi or BT connection, presenting UI 
  nfcPeer.sendFile(blob); 
};

The correct place means where the app is under single file sharable context.
No longer blocks: 948362
Summary: [Gaia] Video/image application: handle data transfer → [Gaia][Video] Video application: handle data transfer
No longer blocks: 948363
Bug 952217 is a blocker for this bugs.
Depends on: 952217
The feature detection had added to WIP patch:
https://github.com/huchengtw-moz/gaia/commit/fa9e3f3833316ff39a897e8135ed435a2bb50e64

(console.log still exists for debugging)
Whiteboard: [FT:RIL] sharing video/audio/image
Depends on: 961913
Depends on: 960790
No longer depends on: 961913
Target Milestone: 1.3 Sprint 5 - 11/22 → 1.3 C3/1.4 S3(31jan)
Priority: -- → P1
Attached file the patch for NFC
I just upload the patch but not set review because I haven't done the end to end test. No workable device now.
Depends on: 963471
Depends on: 964672
Depends on: 964693
Comment on attachment 8364131 [details] [review]
the patch for NFC

1. add "onpeerready" callback when the video is in player view
2. remove "onpeerready" callback when the video is not in player view

To test this patch, we need to have the patch of the following bugs: bug 963471 (add this.doFileTransfer.bind(this) to nfc_handover_manager.js), bug 964672 (remove the doPair call in doFileTransfer), and bug 962310 (gecko).

The video of a workable NFC sharing may be found at bug 948362.
Attachment #8364131 - Flags: review?(dflanagan)
Depends on: 962310
Whiteboard: [FT:RIL] sharing video/audio/image → [FT:RIL] sharing video/audio/image [fxos:media]
Target Milestone: 1.3 C3/1.4 S3(31jan) → 1.4 S1 (14feb)
Comment on attachment 8364131 [details] [review]
the patch for NFC

Since David is too busy on other 1.3+ issue, transfer this review to George Duan who had read and write some patches for video apps.
Attachment #8364131 - Flags: review?(dflanagan) → review?(gduan)
Comment on attachment 8364131 [details] [review]
the patch for NFC

This patch can successfully trigger nfc transfer when player shows.

r=gduan
Attachment #8364131 - Flags: review?(gduan) → review+
Attached video video for nfc sharing
This video is record at offline reviewing for demonstrating the whole procedure to George.
merged to master:
https://github.com/mozilla-b2g/gaia/commit/d128d034bc0c2f53ee9f056b1aa28f0f3edbe5b2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 1.4? → ---
Flags: needinfo?(cserran)
You need to log in before you can comment on or make changes to this bug.