Add mailto: protocol to windows integration preferences

RESOLVED INVALID

Status

SeaMonkey
Preferences
RESOLVED INVALID
17 years ago
5 years ago

People

(Reporter: kiaser_zohsay, Unassigned)

Tracking

(Depends on: 1 bug, {pp})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

17 years ago
MS Outlook registers the mailto: protocol the same way IE and Mozilla can
register http: and the other supported protocols.  Add a checkbox for mailto: to
Preferences | System.
confirming rfe. ->law. cc'ing seth, to keep at least one mailnews engr aware. :)
Assignee: sgehani → law
Status: UNCONFIRMED → NEW
Ever confirmed: true
win32-only.
Keywords: pp

Comment 3

16 years ago
Requires some (optional) mail-specific code.
Target Milestone: --- → mozilla1.0

Comment 4

16 years ago
->mail

Probably covered by simple-mapi work already.
Assignee: law → tiantian
Component: Preferences → Simple MAPI
Product: Browser → MailNews
QA Contact: sairuh → trix
Target Milestone: mozilla1.0 → ---

Comment 5

16 years ago
this wasn't covered by Simple MAPI.  Reassigning to ssu.
Assignee: tiantian → ssu
Target Milestone: --- → mozilla0.9.7

Updated

16 years ago
Keywords: nsbeta1+

Comment 6

16 years ago
*** Bug 104435 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
All that needs creating is the prefs UI (and backend) to do this, mozilla itself
already copes with it.

Just to create \\HKCR\mailto\shell\command
                Default[Reg_SZ] "Mozilla.exe %1"

I manually create the key and it works fine.

Updated

16 years ago
Priority: -- → P1

Updated

16 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 8

16 years ago
I apologize if this is the wrong place for this comment.  I am a bugzilla newbie.

How is this bug not the same as 11459?  I ask because bug 11459 as been out for
a depressing two or three years and it appears to cover a feature I find
critical.  So I hope it is very different from bug 11459 as I would like to see
this behavior fixed.

In short, I don't understand why Mozilla on Win doesn't respect it's own
setting: Use Mozilla Mail as the default mail application: NO!

I find it valuable to have more than one mail user agent installed and
configured on my machine.  I look forward to making Mozilla my primary mail user
agent.  But that's not until I get more experience/faith in it.

Today, I would like to have Mozilla handle my spam mail account since I suspect
that Mozilla's security will be better than Eudora's security since Eudora uses
IE to display html email.

So I want ALL mailtos to be handled by Eudora.  I do want Mozilla's email client
installed, and I want to explicitly bring it up to send/respond to mail sent
to/from suspected spamming companies.

It shouldn't be all or nothing.  In short, is there any reason that Mozilla
doesn't respect it's own setting: "make mozilla the default mail agent: NO"?

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
Priority: P1 → P2
Target Milestone: mozilla0.9.9 → mozilla1.0
*** Bug 122954 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Discussed in 2/25 bug mtg w Mktng, PjM and engineering.  Decision was to future
and nsbeta minus this bug.
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → Future

Updated

16 years ago
Priority: P2 → P3

Comment 11

16 years ago
Huh? Isn't "Preferences | Mail & Newsgroups | Use Mozilla Mail as the default
mail application" precisely what this bug asks for?
(Reporter)

Comment 12

16 years ago
Bug 122954 was more specific in that it refered to mailto: links in non-mozilla
browsers.  When I filed this bug, I was even including non-browser apps that use
url-type protocol specifiers.  Windows Explorer maintains "file type"
information in the registry for http:, ftp: mailto: and several other url
protocols, in the same way that it maintains associations by file extension. 
Mozilla regiters itself to handle these protocol based on the settings in Edit |
Preferences | Advanced | System in the "Windows should use Mozilla to handle
these protocols" list.

This request is to add "mailto:" to that very list.

Updated

16 years ago
Blocks: 11459

Comment 13

16 years ago
I'll do this.
Assignee: ssu → ben
Status: ASSIGNED → NEW
Component: Simple MAPI → Preferences
Product: MailNews → Browser
QA Contact: trix → sairuh
nominating.
Keywords: nsbeta1- → nsbeta1

Comment 15

16 years ago
Patch in bug 160141
Depends on: 160141

Updated

15 years ago
QA Contact: sairuh → pmac

Comment 16

15 years ago
qa contact windows integration-> pmac

Comment 17

15 years ago
nsbeta1+/adt3 per the nav triage team.

Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]

Comment 18

15 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1+ → nsbeta1-
Whiteboard: [adt3]

Comment 19

15 years ago
Isn't this equal to bug 137795?

Comment 20

15 years ago
*** Bug 137795 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
Now that Minotaur/Thunderbird exists, this is no longer just an enhancement,
it's a pretty serious bug. Without this being fixed, people won't be able to use
Minotaur as their default mail client without hacking the registry.

cc'ing the Minotaur developers.
Severity: enhancement → normal
OS: Windows NT → Windows XP

Comment 22

15 years ago
Bug 141965 specifies a behavior for associating Mozilla to mailto: that I think
would be more useful than the checkbox requested by this bug.

Please see my comments in Bug 77846.

Comment 23

15 years ago
Mike, you are absolutely right. I didn't realize this bug report was for a
checkbox in the preferences window. I assumed this would be part of the "make
default mail client" code.

Comment 24

15 years ago
Should this bug be Windows-only?  Mac OSX (for instance) also has a system-
defined mailto: handler.  Gnome provides a related mechanism (see Bug 140635).

If a protocol checkbox is cleared, does that set 'true' the preference for
   network.protocol-handler.external.<protocolname> ?
There is a substantial demand for a UI for the net.p-h.ext.mailto
preference (see bug 11459).  I think this preference could safely be set for
the mail and news protocols, maybe for ftp; I'm not so sure about http.  I'm
also not sure if the pref should be cleared if Mozilla de-associates itself.

I think that using checkboxes is the wrong UI element for these selections;
there is more going on at this level than simple on/off.

Comment 25

15 years ago
Yes, this bug is Windows only since the code is Windows only.  File a new bug
for Macs.  I'd like extensible protocol support (related to your comments) and
that's why I filed bug 160896.

Updated

15 years ago
No longer blocks: 11459

Comment 26

15 years ago
This blocks bug 11459, not depends on it.
Blocks: 11459

Updated

15 years ago
No longer blocks: 11459
This bug seems to be fixed in Thunderbird 0.1
mailto: links open correctly in Thunderbird (failure to do so would have been
catastrophic=

news: links still attempts to open OE , meaning that bug 160141 still needs fixing.
Sorry .. guess I should read all the comments more closely ..
I incorrectly thought as David Tenser in comment #23 that this was the bug for
registering mailto: in windows . I see now that this is bug 207974 , not this one.

Comment 29

15 years ago
*** Bug 207974 has been marked as a duplicate of this bug. ***

Comment 30

15 years ago
Bug 207974 is not a dupe; rescinded.

Comment 31

14 years ago
This bug might be related to bug 207974?

Rainer

Comment 32

14 years ago
Using T-Bird: Mozilla Thunderbird 0.5a (20040120)

I see HKEY_CLASSES_ROOT\mailto\shell\open\command (default) ==
"<path-to-thunderbird.exe> -compose "%1"
But, sadly, it isn't working there if I click in Firebird.  

Pretty sad if we can't make this go away after 2+1/2 years!!!!
Product: Browser → Seamonkey
This bug is the one and only reason I have not switched to Firefox.  I want to
keep Mozilla for email, and use Firefox to browse....
Assignee: bugs → prefs
QA Contact: pmac

Comment 34

11 years ago
Appears to be fixed in T-Bird: Same settings as comment #32, but it works.

Tested from Firefox, Word, Excel, and IE7; on WinXP SP2.

Since Product = Moz App Suite, I'll leave it open until someone can confirm.

Comment 35

11 years ago
(Comment 34 was tested on TB 2beta2.)
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs
Priority: P3 → --
Target Milestone: Future → ---

Comment 37

5 years ago
In current UI there are three separate buttons for Mail, News and RSS thus no separate checkbox for mailto: necessary so closing this
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.