Server not found pages have '&f=regular' appended to url

RESOLVED FIXED in Firefox 28

Status

()

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: nthomas, Assigned: gwagner)

Tracking

({regression})

Trunk
1.4 S1 (14feb)
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox28+ fixed, firefox29+ fixed, firefox30+ fixed, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments, 1 obsolete attachment)

eg: Server not found

Firefox can't find the server at asfdasfasdfdsafdasf.dasf.aesraewrfdsz.com.&f=regular

Broken in Nightly 20140203030203/m-c 44ba69cacd7e, probabaly fair recently.
Must have been caused by bug 959800.
Blocks: 959800
Component: General → Document Navigation
Product: Firefox → Core
Er, yes.  I guess we should put this new thing before the other ones...
The code responsible for putting that text in the error page is getDescription:

http://hg.mozilla.org/mozilla-central/annotate/c150845d077d/docshell/resources/content/netError.xhtml#l63

It seems to assume that the "d=" parameter is last?
Seems like the "manifestURL" stuff just before this newly added code would also mess that up, though presumably that doesn't impact desktop Firefox.
Yep that's our fault.
We could either make the change in bug 959800 B2G only, move f= before d= or maybe teach getDescription to only take the d= part.
Seems like moving f= before d= is sufficient based on the comments. Does the error page for android go through the same code or do we have to check more error pages?
Whiteboard: [systemsfe]
Posted file testcase.html
Putting needinfo on myself to check to see if this reproduces on FxOS. I've confirmed this on FxDesktop as well.
Flags: needinfo?(jsmith)
Posted patch patch (obsolete) — Splinter Review
Assignee: nobody → anygregor
Don't think we need a gaia change here. Mike?
Flags: needinfo?(mhenretty)
Comment on attachment 8369878 [details] [diff] [review]
patch

The comment in the patch is somewhat misleading. I'd be more explicit:

// netError.xhtml's getDescription only handles the "d" parameter at the end of the URL, so append it last
Attachment #8369878 - Flags: feedback+
(In reply to Jason Smith [:jsmith] from comment #7)
> Putting needinfo on myself to check to see if this reproduces on FxOS. I've
> confirmed this on FxDesktop as well.

Confirmed this doesn't reproduce on the latest 1.4 build on FxOS.
Flags: needinfo?(jsmith)
Posted patch patchSplinter Review
Thanks Gavin
Attachment #8369878 - Attachment is obsolete: true
Attachment #8369895 - Flags: review?(bzbarsky)
Gaia doesn't rely on the order of parameters to get the description. We should be good. Thanks for fixing this!
Flags: needinfo?(mhenretty)
Comment on attachment 8369895 [details] [diff] [review]
patch

r=me
Attachment #8369895 - Flags: review?(bzbarsky) → review+
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
blocking-b2g: --- → 1.3+
Target Milestone: 1.3 C3/1.4 S3(31jan) → 1.4 S1 (14feb)
Duplicate of this bug: 967509
Duplicate of this bug: 967892
https://hg.mozilla.org/mozilla-central/rev/7f5b2aab179b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 968151
Duplicate of this bug: 968124
Duplicate of this bug: 968614
Duplicate of this bug: 968846
can this be uplifted to aurora & beta?
Needs approvals (and presumably approval requests), no?
Duplicate of this bug: 969824
Comment on attachment 8369895 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 959800
User impact if declined: Showing "&f=regular" at the end of the hostname on the "host not found" error page.
Testing completed (on m-c, etc.): Fine on m-c.
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8369895 - Flags: approval-mozilla-beta?
Attachment #8369895 - Flags: approval-mozilla-aurora?
Attachment #8369895 - Flags: approval-mozilla-beta?
Attachment #8369895 - Flags: approval-mozilla-beta+
Attachment #8369895 - Flags: approval-mozilla-aurora?
Attachment #8369895 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.