Closed Bug 967425 Opened 7 years ago Closed 7 years ago

OSX: window controls and fullscreen button are wrongly positioned

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mikedeboer, Assigned: mikedeboer)

References

()

Details

(Whiteboard: [Australis:P3] )

Attachments

(1 file)

This struck me as I saw the screenshot https://bug967360.bugzilla.mozilla.org/attachment.cgi?id=8369842 of bug 967360: compared to other native OSX apps bundled by Apple, the close/ minimize/ maximize and fullscreen buttons are too far away from the edge of the window.

Moving them closer to the top also allows for a better distinction between buttons that have a function related to Firefox and buttons that allow controlling the mode of the window (which is consistent OS-wide).

It also provides a space beneath the close/ minimize/ maximize buttons, which can/ will be used to drag the window. (I mention this because ppl complained about the reduced amount of space above the tabs to grab & drag the window).

This would also fix bug 898875.
Markus, what do you think of this approach? It *looks* mighty fine to me visually, but I'm unsure of the JS part of this patch.

The '4' px added bottom-margin is a magic number, for example. But, I hope/ think that together we can figure this one out ;)
I don't agree with you from a visual perspective :)

I think we could even move the window buttons further to the right, so that the distances between window edge and window buttons and between window buttons and the first tab icon are more balanced.

But this is really a question that should by answered by Stephen. The current icon positions match his mockups to the pixel. Stephen, what do you think?
Flags: needinfo?(shorlander)
Quite irrespective of how I feel about the particular issue, it's clearly not a big deal. I really don't think we should pursue this until bug 930094 has landed, as that's much more important considering how utterly broken we currently are on OS X with the titlebar turned on or any other manner of tricks. That patch will bitrot this patch (and not in an easily fixable way as it removes these margins from the TabsInTitlebar calculations). So please can we hold off here?
Attachment #8369961 - Flags: feedback?(mstange)
I attached URL http://note.io/1emQnoj to a screenshot that show the result of this patch applied.
So basically this bug is about reverting bug 851652 (as noted on IRC by Markus).
The vertical centering of the window controls was an intentional design decision for Australis. It visually balances the vertical elements in the reduced height tab strip+titlebar and reduces the amount of elements that are misaligned.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(shorlander)
Resolution: --- → WONTFIX
No longer blocks: fxdesktopbacklog
Whiteboard: [Australis:P3] [feature] p=0 → [Australis:P3]
Duplicate of this bug: 1045173
You need to log in before you can comment on or make changes to this bug.