If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

automatic(meta?) refresh causes page to be added SH each time

RESOLVED FIXED in mozilla0.9.5

Status

()

Core
Document Navigation
--
major
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: WD, Assigned: Radha on family leave (not reading bugmail))

Tracking

({regression})

Trunk
mozilla0.9.5
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3+) Gecko/20010825
BuildID:    2001082508

The URL listed is a frameset page, with one of the frames having an automatic
reload/refresh.    Each time the frame reloads, an entry is added to the session
history

Reproducible: Always
Steps to Reproduce:
1.Go to:  http://dormcam.org/index1.shtml
2.wait about 30 seconds or so.  (enough to let the chat frame refresh a couple
of times)
3.Press the back button

Actual Results:  You still remain on the same page

Expected Results:  You are brought to the page you were previously at.
(Reporter)

Updated

16 years ago
Blocks: 59387

Comment 1

16 years ago
Seeing on Linux 2001082622 too. Not platform specific.
OS: Windows 98 → All
Hardware: PC → All

Comment 2

16 years ago
I also see this problem (linux 2001082708) on non-frame pages with refresh;
summary should be changed to a more general description.

Comment 3

16 years ago
changing summary. you can see the pure effect by simply opening the frame into
its own new window. Wait a few seconds and you'll see the back button light up
and the 'Go' fill up with repeats. I'd say this was a major regression.
Keywords: regression
Summary: a reloading frame gets added to the history with each refresh → automatic(meta?) refresh causes page to be added SH each time

Comment 4

16 years ago
the frame url: http://dormcam.mine.nu:8080/messages/messages.html
and from the HTML: <html><head><meta HTTP-EQUIV="Refresh" CONTENT="7"> <meta
HTTP-EQUIV="Pragma" CONTENT="no-cache"></head><body

Comment 5

16 years ago
Forgot to add before: should this still block bug 59387?

Comment 6

16 years ago
re 59837, no b/c it's not isolated to frames as we've both stated.
Severity: normal → major

Updated

16 years ago
No longer blocks: 59387

Comment 7

16 years ago
Still a bug with build 2001090703.

This bug makes it frustrating to use the Back button when monitoring a page
generated by BigBrother, a popular freeware monitor tool available at
http://bb4.com. 

Could the target milestone be set to at least 0.9.5?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.5
Created attachment 49684 [details] [diff] [review]
simple patch to docshell
This regresion was caused by hte fix to bug 83684 on 8/23/01.  The attached
simple patch fixes this bug. I think I forgot to take care of LOAD_REFRESH when
I was dealing with sequentially repeating urls. 

Comment 10

16 years ago
what, no takers yet? the patch seems likely the right thing to do. (r)r=danm.
*** Bug 98904 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
sr=alecf
*** Bug 100626 has been marked as a duplicate of this bug. ***
*** Bug 101031 has been marked as a duplicate of this bug. ***
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 101533 has been marked as a duplicate of this bug. ***
*** Bug 102854 has been marked as a duplicate of this bug. ***
*** Bug 110047 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 105116 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.