Use an ::after element to workaround for backgound-attachment: fixed making start page watermark jittery

VERIFIED FIXED in Firefox 28, Firefox OS v1.3

Status

P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rsilveira, Assigned: rsilveira)

Tracking

unspecified
Firefox 30
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox28 verified, firefox29 verified, firefox30 verified, b2g-v1.3 fixed)

Details

(Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28 [qa+])

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 8374288 [details] [diff] [review]
Patch v1

Using a fixed ::after element for watermark. Doesn't jitter but seems to affect scroll perf on my machine.

Comment 1

5 years ago
I ran a mochiperf test I wrote that measures about:start frame rates on my surface pro. We gain a little by not having the watermark at all, but your fix doesn't appear to be any different from the old way we did things. I say we land this.

frame rates - lowest, average, highest

without:
12.78128948211673, 18.59786614073508, 36.36217947006226
12.63769250167044, 18.62844010021375, 35.69318911903783
13.99339901773557, 18.51968537923452, 35.94249534606933

with:
12.57155618667602, 20.24701798523908, 41.5103327751159
11.65082846189800, 20.54952812194824, 46.2052700645045
13.53932342529296, 19.32422757747784, 38.7889627456665

old watermark:
12.74443211555481, 20.20959343659250, 44.13960485458374
13.13732051849365, 19.86325096827681, 43.41022511532432
12.20469630391974, 20.44748240805961, 46.02304097225792

http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/tests/mochiperf/browser_apzc.js#175
http://www.mathies.com/mozilla/mochiperf.html?testid=2E60F8B5-8925-4628-988E-E4C0BC6B34C7
Created attachment 8374624 [details] [diff] [review]
Patch v2

using negative margin instead of calc.
Attachment #8374288 - Attachment is obsolete: true
Attachment #8374624 - Flags: review?(sfoster)

Updated

5 years ago
Blocks: 969356

Updated

5 years ago
Blocks: 838081
Whiteboard: [release28] p=0 r=ff28

Updated

5 years ago
Attachment #8374624 - Flags: review?(sfoster) → review+

Updated

5 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: [release28] p=0 r=ff28 → [release28] p=1 s=it-30c-29a-28b.1 r=ff28
https://hg.mozilla.org/mozilla-central/rev/2c154d398ab2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30

Comment 5

5 years ago
Are we going to uplift this to beta?
(In reply to Jim Mathies [:jimm] from comment #5)
> Are we going to uplift this to beta?

We don't have a fix for bug 969356 yet, that's why I'm holding this one.
Now that bug 969356 has landed and is verified we can uplift this one. Juan, can you verify it?
Flags: needinfo?(jbecerra)
Went through the following verification process using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-24-03-02-03-mozilla-central/

Used the following test cases

- Scrolled through the about:start screen window right after an installation
- Added several website tiles into the "Top Sites" category and scrolled through about:start
- Added several website tiles into the "Bookmarks" category and scrolled through about:start
- Ensured that there was enough website tiles under "Recent History" and scrolled through about:start
- Scrolled through the about:start using several methods (scroll bars, mouse wheel, keyboard arrows, touch)
- Went through all of the above test cases using several variations of snapped view
- Went through the following test cases using both the X1 Carbon and the Surface Pro 2

I did find Bug #976278 when going through this issue. Marking this as verified as the original issue has been fixed.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jbecerra)
Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28 → [release28] p=1 s=it-30c-29a-28b.1 r=ff28 [qa+]
Comment on attachment 8374624 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This is a workaround for bug 970942.
User impact if declined: No watermark will be displayed in metro's start page. It's the most visible piece of branding we have on start page
Testing completed (on m-c, etc.): On m-c since 02/13. Also QA tested, see comment #8
Risk to taking this patch (and alternatives if risky): Very low, css change that affects metro only. Note that bug 969356 also impacts the watermark and would be better if both could be uplifted.
String or IDL/UUID changes made by this patch: none
Attachment #8374624 - Flags: approval-mozilla-beta?
Attachment #8374624 - Flags: approval-mozilla-aurora?
Attachment #8374624 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/e245c793a38e
status-firefox29: --- → fixed
status-firefox30: --- → fixed
Attachment #8374624 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
status-b2g-v1.3: --- → fixed
Changing this back to resolved, will need to verify Aurora/BETA. Marking Nightly as verified as per comment #8
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-firefox30: fixed → verified
Went through the following verification process using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-26-00-40-01-mozilla-aurora/

- Went through the original test cases from comment #0
- Went through all the test cases from comment #8

Patch didn't make it into Firefox 28.0b6, waiting for a newer BETA to complete verification.
status-firefox29: fixed → verified
Went through the following verification process using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b7/win32/en-US/

- Went through the original test case from comment #0
- Went through all of the test cases from comment #8
- Went through the above test cases using both the X1 Carbon and the Surface Pro 2
Status: RESOLVED → VERIFIED
status-firefox28: fixed → verified
You need to log in before you can comment on or make changes to this bug.