Closed Bug 973886 Opened 6 years ago Closed 5 years ago

Blog Account for the Mozilla SeaMonkey Project

Categories

(Infrastructure & Operations :: IT-Managed Tools, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mcsmurf, Assigned: cturra)

References

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1084] )

The Mozilla SeaMonkey Project currently has its blog on weblogs.mozillazine.org, which is encouraging users to move somewhere else (also that blog host is mostly not maintained anymore).
I would very much appreciate if we could get a blog at blogs.mozilla.org/seamonkey/ so that we could retire the mozillazine blog for good.
I have an existing LDAP account at mcsmurf[a]mcsmurf.de if that helps, you can use it for access control for that blog.
Assignee: server-ops → server-ops-webops
Component: Server Operations → WebOps: IT-Managed Tools
Product: mozilla.org → Infrastructure & Operations
QA Contact: shyam → nmaul
:mcsmurf - all new blog requests must get approval from PR. i have copied a couple folks here for their feedback here.
Flags: needinfo?(vponell)
Flags: needinfo?(lnakajima)
OS: Windows 8.1 → All
Hardware: x86_64 → All
Ok, I see.
Just a quick update, this has been kicked higher up the management chain. I'll leave the NEEDINFO's as-is for now, because that's probably the route the answer will come back down through.

Sorry!
As a note, if we might be uncomfortable with having a mozilla.org domain on it, and it might be easy to run it under a different domain name, I can easily config the seamonkey-project.org DNS to point something to wherever this may run. This just in case we might want to avoid slapping "mozilla" on it.
I don't really know what this project is about but don't have an issue with a blog for it if it is needed for your project to move forward. Thanks
Flags: needinfo?(lnakajima)
Flags: needinfo?(vponell)
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #4)
> [...] and it might be easy to run it under a different domain name, I can
> easily config the seamonkey-project.org DNS to point something to wherever
> this may run.

Something like blog.seamonkey-project.org would be nice, also to keep the blog close to the project (even if at least visually).
Is there anything else that's blocking this bug from completion (of course IT needs resources to create the actual account :)?
Someone can help us here to get this bug moving...?
Flags: needinfo?(cturra)
we're discussing this request internally to decide the right place to put it. at this point, i don't have an answer, so cannot provide a solution, but will keep this bug posted as i know more. unfortunately i cannot commit to a time frame for that since there are a couple moving pieces here -- we're throwing around some new ideas that have to be vetted up the chain. anyway, stay tuned.
Flags: needinfo?(cturra)
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/147]
Ping...?
Assignee: server-ops-webops → srich
sean, or jake, can we please get a brief status update, whats blocking this, etc?
Flags: needinfo?(srich)
Flags: needinfo?(nmaul)
Justin,

I have reviewed this and wanted to let you know that we will have a technical path forward quite soon. The one thing I am unsure of is if you settled on a domain. Further do you have the domain purchased and / or the DNS set up? If not the DNS will need to point to 63.245.217.86 and I will need to know what the fqdn is.

Thanks
Flags: needinfo?(srich)
Flags: needinfo?(nmaul)
:jd,

I wasn't clear on if we were to use a mozilla run domain/DNS or our own.

If our own that is fine, and we can have KaiRo setup blog.seamonkey-project.org to point at 63.245.217.86 for us.

KaiRo owns the seamonkey-project.org domain and DNS server, and can easily setup a subdomain to point at the blog.

Is this the path forward we shall take?
Flags: needinfo?(kairo)
Flags: needinfo?(jcrowe)
Justin,

I believe that will be the approach that will allow us to get something up and running the fastest. As long as you are happy with that then I would say, yea, lets go for it.
Flags: needinfo?(jcrowe)
Depends on: 1053543
per the comment :jd made above, we're well on track to getting this blog sorted out. this and a couple similar requests have been a catalyst for us to review our current blog platform setup and ultimately resulted in us doing some (much needed) overhauling :)

so where we're at now? we will need :KaiRo to add a A record to DNS so blog.seamonkey-project.org resolves to 63.245.217.86. 

:Callek - once the DNS record is added (and propagated) you can access the wordpress admin panel at the following location using your ldap credentials:

  http://blog.seamonkey-project.org/wp-admin/


from here, you should be able to add other blog users. ping me if you're having any issues with that and i can help you out.

there are a couple outstanding items we'll probably need to discuss:

 1) the final decision on bug 1053543 re: is ssl a requirement
 2) will you need a custom theme
/me grabbing this from :srich.
Assignee: srich → cturra
OK, DNS for blog.seamonkey-project.org and blog.seamonkeyproject.org has been set and the server returns the right address when querying locally:

linz:~ # host blog.seamonkey-project.org localhost
Using domain server:
Name: localhost
Address: 127.0.0.1#53
Aliases: 

blog.seamonkey-project.org has address 63.245.217.86

linz:~ # host blog.seamonkeyproject.org localhost
Using domain server:
Name: localhost
Address: 127.0.0.1#53
Aliases: 

blog.seamonkeyproject.org has address 63.245.217.86


The entry can take a bit to propagate through the DNS system. I also see a blog entry page when accessing the site via lynx from the server. :)
Flags: needinfo?(kairo)
I see blog.seamonkeyproject.org has propagated. As this was not told to us previously it was not set to work on our servers. I have updated the relevant configurations and set it as a secondary domain pointing to the same blog.

blog.seamonkey-project.org is still not resolving to the correct IP for me. I only mention as it is the primary domain for the blog so there is an automatic redirect to it when accessing by the secondary domain.

Also we still need information from you for the questions in comment 15.

Regards
no custom theme at this time

ssl termination can be left out at this time, we'll add it in sometime after mozilla owns the DNS (being transferred in another bug)
:jd, while we're at it, can you temporarily enable the moveable type importer?

Alternatively I can provide you with a moveable type export.

We're looking to import http://weblogs.mozillazine.org/seamonkey/ into our new blog.

http://codex.wordpress.org/Importing_from_Movable_Type_to_WordPress describes the process I hope to follow.

We don't need to do anything fancy, this is mainly a "it sounds easy" choice.
I enabled the movable type importer for your blog. Please let me know when you have finished with it so I can disable it again.

Thanks
and the URL is not like the one in the instructions you have, it is

https://blog.seamonkey-project.org/wp-admin/admin.php?import=mt

regards
Per IRC the import is finished. I have disabled / removed the plugin.

I believe this wraps things up. If you have additional requests please feel free to file a new bug.

Cheers
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
:jd,

So apparantly I just tried to create a login for my own community LDAP (Callek@gmail.com) [among a few other logins] and it failed to let me login as that.

The same creation process worked for KaiRo with his moco LDAP.

I confirmed my password is correct (afaict, hard to remember what I have set for moco ldap login and community login these days)

Can you confirm that this should work for non-employees (most admin/editors will be non employees but all will have LDAP)

I'm happy to be a guinnea pig here.
Status: RESOLVED → REOPENED
Flags: needinfo?(jcrowe)
Resolution: FIXED → ---
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/147]
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1084]
This should work. If you are able to add the user from LDAP you should be able to login. I looked at the user and I see it is an ldap user and I looked in LDAP and the dn is set correctly. There was some unrelated login trouble on the platform this morning which you might have hit, can you try again and see if it works now that that issue has been resolved? If not, you might try logging into the password reset app for that account to make sure you are using the correct password (no need to change a login will verify it):

https://passwordreset.mozilla.org/
Flags: needinfo?(jcrowe)
Thanks Jason,

Looks to be PEBKAC, my community LDAP isn't working. I wonder if I got roped into some heartbleed password-reset-force at some point by accident as my community LDAP. (since it is a member of s-g) but without an e-mail notice to tell me so

I'll get a new bug on file soon to get it reset.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Depends on: 956561
Duplicate of this bug: 956561
No longer depends on: 956561
Blocks: 1147825
You need to log in before you can comment on or make changes to this bug.