Closed Bug 974332 Opened 9 years ago Closed 9 years ago

Unable to open links in new tab using right click in e10s

Categories

(Firefox :: Menus, defect)

30 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---
firefox30 --- affected

People

(Reporter: walker.pilot.b, Assigned: ally)

References

(Blocks 1 open bug)

Details

I have nightly 30.0a1 running on windows 8.1 (64 bit)
when I have e10 enabled and I go to a website with links right clicking them and selecting "open in new tab" does not work.
Steps to reproduce:
open nightly
go to about:config (if you have not done this already) and search browser.tabs.remote and tick it to "true"
restart nightly
click file (menu bar)and click "new e10 window"
then in the new windows go to site with many links (ex: en.wikipedia.org)
right click a link and click "open in new tab"

expected result:
link opens in new tab

actual result:
link does not open in new tab

also if I may add opening the link in a new window works fine
Confirmed on Windows 8.
Assignee: nobody → mz_mhs-ctb
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: e10s
Component: Untriaged → Tabbed Browser
Michael, did you mean to assign the bug to yourself?
Flags: needinfo?(mz_mhs-ctb)
Gavin, is there a particular way we should tag or otherwise mark up or sort bugs coming in that are related to e10s? I added this as a blocker to the meta/tracking bug which is assigned to you, so I thought I'd ask.  Thanks!
Flags: needinfo?(gavin.sharp)
Oops. Thanks for pointing that out!
Assignee: mz_mhs-ctb → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(mz_mhs-ctb)
(In reply to Liz Henry :lizzard from comment #3)
> Gavin, is there a particular way we should tag or otherwise mark up or sort
> bugs coming in that are related to e10s?

I think blocking the meta bugs is all that is needed. Note that there is also fxe10s under the e10s bug if it's related to the front-end. I think this falls under there until further investigation proves otherwise.
Blocks: fxe10s
No longer blocks: e10s
Summary: Unable to open links in new tab using right click in e10 → Unable to open links in new tab using right click in e10s
I suspect this is a dupe of bug 947895, but let's wait and see.

And yes, fxe10s is the right bug to block.
Flags: needinfo?(gavin.sharp)
Component: Tabbed Browser → Menus
Assignee: nobody → ally
Blocks: e10s-m1
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.