Closed Bug 976537 Opened 6 years ago Closed 6 years ago

Crash in NFC shutdown.

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, firefox28 wontfix, firefox29 wontfix, firefox30 fixed, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S2 (28feb)
blocking-b2g 1.3+
Tracking Status
firefox28 --- wontfix
firefox29 --- wontfix
firefox30 --- fixed
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: dougc, Assigned: dougc)

References

Details

Attachments

(1 file)

Seeing crashes in NFC Shutdown due to sNfcConsumer being NULL.  This seems to occur if there are other problems in SystemWorkerManager initialization and it bails out and calls NfcConsumer::Shutdown in the exit path.

Program received signal SIGSEGV, Segmentation fault.
0xb4936096 in mozilla::ipc::NfcConsumer::Shutdown () at ../../../src/ipc/nfc/Nfc.cpp:314
314	    sNfcConsumer->mShutdown = true;
(gdb) back
#0  0xb4936096 in mozilla::ipc::NfcConsumer::Shutdown () at ../../../src/ipc/nfc/Nfc.cpp:314
#1  0xb4f7b35e in mozilla::dom::gonk::SystemWorkerManager::Shutdown (this=0x1669598) at ../../../../src/dom/system/gonk/SystemWorkerManager.cpp:132
#2  0xb4f7b6fa in mozilla::dom::gonk::SystemWorkerManager::FactoryCreate () at ../../../../src/dom/system/gonk/SystemWorkerManager.cpp:161
#3  0xb4d9eafc in SystemWorkerManagerConstructor (aResult=0xbe9109f8, aIID=..., aOuter=<optimized out>) at ../../../src/layout/build/nsLayoutModule.cpp:290
#4  SystemWorkerManagerConstructor (aOuter=<optimized out>, aIID=..., aResult=0xbe9109f8) at ../../../src/layout/build/nsLayoutModule.cpp:291
Comment on attachment 8381384 [details] [diff] [review]
Guard against crash in NFC shutdown when the sNfcConsumer is NULL

Review of attachment 8381384 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch. Add r=me.

May I know which device you're testing on? Nexus 4?
Attachment #8381384 - Flags: review?(allstars.chh) → review+
Assignee: nobody → dtc-moz
Blocks: b2g-nfc
(In reply to Yoshi Huang[:allstars.chh] from comment #2)
> Comment on attachment 8381384 [details] [diff] [review]
> Guard against crash in NFC shutdown when the sNfcConsumer is NULL
> 
> Review of attachment 8381384 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Nice catch. Add r=me.
 
Thank you for the quick review.

> May I know which device you're testing on? Nexus 4?

Yes, the Nexus 4.

btw This path was taken when Wifi debugging was enabled, see bug 976455.
Keywords: checkin-needed
Hi Douglas
Due to the new policy we cannot land patches right now.
Let's ask Ken for this.
Flags: needinfo?(kchang)
Keywords: checkin-needed
After discussing with Yoshi, it causes regression.
Flags: needinfo?(kchang)
After discussed with Ken, nominate this with 1.3+
blocking-b2g: --- → 1.3?
Flags: needinfo?(kchang)
It is 1.3+.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(kchang)
Comment on attachment 8381384 [details] [diff] [review]
Guard against crash in NFC shutdown when the sNfcConsumer is NULL

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 933635
User impact if declined: Crash due to SIGSEGV
Testing completed: verified on Nexus-4
Risk to taking this patch (and alternatives if risky): Low. This patch just checks if the pointer is valid or not before accessing it.
String or UUID changes made by this patch: No
Attachment #8381384 - Flags: approval-mozilla-b2g28?
Attachment #8381384 - Flags: approval-mozilla-b2g28? → approval-mozilla-b2g28+
https://hg.mozilla.org/mozilla-central/rev/34dd23453855
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.