Closed Bug 977295 Opened 10 years ago Closed 6 years ago

[B2G][Camera] Rapidly tapping record/stop for video with APZ enabled is unpredictable

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.4 --- affected

People

(Reporter: justindarc, Unassigned)

Details

This was discovered while investigating Bug 975481 which was resolved by the patch for Bug 975453. However, an issue with APZ enabled still remains.

If you enter video mode and rapidly tap the record/stop button when APZ is enabled, you can subsequently tap *anywhere* on the screen and a 'click' event will continue to be triggered on the record/stop button.

Here is a video demonstration:
http://www.youtube.com/watch?v=OtqtITX545M

You will first see with APZ enabled that after the rapid clicking on the 'capture' button, I can tap anywhere on-screen and it still triggers the 'click' event on the 'capture' button. Then, I turn off APZ, restart the Camera app and it works as expected.
Flags: needinfo?(21)
Blocks: gaia-apzc
Does this affect 1.3 or 1.4? Or both?
I was testing in 1.4. I'll try and reproduce in 1.3.
QA Wanted to check the behavior on 1.3.
Keywords: qawanted
We spoke on IRC and this seems like an APZC bug where the event queue is busted. Looking at the video I'm not confident it should block the release but it worth beeing fixed. I'm worried that there is some easier way to trigger it.
Flags: needinfo?(21)
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #4)
> We spoke on IRC and this seems like an APZC bug where the event queue is
> busted.

Do you have more details on this?
Unable to reproduce on 1.3 or 1.4 Buri with APZ enabled. 
Could device type be a factor?

-------------------------------------

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140227004003
Gaia: ad504390a7a5f094f8967f80a0f29a1e6552535e
Gecko: 6bd9b70a1b6c
Version: 28.0
Firmware Version: v1.2-device.cfg

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140227040202
Gaia: 22d48b62df7901ad45044f66e15e7d8943884a06
Gecko: a98a1d78817f
Version: 30.0a1
Firmware Version: v1.2-device.cfg
Keywords: qawanted
My understanding of APZ is very limited, but there does seem to be some issue with the graphics hardware on Helix (see bug 965402).. so maybe this is specific to this device?
(In reply to Justin D'Arcangelo from comment #7)
> My understanding of APZ is very limited, but there does seem to be some
> issue with the graphics hardware on Helix (see bug 965402).. so maybe this
> is specific to this device?

That video shows off loads of problems showcasing bug 965402 actually.

I'm not even sure we can trust Helix on 1.4 to be honest - the hardware is extremely out of date with 1.4.
No longer blocks: gaia-apzc-2
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.