Closed Bug 949585 (gaia-apzc-2) Opened 6 years ago Closed 5 years ago

[meta] APZC for all of gaia follow up issues

Categories

(Firefox OS Graveyard :: Gaia, defect, P1)

All
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
2.0 S1 (9may)

People

(Reporter: milan, Assigned: kats)

References

Details

(Keywords: perf, Whiteboard: [c=handeye p= s=2014.05.09.t u=])

+++ This bug was initially created as a clone of Bug #909877 +++

Currently subframe scrolling in Gaia apps happens using BrowserElementPanning.js and occurs synchronously. This bug tracks all the work needed to switch that over to AsyncPanZoomController's async panning.

This bug collects the non-blocking issues for enabling APZC on Gaia apps in the first place.
Flags: needinfo?(nhirata.bugzilla)
Blocks: 942267
Vikram, this is a meta bug for 1.4 work on APZC.  If there are individual bugs under this one that you think must be done for 1.3, please make them block the 1.3 CS bug directly.
No longer blocks: 942267
Depends on: 963156
Not blocking - APZC followups are tracking all non-blocking issues & this is a meta bug.
blocking-b2g: 1.4? → ---
Blocks: 960372
No longer blocks: 967587
Depends on: 967587
Depends on: 969442
No longer depends on: 969442
Depends on: 971335
Depends on: 973100
Depends on: 973092
Depends on: 973096
Depends on: 973105
Depends on: 959782
Depends on: 973980
Assignee: nobody → bugmail.mozilla
blocking-b2g: --- → 1.4+
Depends on: 972675
Depends on: 965389
Clearing blocking flag - per a drivers' decision, QC needs to nominate individual actionable bugs to be FC & QC blockers, not block on meta bugs.

putting needinfo on mvines to review the dependencies here to determine which ones should fall under the FC & CS meta for 1.4.
No longer blocks: 960372
blocking-b2g: 1.4+ → ---
Flags: needinfo?(mvines)
Flags: needinfo?(mvines)
(In reply to Jason Smith [:jsmith] from comment #3)
> Clearing blocking flag - per a drivers' decision, QC needs to nominate
> individual actionable bugs to be FC & QC blockers, not block on meta bugs.
> 
> putting needinfo on mvines to review the dependencies here to determine
> which ones should fall under the FC & CS meta for 1.4.

Let's please not.  I mean, I don't mind if Michael does it, but we're asking him to make low level decisions that he really should not have to.  We have to fix APZC, and I think that's all QC cares about.  Please leave 1.4+ on this, and have it block bug 960372 until we make sure we have something in place to make sure we don't miss functionality required for 1.4
Blocks: 960372
blocking-b2g: --- → 1.4+
Depends on: 796474
No longer depends on: 959782
Depends on: 977598
No longer depends on: 977295
Status: NEW → ASSIGNED
Priority: -- → P1
No longer depends on: 973980
Taking this off the blocker list for bug 960372 since this is a meta-bug. Individual bugs under this one are already blocking bug 960372 directly where appropriate.
No longer blocks: 960372
Sorry for the bugzilla churn.  QC would prefer to tack the individual bugs - as well as - this one, so I'll make this back into a blocker.  We will mark this bug fixed when we consider that all 1.4 blocker issues are resolved.
Blocks: 960372
Whiteboard: [c= p= s= u=] → [c=handeye p= s= u=1.4]
Depends on: 982141
kats, I see that the Marionette issue (bug 958036) no longer blocks this; will this work not be breaking Marionette tests?  If it does, we should add this blocker back, since we don't want lose test coverage when this lands.
Sorry, this bug at one point was tracking regressions that needed to be fixed for 1.4 so I removed that dependency. Putting it back. However note that there isn't anything to "land" as part of this bug; APZC is already enabled in all Gaia apps and has been the case for a while now. This bug is simply tracking fallout from that.
Depends on: 958036
Thanks for the clarification!
Depends on: 979720
Depends on: 984673
No longer depends on: 984673
No longer blocks: 960372
We're now tracking 1.4+ directly, rather than through this meta bug.
blocking-b2g: 1.4+ → ---
Depends on: 989403
Flags: needinfo?(nhirata.bugzilla)
(In reply to Milan Sreckovic [:milan, travelling, maybe slow to respond] from comment #6)
> We will mark
> this bug fixed when we consider that all 1.4 blocker issues are resolved.

As none of the remaining dependencies are on the 1.4 blocker list, I'm going to put this meta bug to rest. Any further APZC issues can just be filed in the Core::Panning and Zooming component and will be dealt with as usual.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [c=handeye p= s= u=1.4] → [c=handeye p= s=2014.05.09.t u=]
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.