Closed Bug 978934 Opened 6 years ago Closed 6 years ago

[e10s] HTML form's dropdown lists are rendered using non-native style on OS X

Categories

(Core :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: cpeterson, Unassigned)

References

()

Details

Attachments

(1 file)

STR:
1. Compare the style of the dropdown list in an e10s and non-e10s window on any Bugzilla bug or http://www.w3schools.com/html/tryit.asp?filename=tryhtml_select3

See the attached screenshot showing a Bugzilla dropdown list with wrong font and without a scrollbar.
Well, this is a progression, really. In the e10s window it matches the native OS X style which is good, IMHO. Currently, Firefox shows a Windows-ish dropdown for all non-e10s tabs (while browser chrome uses native dropdowns as well), see: Bug 402625. 

I'd rather see this stay (and fixed for non-e10s) but this behaviour may hint to a bug.
See Also: → 402625
See Also: → 674443
As Florian said, e10s uses native styling for the select popup. I see the same native styling on Windows.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
See Also: → 1012212
Duplicate of this bug: 1012212
(In reply to Tim Nguyen [:ntim] from comment #2)
> As Florian said, e10s uses native styling for the select popup. I see the
> same native styling on Windows.

Should I file a new bug for linux or will the stying for linux be handled in bug 402625? Cause there neither e10n or non-e10n have the correct look.
See Also: → 1049285
You need to log in before you can comment on or make changes to this bug.