The default bug view has changed. See this FAQ.

Australis: Bookmarks Widget panel is too narrow for contents (causing horizontal overflow), which shift to the left when mousing over it the first time

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: Gijs)

Tracking

(Blocks: 1 bug, {jp-critical, regression})

30 Branch
Firefox 30
x86_64
Windows 8.1
jp-critical, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29+ fixed, firefox30+ verified)

Details

(Whiteboard: [Australis:P3+] [good first verify] [testday-20140523])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
STR
1. Start Nightly
2. Click Bookmarks Widget
3. Move mouse pointer to the panel

Actual Results:
contents (bookmarks items, etc.) shift to the left
(Reporter)

Updated

3 years ago
Blocks: 939862
Keywords: regression
(Reporter)

Comment 1

3 years ago
Created attachment 8387096 [details]
screen capture
(Reporter)

Comment 2

3 years ago
Regression window
Good:
https://hg.mozilla.org/integration/fx-team/rev/8be6b5960a48
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140304064456
Bad:
https://hg.mozilla.org/integration/fx-team/rev/6ffd90abc060
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140304065156
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=8be6b5960a48&tochange=6ffd90abc060
Regressed by:
3d267302cbd6	Blake Winton — Bug 972405 - Make the bookmarks panel look like all the other sub-panels. ui-r=shorlander, r=dao
Blocks: 972405
Whiteboard: [Austalis:P3+]
Whiteboard: [Austalis:P3+] → [Australis:P3+]
(Assignee)

Comment 3

3 years ago
I believe this is fixed by Blake's patch in bug 979378.
Depends on: 979378
(Assignee)

Comment 4

3 years ago
Actually, I can't reproduce this even on vanilla nightly from the 6th, on Win 7 glass. Alice, do you know if this is Windows 8 specific or something?
Flags: needinfo?(alice0775)
(Reporter)

Comment 5

3 years ago
I cannot reproduce on Windows7 Aero/Classic.

Probably, this is Winddows8.1 desktop specific.
Flags: needinfo?(alice0775)
(Assignee)

Comment 6

3 years ago
Can't reproduce on newer builds from fx-team --> marking wfm. I expect bug 979378 probably fixed this (but I'm not sure that's what it was).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

3 years ago
(In reply to Alice0775 White from comment #5)
> I cannot reproduce on Windows7 Aero/Classic.
> 
> Probably, this is Winddows8.1 desktop specific.

Err,
I can reproduce the problem on Windows7 if I set system font to "Meiryo UI" instead "Meiryo"(default of Japanese edition of Windows7).

"Meiryo UI" is default system font of Japanese edition of Windows8.1 and 8.



I can still reproduce.
https://hg.mozilla.org/mozilla-central/rev/0d70e6efa22c
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140307122629
Status: RESOLVED → REOPENED
tracking-firefox30: --- → ?
Keywords: jp-critical
Resolution: WORKSFORME → ---
(Reporter)

Updated

3 years ago
Status: REOPENED → NEW
(Assignee)

Comment 8

3 years ago
(In reply to Alice0775 White from comment #7)
> (In reply to Alice0775 White from comment #5)
> > I cannot reproduce on Windows7 Aero/Classic.
> > 
> > Probably, this is Winddows8.1 desktop specific.
> 
> Err,
> I can reproduce the problem on Windows7 if I set system font to "Meiryo UI"
> instead "Meiryo"(default of Japanese edition of Windows7).
> 
> "Meiryo UI" is default system font of Japanese edition of Windows8.1 and 8.
> 
> 
> 
> I can still reproduce.
> https://hg.mozilla.org/mozilla-central/rev/0d70e6efa22c
> Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
> ID:20140307122629

Blargh. The problem is the -moz-box-flex: 0 that was introduced on the footer text, but I don't know why, or why that has different effects depending on the font size. :-\

Mike, weren't we struggling with centering the footer text? Can we fix this some way?
Flags: needinfo?(mconley)
(Assignee)

Comment 9

3 years ago
> Blargh. The problem is the -moz-box-flex: 0 that was introduced on the
> footer text, but I don't know why, or why that has different effects
> depending on the font size. :-\

Clearly I meant font family...
(Assignee)

Comment 10

3 years ago
Let's downgrade this to a P3- though, if it's just people with these fonts that hit it - Windows 8 is still a tiny minority, and users with that pref will be an even smaller minority of users.
Whiteboard: [Australis:P3+] → [Australis:P3-]
(Assignee)

Comment 11

3 years ago
So it seems there are other conditions where people are seeing this, per bug 969592 comment 28 and further, so I'm upgrading this to a P3+. Stuff gets cut off and looks bad and there's gaps between the main menu and submenu. :-(
No longer depends on: 979378
Summary: Australis: Bookmarks Widget panel contents shift to the left when mouse over it at the first time → Australis: Bookmarks Widget panel contents overflow, and shift to the left when mouse over it at the first time
Whiteboard: [Australis:P3-] → [Australis:P3+]
(Assignee)

Updated

3 years ago
Summary: Australis: Bookmarks Widget panel contents overflow, and shift to the left when mouse over it at the first time → Australis: Bookmarks Widget panel is too narrow for contents (causing horizontal overflow), which shift to the left when mousing over it the first time
(Assignee)

Comment 12

3 years ago
G_HZ, let's keep the rest of this in here... but can you tell me the DPI of your Win 7 machine, ie the settings under Control Panel > Appearance and Personalization > Display > "Make text and other items larger or smaller" ? Is it set to 100% or to something else?
Flags: needinfo?(gandalf_hz)

Comment 13

3 years ago
OK, sorry

100%


Work properly with the Vivaldi font size 8, but it's unreadable

http://i.imgur.com/TirRe5w.png
http://i.imgur.com/4Z1BA8K.png

font setting
http://i.imgur.com/HLxfvYi.png
Flags: needinfo?(gandalf_hz)
(Assignee)

Comment 14

3 years ago
Blake, can you tell us why the flex: 0 was added?

I talked with Stephen and we can probably increase the width for the single-view panels so they don't look so cramped.
Flags: needinfo?(mconley) → needinfo?(bwinton)
(Assignee)

Comment 15

3 years ago
(In reply to :Gijs Kruitbosch from comment #14)
> I talked with Stephen and we can probably increase the width for the
> single-view panels so they don't look so cramped.

More specifically, he said 30em would probably be OK.
(In reply to :Gijs Kruitbosch from comment #14)
> Blake, can you tell us why the flex: 0 was added?

Yep, although it'll be tricky with all ascii diagrams…  (Do you remember the drawing on the whiteboard?  That'll help.)

So, in the case where we have a shortcut and a label, we want them both to be centered, like this:
|---|label|-|shortcut|---|
but if the label has a flex of 1, they're both centered like this:
||label-------||shortcut|| (Or ||----label---||shortcut||, or whatever)
which isn't great.

On the other hand, the current situation doesn't sound great either, so if you wanted to revert this, feel free.  (Also, Philipp had similar problems getting other footer panels centered, so perhaps we should just make them all work the way he did…)
Flags: needinfo?(bwinton)
tracking-firefox30: ? → +
(Assignee)

Updated

3 years ago
Duplicate of this bug: 982543
I'll see what I can do here.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Assignee: jaws → nobody
Status: ASSIGNED → NEW
(Reporter)

Comment 19

3 years ago
Today, I notice this problem happens on Windows 7.
And Aurora29.0a2 is also affected.

And, The menu items are cut off on a localized version of Aurora29.0a2.
status-firefox29: --- → affected
tracking-firefox29: --- → ?
(Assignee)

Comment 20

3 years ago
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #18)
> I'll see what I can do here.

Jared, you unassigned, did you not find anything? I may be able to have a look tomorrow... maybe we can just add the flex back?
Flags: needinfo?(mconley)
Flags: needinfo?(jaws)
Yeah, I couldn't get anything to work here.
Flags: needinfo?(jaws)

Comment 22

3 years ago
FYI:
Bug 982543 seems to be fixed on 29.0a2 (2014-03-15).

Comment 23

3 years ago
The update today is very interesting.

before
http://i.imgur.com/wW6NcMU.png
http://i.imgur.com/qF7ZIj6.png

after
http://i.imgur.com/dxeImpG.png
http://i.imgur.com/tqSVHmP.png


The font size is correct. There remains the problem of width

Nightly, Windows 7 x64
Windows font Tahoma Size 8
DPI 100%
(Assignee)

Comment 24

3 years ago
Created attachment 8391982 [details] [diff] [review]
make Australis' standalone subview panels wider,

This actually works for me, surprisingly. I guess it's just to do with the footer overflowing depending on the font size used. I made the other standalone subviews use the same styling, which then showed the border of the panel-subviews container (which shows the border when opening subviews), so I display:none it for standalone panels...
Attachment #8391982 - Flags: review?(bmcbride)
(Assignee)

Updated

3 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8391982 [details] [diff] [review]
make Australis' standalone subview panels wider,

Review of attachment 8391982 [details] [diff] [review]:
-----------------------------------------------------------------

This was fun to reproduce.
Attachment #8391982 - Flags: review?(bmcbride) → review+
 https://hg.mozilla.org/integration/fx-team/rev/6ce4ff67f3f9
https://hg.mozilla.org/mozilla-central/rev/6ce4ff67f3f9
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-firefox30: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
tracking-firefox30: + → -
(Assignee)

Updated

3 years ago
Flags: needinfo?(mconley)
(Assignee)

Comment 28

3 years ago
Comment on attachment 8391982 [details] [diff] [review]
make Australis' standalone subview panels wider,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 973502 / bug 972405
User impact if declined: users with non-default fonts on Win 7 and Win 8, and in some locales like Japanese, users with the default Windows font, will see the following symptoms in the bookmarks menu: cut off labels, shifting content, "missing" arrows for menus that have submenus (shifted out of view), and space between the parent menu and submenus when opening the submenus.
Testing completed (on m-c, etc.): local, on m-c
Risk to taking this patch (and alternatives if risky): very low. We've effectively just made the menu wider, and that makes the problem go away
String or IDL/UUID changes made by this patch: none
Attachment #8391982 - Flags: approval-mozilla-aurora?
Attachment #8391982 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 29

3 years ago
remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/b85a078f692f
status-firefox29: affected → fixed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 984347
tracking-firefox30: - → ?
tracking-firefox30: ? → +
tracking-firefox29: ? → +

Updated

3 years ago
Whiteboard: [Australis:P3+] → [Australis:P3+] [good first verify]
Verified fixed using Windows 7 64 bit and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0. Verified in latest Nightly as well, setting the STATUS to VERIFIED.
Status: RESOLVED → VERIFIED
Whiteboard: [Australis:P3+] [good first verify] → [Australis:P3+] [good first verify] [testday-20140523]

Comment 32

3 years ago
I can also confirm this as verified fixed with latest Fx 30 beta 7 (Build ID: 20140522105902) on Windows 8.1 x64.
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.