Closed Bug 98466 Opened 23 years ago Closed 16 years ago

SAP Internet Transaction Server WebGUI drop-down menus not working

Categories

(Tech Evangelism Graveyard :: English US, defect, P2)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: brianclark44, Unassigned)

References

()

Details

(Whiteboard: [bae:20020116])

Attachments

(6 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.3+) Gecko/20010905
BuildID:    2001090508

When using SAP's WebGUI web application (based on their Internet Transaction
Server, version 4.6D C4 patch level 186), the drop-down menus from the top menu
bar don't work correctly.  They drop-down, but none of the items in the
drop-down menu are selectable.  

I tested with Mozilla Build 2001090508 for MacOS 9.x as well as with Build
2001090503 for Win2k.  

The curious thing is that they work fine with Netscape 6.1 for Mac, as well as
with Netscape 6.1 for Windows on my Win2K PC.  

Reproducible: Always
Steps to Reproduce:
1.login
2.click on one of the menus
3.notice that you can't select anything

Expected Results:  The menu should be colored a "light tan", not plain white,
and the items should be selectable.

I attached the complete HTML of the web page, but the offending code seems to be
right here.  This is a snippet of attached page.   


<script>

arMenu_1_1_3= new Array("Hold data",'ON','STD',"1/3/1",'-',"Set
data",'ON','STD',"1/3/2",'-',"Delete data",'ON','STD',"1/3/3",'-',"Own
data",'ON','STD',"1/3/4",'-',"Expand favorites",'ON','STD',"1/3/5",'-');
arMenu_1_1_4_4= new Array("Extended table
maintenance",'ON','STD',"1/4/4/1",'-',"View cluster
maintenance",'ON','STD',"1/4/4/2",'-');
arMenu_1_1_4_5= new
Array("Sessions",'ON','STD',"1/4/5/1",'-',"Logs",'ON','STD',"1/4/5/2",'-',"Recorder",'ON','STD',"1/4/5/3",'-',"-",'OFF','STD',"1/4/5/4",'-',"Restart
transaction",'OFF','STD',"1/4/5/5",'-',"Delete
transaction",'OFF','STD',"1/4/5/6",'-',"Next
transaction",'OFF','STD',"1/4/5/7",'-',"-",'OFF','STD',"1/4/5/8",'-',"Process/foreground",'OFF','STD',"1/4/5/9",'-',"Display
errors only",'OFF','STD',"1/4/5/10",'-',"Expert mode
on",'OFF','STD',"1/4/5/11",'-',"Expert mode
off",'OFF','STD',"1/4/5/12",'-',"-",'OFF','STD',"1/4/5/13",'-',"Cancel",'OFF','STD',"1/4/5/14",'-');
arMenu_1_1_4_6= new
Array("Recorder",'ON','STD',"1/4/6/1",'-',"-",'OFF','STD',"1/4/6/2",'-',"Process/foreground",'OFF','STD',"1/4/6/3",'-',"Display
errors
only",'OFF','STD',"1/4/6/4",'-',"-",'OFF','STD',"1/4/6/5",'-',"Cancel",'OFF','STD',"1/4/6/6",'-');
arMenu_1_1_4_8= new
Array("Record",'ON','STD',"1/4/8/1",'-',"-",'OFF','STD',"1/4/8/2",'-',"Cancel",'OFF','STD',"1/4/8/3",'-');
arMenu_1_1_4_9= new Array("Define job",'ON','STD',"1/4/9/1",'-',"Job
overview",'ON','STD',"1/4/9/2",'-');
arMenu_1_1_4_12= new
Array("Owner",'ON','STD',"1/4/12/1",'-',"Employee...",'ON','STD',"1/4/12/2",'-');
arMenu_1_1_4= new
Array("Reporting",'ON','STD',"1/4/1",'-',"QuickViewer",'ON','STD',"1/4/2",'-',"Output
controller",'ON','STD',"1/4/3",'-',"Table
maintenance",'ON','POP',"arMenu_1_1_4_4",'-',"Batch
input",'ON','POP',"arMenu_1_1_4_5",'-',"Fast
entry",'ON','POP',"arMenu_1_1_4_6",'-',"Direct
input",'ON','STD',"1/4/7",'-',"CATT",'ON','POP',"arMenu_1_1_4_8",'-',"Jobs",'ON','POP',"arMenu_1_1_4_9",'-',"Queue",'ON','STD',"1/4/10",'-',"SAP
Service",'ON','STD',"1/4/11",'-',"Appointment
calendar",'ON','POP',"arMenu_1_1_4_12",'-',"Business
Workplace",'ON','STD',"1/4/13",'-');
arMenu_1_1_5_8= new Array("Execute",'ON','STD',"1/5/8/1",'-',"Switch
on",'ON','STD',"1/5/8/2",'-',"Switch off",'ON','STD',"1/5/8/3",'-');
arMenu_1_1_5= new Array("Debug screen",'ON','STD',"1/5/1",'-',"Debug
ABAP",'ON','STD',"1/5/2",'-',"Debug system",'ON','STD',"1/5/3",'-',"Resource
usage",'ON','STD',"1/5/4",'-',"Autom. queue synchronous
processing",'ON','STD',"1/5/5",'-',"Performance
display",'ON','STD',"1/5/6",'-',"Performance
trace",'ON','STD',"1/5/7",'-',"Runtime
analysis",'ON','POP',"arMenu_1_1_5_8",'-',"Display authorization
check",'ON','STD',"1/5/9",'-');
arMenu_1_1_6_3= new Array("Office folders",'OFF','STD',"1/6/3/1",'-',"Menu
folders",'OFF','STD',"1/6/3/2",'-',"Local file",'OFF','STD',"1/6/3/3",'-');
arMenu_1_1_6= new
Array("Print",'OFF','STD',"1/6/1",'-',"Find...",'OFF','STD',"1/6/2",'-',"Save",'ON','POP',"arMenu_1_1_6_3",'-',"Send",'OFF','STD',"1/6/4",'-',"List
header",'OFF','STD',"1/6/5",'-');
arMenu_1_1= new Array("Create session",'ON','STD',"1/1",'-',"End
session",'ON','STD',"1/2",'-',"User
profile",'ON','POP',"arMenu_1_1_3",'-',"Services",'ON','POP',"arMenu_1_1_4",'-',"Utilities",'ON','POP',"arMenu_1_1_5",'-',"List",'ON','POP',"arMenu_1_1_6",'-',"Services
for object",'ON','STD',"1/7",'-',"Object history",'ON','STD',"1/8",'-',"Own
spool requests",'ON','STD',"1/9",'-',"Own jobs",'ON','STD',"1/10",'-',"Short
message",'ON','STD',"1/11",'-',"Status...",'ON','STD',"1/12",'-',"Log
off",'ON','STD',"1/13",'-');
arMenu_1_2= new Array("Application help",'ON','STD',"2/1",'-',"SAP
Library",'ON','STD',"2/2",'-',"Glossary",'ON','STD',"2/3",'-',"-",'OFF','STD',"2/4",'-',"Release
notes",'ON','STD',"2/5",'-',"-",'OFF','STD',"2/6",'-',"SAP Service
Marketplace",'ON','STD',"2/7",'-',"-",'OFF','STD',"2/8",'-',"Feedback",'ON','STD',"2/9",'-',"-",'OFF','STD',"2/10",'-',"Settings...",'ON','STD',"2/11",'-');
arMenu_1= new
Array("System",'ON','POP',"arMenu_1_1",'-',"Help",'ON','POP',"arMenu_1_2",'-');

	</SCRIPT>
the attached source code is not accesible.

reporter can you please attach a test case that can be accessed outside of 
your firewall?
Unfortunately, I cannot provide a test case outside of my firewall at this time.
 Is there anything else I can do to try and get you more information?  I will
attach a complete html page to try and give you more perspective on how this
page works.  However, the problem may lie in the css pages that are included.  I
will see if I can get copies of those as well and attach them.  
Brian, can you please make a local copy of the testcase, look at the code and 
dereference any links back to your internal website. The references back to your 
internal site is preventing us from looking at the page. If we try to access the 
test case you attached, we get the error:

Not Found

The requested URL /sap/its/mimes/webgui/99/style/generator.css was not found on 
this server.


Apache/1.3.19 Server at bugzilla.mozilla.org Port 80

The only way to see the code is by doing 
view-source:http://bugzilla.mozilla.org/showattachment.cgi?attach_id=51644

Making a local copy of the source at least allows us to see the coding, but it 
will still not render. There must be a dosen or more script elements refering to 
numerous .js files and a couple of link elements refering to .css files. There 
are iframes within the document as well.
Just curious but can you grab the source of:

<script LANGUAGE="JavaScript"
SRC="/sap/its/mimes/webgui/99/scripts/menu.js"></SCRIPT>

That looks like a hierMenus script (see bug 85104) especially with the code that
directly follows that.  In any case the menu.js would be helpful.  Can you
upload a copy of the menu.js from that as well, Brian?
Brian, any update on this?
OK.  I just tested this with Mozilla build 2001121405 on MacOS X. It is still
broken. However, It does work with Netscape 6.2.1 on Mac and Windows platforms
(and 6.2 and I believe 6.1). SAP did some work on this, and it started working
with Netscape 6.1 as of ITS version 4.6DC4 patch level 233. 

I don't quite know what to make of this. I never uploaded the menu.js script
stuff that was suspected to be related to the "hierMenu" script bug. Is this
still needed?
Yes, that would still be nice
Attached file menu.js script
attaching the requested menu.js file. If you need any others, please let me
know.
Well, it's not hiermenus.  Brian, can you attach more (all?) of the JS files? 
You can zip them up if you like.  Also if you can include an udpated copy of the
HTML files in there too it would be great.

I'm pretty sure there's some code error going on that the developers need to
fix... but it's really hard to say what's going on when we can't see...
sent Brian a sidenote, waiting to hear back from him
heard back from Brian, he will be testing this again in hte next few days
Whiteboard: [bae:20020116]
OK.  I installed SAP's latest version of this software, version 6.10 patch level
6. It works well with Netscape 6.2 (win2k), but Mozilla 0.9.7 still has
problems, including the drop-down menus. Now, the menus don't work at all.
Previously, they would drop down but not be selectable.

I will take another look at trying to post a test case on a publicly available
server. I will add a comment to this bug when a test case is available,
hopefully this week-end.
See also bug 117248 which may be related?
OK.  I have looked into this more, and I think I have found the source of the
problem. I will have a test case available in the next few days. Here are some
code snippets that seems to be in question. 

<!-- first the arMenu scripts are defined, which are called in the table below -->
<script>
arMenu_1_1= new Array("Create session",'ON','STD',"1/1",'-',"End
session",'ON','STD',"1/2",'-',"User
profile",'ON','POP',"arMenu_1_1_3",'-',"Services",'ON','POP',"arMenu_1_1_4",'-',"Utilities",'ON','POP',"arMenu_1_1_5",'-',"List",'ON','POP',"arMenu_1_1_6",'-',"Services
for object",'ON','STD',"1/7",'-',"Object history",'ON','STD',"1/8",'-',"Own
spool requests",'ON','STD',"1/9",'-',"Own jobs",'ON','STD',"1/10",'-',"Short
message",'ON','STD',"1/11",'-',"Status...",'ON','STD',"1/12",'-',"Log
off",'ON','STD',"1/13",'-');
arMenu_1_2= new Array("Application help",'ON','STD',"2/1",'-',"SAP
Library",'ON','STD',"2/2",'-',"Glossary",'ON','STD',"2/3",'-',"-",'OFF','STD',"2/4",'-',"Release
notes",'ON','STD',"2/5",'-',"-",'OFF','STD',"2/6",'-',"SAP Service
Marketplace",'ON','STD',"2/7",'-',"-",'OFF','STD',"2/8",'-',"Feedback",'ON','STD',"2/9",'-',"-",'OFF','STD',"2/10",'-',"Settings...",'ON','STD',"2/11",'-');
</script>


<script DEFER>
arrMenu_FM = new Array("Help",'ON','STD',"F1",'NCHK',"Possible
entries",'ON','STD',"F4",'NCHK',"Open SAP Easy
Access",'ON','STD',"F5",'NCHK',"Exit session",'ON','STD',"F15",'NCHK');
</SCRIPT>

<!-- Here is the table, that includes the drop-down menus that don't work.
It seems that it is the "onmouse" commands that are not working at all in
Mozilla 0.9.7. -->

<table ID=_sapMenu_ CLASS=NewMenuBar ><tr>
<td CLASS=NewMenuCaption nowrap cmd="arMenu_1_1" onmousedown='MenuDown(this,
event);' onmouseover='MenuOver(this);' onmouseout='MenuOut();'>System</td><td
CLASS=NewMenuCaption nowrap cmd="arMenu_1_2" onmousedown='MenuDown(this,
event);' onmouseover='MenuOver(this);' onmouseout='MenuOut();'>Help</td>
<td WIDTH=100% ALIGN=RIGHT></td>
<td CLASS=NewMenuCaption nowrap cmd=arrMenu_FM onmousedown='MenuDown(this,
event);' onmouseover='MenuOver(this);' onmouseout='MenuOut();'>Function</td>
</tr></table>

Does this help anyone figure out what is going on here? I will post the URL to
the test case on Thursday.
Brian I think the function definitions of MenuOut(), MenuOver(), and menuDown()
would be quite useful to us :)

Also here is something which I guess we should have asked a lot sooner.  Please
go to Edit > Preferences > Debug and enable the checkbox to Show JavaScript
strict warnings.  Hit OK and then go to Tasks > Tools > Javascript Console. 
Clear any errors that are there, and then Reload the page on your intranet which
gives you the problem.  Any warnings or especially errors on there which
reference your intranet would be very useful.  They will give you some line
numbers and filenames where problems are occuring.

If you can post some out the output of the JS Console in here, and perhaps
copies of the files it flags with warnings or errors, I think that would be
extremely helpful in debugging this.
Sorry for not giving the definitions for the menu functions. My knowledge is
limited on this stuff. I have the output of the JS Console for you. I will
upload the referenced js files shortly.

There are two errors, and many warnings. Here are the two errors:

Error: laMatch has no properties
Source File:
http://hopper.us.brann.com:81/sap/its/mimes/system/99/script/sapwebframework.js
Line: 656

Error #2
webguiSetDynproScrollPos is not defined

There are lots and lots of warnings. Here are the ones that look like they are
applicable. There are many, many errors that look just like the arMenu errors
that I have below. I have only listed a few for reference.

Warning: assignment to undeclared variable arMenu_1_1
Source File:
http://hopper.us.brann.com:81/scripts/wgate/webgui4311567a/~flN0YXRlPTM1NTEuMDAxLjAxLjAx====
Line: 301

Warning: assignment to undeclared variable arMenu_1_2
Source File:
http://hopper.us.brann.com:81/scripts/wgate/webgui4311567a/~flN0YXRlPTM1NTEuMDAxLjAxLjAx====
Line: 302

Warning: assignment to undeclared variable arMenu_1
Source File:
http://hopper.us.brann.com:81/scripts/wgate/webgui4311567a/~flN0YXRlPTM1NTEuMDAxLjAxLjAx====
Line: 303

There are also a whole bunch of these errors referencing the aforementioned laMatch:

Warning: reference to undefined property laMatch[10]
Source File:
http://hopper.us.brann.com:81/sap/its/mimes/system/99/script/sapwebframework.js
Line: 1026

As well as a bunch of these messages in various lines in the sapwebframework.js
file:
Warning: deprecated with statement usage
Source File:
http://hopper.us.brann.com:81/sap/its/mimes/system/99/script/sapwebframework.js
Line: 29, Column: 1
Source Code:
	}
Also in lines 353, 972, 997, 1029, 1063

Warning: redeclaration of var NewArray
Source File: http://hopper.us.brann.com:81/sap/its/mimes/webgui/wa/scripts/basis.js
Line: 63, Column: 6
Source Code:
var NewArray = new Array();

Warning: reference to undefined property window.isMenu
Source File:
http://hopper.us.brann.com:81/sap/its/mimes/webgui/99/scripts/generator.js
Line: 102

Warning: reference to undefined property window.dockOnLoad
Source File:
http://hopper.us.brann.com:81/sap/its/mimes/webgui/99/scripts/nsnavigator/d_control.js
Line: 61

Warning: reference to undefined property window.splitterOnLoad
Source File:
http://hopper.us.brann.com:81/sap/its/mimes/webgui/99/scripts/nsnavigator/d_control.js
Line: 69

Warning: reference to undefined property window.webguiTCs
Source File:
http://hopper.us.brann.com:81/sap/its/mimes/webgui/99/scripts/nsnavigator/d_generator.js
Line: 656

Warning: reference to undefined property this.parentNode.updateCurrentBrowser
I included not only the files referenced in the JS errors that I posted, but
also other files, that hopefully contain the definitions to any functions that
you need.
I finally have a test case. I am not sure it is complete. I used the Mozilla
0.9.7  save page as... feature, and it seemed to collect all of the necessary
.js and .css files. However, the drop down links don't work in any browser, so
Mozilla may have not pulled them down properly. 

The test case is here:  http://timesheets.us.brann.com/saptest/index.html

The words "System" and "Help" on the top left hand corner of the screen are
supposed to be JavaScript drop-down menus, as is the word "Function" in the
upper right-hand side of the page.

If I am missing something that you need to be included in the test case, please
let me know.
Hmm....

 menuFrame = eval("window.frames.MenuFrame" + level);
 menuFrame.document.body.innerHTML = s;

How nice.. except there are no <frame> or <iframe> tags, so window.frames has
length 0 and menuFrame is null.  Then execution stops when we try to access its
properties...
Bouncing this to DOM0, not layout.
Assignee: attinasi → jst
Status: UNCONFIRMED → NEW
Component: Layout → DOM Level 0
Ever confirmed: true
QA Contact: petersen → desale
This bug is with SAP Internet Transaction Server WebGUI which gives high 
visibility to this bug because lot of users could be using this. Severity is 
Medium. Setting priority = p2.
Priority: -- → P2
So shouldn't this be evangelism?  I thought it already got pushed over there,
but I could be wrong...
I have an update here. First, I have a server that you can login to and see the
problem first hand:

http://mysap.us.brann.com:81/scripts/wgate/webgui/!

Note that the "!" is part of the URL. You need to use the userid: mozilla and
the password "bug123". 

After upgrading to SAP's ITS WebGUI v.6.10 patch level 7, it works better, but
not 100%. For example, the cascading feature of the drop down menus work fine in
Netscape 6.2.1 and IE 5.5sp2, but don't work properly in Mozilla 0.9.8. They
cascade to the right on 6.2.1 and IE, but don't cascade at all on Mozilla 0.9.8.

My question is, what changed between Mozilla 0.9.4+ (Netscape) and 0.9.8 that
would cause this to break like this?
In recent commercial (2002 02 05 12/win2k) and trunk (2002 02 06 03/win2k)
builds, the menus allow items on the pull down menus to be clicked. They just
seem to have no effect.

With out strict js warnings from js console:

Error: undefined has no properties
Source File:
http://mysap.us.brann.com:81/sap/its/mimes/system/99/script/sapwebframework.js
Line: 79

Error: spServer is not defined
Source File:
http://mysap.us.brann.com:81/sap/its/mimes/system/99/script/sapwebframework.js
Line: 1020


From Venkman:

Called from line 85: new SAPWF_Enumeration(); // netscape needs this!!!


Exception [Error] [class: Error] {3} thrown from function
SAPWF_Enumeration(assocArray=void:void) in
<http://mysap.us.brann.com:81/sap/its/mimes/system/99/script/sapwebframework.js>
line 79.
[e] message = [string] "undefined has no properties
Stopped for thrown exception.
$[0] = [Error] [class: Error] {3}
function SAPWF_Enumeration(assocArray=void:void) in
<http://mysap.us.brann.com:81/sap/its/mimes/system/99/script/sapwebframework.js>
line 79
077: this.elements = new Array();
078: this.pos = 0;
079: for (li in assocArray) {

Looks like we are failing when attempting to enumerate an undefined Object.

Note sure about the second error however.

-> Evang at least temporarily until we can get the issue with the enumerated
properties fixed and can proceed futther in the app without errors. I have been
working on getting contacts. 
Assignee: jst → bclary
Component: DOM Level 0 → US Ecommerce
Product: Browser → Tech Evangelism
Whiteboard: [bae:20020116] → [bae:20020116][eapp]
Version: other → unspecified
Depends on: 124862
*** Bug 124862 has been marked as a duplicate of this bug. ***
qa->marcio
QA Contact: desale → mgalli
Major corporations depend on eapp bugs, and need them to be fixed before they
can recommend Mozilla-based products to their customers. Adding nsbeta1+ keyword
and making sure the bugs get re-evaluated if they are targeted beyond 1.0.
Keywords: nsbeta1+
eapp was incorrectly used to change this to nsbeta1+. Evang bugs should not be
nominated.
Keywords: nsbeta1+
removing myself from the cc list
No longer blocks: 125136
Whiteboard: [bae:20020116][eapp] → [bae:20020116]
Brian, what is the situation with this bug now? 
Unfortunately, I am no longer with this company, so I can't test this particular
setup any more. The people that I know that are still there don't have the
expertise to really work on this. Sorry. 
tech evang june 2003 reorg
Assignee: bc → english-us
Component: US Ecommerce → English US
QA Contact: mgalli → english-us
assuming fixed
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: