Closed Bug 991141 Opened 7 years ago Closed 7 years ago

[Follow up from Bug 956219] Look and feel for "Delete contacts" button under Settings

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.0, tracking-b2g:backlog, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S6 (25apr)
feature-b2g 2.0
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: vicky, Assigned: arcturus)

References

Details

Attachments

(2 files)

Attached image detail
A few inconsistencies have been detected in this implementatio. PLease see attachment for more detail.
blocking-b2g: --- → 1.5?
Summary: [Follow up from Bug 956219] Fix error in implementation → [Follow up from Bug 956219] Fix errors in implementation
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → All
triage: lets fix this as part of the visual refresh work in 1.5
blocking-b2g: 1.5? → backlog
Blocks: 956219
+1 to comment 1.

Just one clarification. What we are seeing is the 'select' mode, in this case 'edit mode' cause we remove. But also the list and everything is used to select contacts.

So perhaps what we have to do is modify this 'select mode' of the list to change the style to perform the common edit mode in the rest of the apps.

Thanks a lot Viky!
Assignee: nobody → francisco.jordano
Target Milestone: --- → 1.4 S6 (25apr)
Summary: [Follow up from Bug 956219] Fix errors in implementation → [Follow up from Bug 956219] Look and feel for edit mode (list in select mode used for deleting)
Duplicate of this bug: 994719
We need to make the select mode accept a parameter to change look and feel.

Also we need to address the other errors appointed by Vicky.
(In reply to Francisco Jordano [:arcturus] from comment #4)
> We need to make the select mode accept a parameter to change look and feel.
> 
> Also we need to address the other errors appointed by Vicky.

Franciso,
I'm working in this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=990478
Which should solve half the issues we are having here.
(In reply to Arnau March  [:arnau] from comment #5)
> Franciso,
> I'm working in this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=990478
> Which should solve half the issues we are having here.

Thanks Arnau!

I'll focus on the list, and the delete button then!
Depends on: 990478
The missalignment in the Confirmation screen that Vicky reports in the attachment 8400729 [details] will be handled in Bug 994653
Depends on: 994653
So basically, what we have left for this bug is removing the red color of the button isnt?
(In reply to Francisco Jordano [:arcturus] from comment #8)
> So basically, what we have left for this bug is removing the red color of
> the button isnt?

Just to summarize what should be implemented within this bug:
1- "Delete contacts" button under settings should be grey instead of red (please refer to the third screenshot included in detail.png image)
2- "OK" button within delete confirmation message screen (please refer to the second screenshot included in detail.png image) should be red and the text should be "Delete" instead of "OK"

Moreover, 
3- The edit mode (please refer to the first screenshot included in detail.png image) will be covered in Bug 990478
4- The misalignment in the Confirmation screen (please refer to the second screenshot included in detail.png image) will be covered in Bug 994653

ni to vicky to confirm. Thanks!
Flags: needinfo?(vpg)
(In reply to Noemí Freire (:noemi) from comment #9)
> (In reply to Francisco Jordano [:arcturus] from comment #8)
> > So basically, what we have left for this bug is removing the red color of
> > the button isnt?
> 
> Just to summarize what should be implemented within this bug:
> 1- "Delete contacts" button under settings should be grey instead of red
> (please refer to the third screenshot included in detail.png image)
> 2- "OK" button within delete confirmation message screen (please refer to
> the second screenshot included in detail.png image) should be red and the
> text should be "Delete" instead of "OK"
> 
> Moreover, 
> 3- The edit mode (please refer to the first screenshot included in
> detail.png image) will be covered in Bug 990478
> 4- The misalignment in the Confirmation screen (please refer to the second
> screenshot included in detail.png image) will be covered in Bug 994653
> 
> ni to vicky to confirm. Thanks!

Perfect Noemí, thanks a lot for the summary!
Flags: needinfo?(vpg)
Attached file Pointer to PR 18629
Attachment #8411671 - Flags: review?(jmcf)
Flags: in-testsuite+
Finally this bug will just cover point 1 in comment 9:
1- "Delete contacts" button under settings should be grey instead of red (please refer to the third screenshot included in detail.png image)

Since point 2 in comment 9 will be covered by bug 991114:
2- "OK" button within delete confirmation message screen (please refer to the second screenshot included in detail.png image) should be red and the text should be "Delete" instead of "OK"

so changing the summary accordingly.
Summary: [Follow up from Bug 956219] Look and feel for edit mode (list in select mode used for deleting) → [Follow up from Bug 956219] Look and feel for "Delete contacts" button under Settings
Thanks Noemi, will just rebase to land that change.
Comment on attachment 8411671 [details] [review]
Pointer to PR 18629

Changing reviewer since this change is a BB one. (A proper use of the BB)
Attachment #8411671 - Flags: review?(jmcf) → review?(arnau)
Landed:

https://github.com/arcturus/gaia/commit/68e25f08d397a07e9d38268465502da4ec6a2242
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
feature-b2g: --- → 2.0
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.