Closed Bug 993564 Opened 6 years ago Closed 6 years ago

[B2G][Tarako]Unable to proceed past the extension line when calling into the Mozilla conference line

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified)

VERIFIED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified

People

(Reporter: astole, Assigned: james.zhang)

References

Details

(Keywords: regression, smoketest, Whiteboard: [POVB])

Attachments

(5 files)

Attached file logcat
When calling into the Mozilla conference line, the user cannot proceed past the extension. After pressing the '92' extension, the user is unable to hear anything

Repro Steps:
1) Update a Tarako to BuildID: 20140408004001
2) Open the Dialer app and call the Mozilla conference line
3) When prompted, enter an extension number (extension 92 was used for testing)

Actual:
The user cannot hear anything and cannot proceed past the extension line

Expected:
The user can proceed past the extension line and there is sound

1.3 Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140408004001
Gaia: 643f3e6676cbb89c62708a9f7cbef2edc795a552
Gecko: b850e0f09e61
Version: 28.1
Firmware Version: sp8810

Repro frequency: 90%
See attached: logcat
This issue does not occur on the Buri v1.3

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140408004002
Gaia: 0a7a50129995f080c1df4d807a2334701701e8ed
Gecko: e3fca8c23e1d
Version: 28.0
Firmware Version: V1.2-device.cfg
Keywords: smoketest
Really, really bad regression.
blocking-b2g: --- → 1.3T?
Keywords: regression
Did this ever work?  I would speculate that it's a Mozilla RIL bug.
Ah, I guess comment 1 tested the Buri with our RIL.
Does this reproduce on 1.4 with our RIL?  Bug 960894 would be my first suspect.
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #5)
> Does this reproduce on 1.4 with our RIL?  Bug 960894 would be my first
> suspect.

It doesn't reproduce on 1.4 with a single SIM device. Haven't checked a 1.4 DSDS setup though.

Eric - Can you check if this happens on 1.4 Fugu?
Component: Gaia::Dialer → RIL
Flags: needinfo?(echang)
HsinYi, please take a look at this telephony bug
Flags: needinfo?(htsai)
blocking-b2g: 1.3T? → 1.3T+
(In reply to Wesley Huang [:wesley_huang] from comment #7)
> HsinYi, please take a look at this telephony bug

Sure.
Flags: needinfo?(htsai)
(In reply to Andrew Stole from comment #0)
> Created attachment 8403472 [details]
> logcat
> 
> When calling into the Mozilla conference line, the user cannot proceed past
> the extension. After pressing the '92' extension, the user is unable to hear
> anything
> 
> Repro Steps:
> 1) Update a Tarako to BuildID: 20140408004001
> 2) Open the Dialer app and call the Mozilla conference line
> 3) When prompted, enter an extension number (extension 92 was used for
> testing)
> 
> Actual:
> The user cannot hear anything and cannot proceed past the extension line
> 
> Expected:
> The user can proceed past the extension line and there is sound
> 
> 1.3 Environmental Variables:
> Device: Tarako 1.3T
> BuildID: 20140408004001
> Gaia: 643f3e6676cbb89c62708a9f7cbef2edc795a552
> Gecko: b850e0f09e61
> Version: 28.1
> Firmware Version: sp8810
> 
> Repro frequency: 90%
> See attached: logcat

No RIL debug messages. :( I'm trying to reproduce this issue. In the meanwhile, please try either way below to enable ril debugger and then "adb logcat -b radio -b main" to capture messages, thanks.
1) Refer to Bevis's script from https://bugzilla.mozilla.org/attachment.cgi?id=8385781
2) https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Changing_preferences

Once you are successful in enabling debugger, you will see a lot of messages with prefix "RIL Worker"
Flags: needinfo?(astole)
Assignee: nobody → htsai
I cannot reproduce this locally. Still waiting for feedback from Andrew Stole.
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #9)
> (In reply to Andrew Stole from comment #0)
> > Created attachment 8403472 [details]
> > logcat
> > 
> > When calling into the Mozilla conference line, the user cannot proceed past
> > the extension. After pressing the '92' extension, the user is unable to hear
> > anything
> > 
> > Repro Steps:
> > 1) Update a Tarako to BuildID: 20140408004001
> > 2) Open the Dialer app and call the Mozilla conference line
> > 3) When prompted, enter an extension number (extension 92 was used for
> > testing)
> > 
> > Actual:
> > The user cannot hear anything and cannot proceed past the extension line
> > 
> > Expected:
> > The user can proceed past the extension line and there is sound
> > 
> > 1.3 Environmental Variables:
> > Device: Tarako 1.3T
> > BuildID: 20140408004001
> > Gaia: 643f3e6676cbb89c62708a9f7cbef2edc795a552
> > Gecko: b850e0f09e61
> > Version: 28.1
> > Firmware Version: sp8810
> > 
> > Repro frequency: 90%
> > See attached: logcat
> 
> No RIL debug messages. :( I'm trying to reproduce this issue. In the
> meanwhile, please try either way below to enable ril debugger and then "adb
> logcat -b radio -b main" to capture messages, thanks.
> 1) Refer to Bevis's script from
> https://bugzilla.mozilla.org/attachment.cgi?id=8385781
> 2) https://wiki.mozilla.org/B2G/QA/Tips_And_Tricks#Changing_preferences
> 
> Once you are successful in enabling debugger, you will see a lot of messages
> with prefix "RIL Worker"

One possible guess: the tone duration is too short for operator to recognize. 
So, please use *adb logcat -b radio -b main -v time* to capture log messages so that we could check time frame as well.
Works okay on Fugu v1.4 & v1.3.

(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #5)
> > Does this reproduce on 1.4 with our RIL?  Bug 960894 would be my first
> > suspect.
> 
> It doesn't reproduce on 1.4 with a single SIM device. Haven't checked a 1.4
> DSDS setup though.
> 
> Eric - Can you check if this happens on 1.4 Fugu?
Flags: needinfo?(echang)
We retested this issue on multiple Tarako devices and were only able to reproduce it on 1/5 devices. Since this is a Dialer issue and we're still partially blocked from testing Dialer (bug 994191), I'd like to ask someone on Taipei side to retest this issue and confirm it's reproducible on your builds.

William, would you be able to help here?
Flags: needinfo?(whsu)
I've rechecked this on 

Gaia      643f3e6676cbb89c62708a9f7cbef2edc795a552
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/e757fdd55426
BuildID   20140409004001
Version   28.1
ro.build.version.incremental=215
ro.build.date=Mon Mar 31 10:11:50 CST 2014

And, while I'm able to still get audio through the call, I am not able to get DTMF tones to work to navigate the menu.  I'll investigate as to whether there's a bug on that or not.
Flags: needinfo?(whsu)
I can confirm by calling (804) 222-1111 (testcall.com) that DTMF is hosed.   You should be able to enter a number and have the number repeated to you by the system. In our case, when entering numbers, call times out due to no input, although a handful of DTMF numbers are recognized.
(In reply to John Hammink from comment #15)
> I can confirm by calling (804) 222-1111 (testcall.com) that DTMF is hosed.  
> You should be able to enter a number and have the number repeated to you by
> the system. In our case, when entering numbers, call times out due to no
> input, although a handful of DTMF numbers are recognized.

Thanks for the information, John.

As I still cannot reproduce this issue, and as some operators require longer DTMF tone duration to recognize the DTMF code, it is much helpful to provide a log "adb logcat -b radio -b main -v time" with ril debugger enabled. Please see comment 9 to enable the debugger.

Also, if you press a DTMF number longer, does it help to have that number being recognized?  Thanks!
Just test with Tarako to call my office line with extension, it also works okay.
Blocks: 994455
My tarako also fine to call my office line, but I encounter another problem as bug#993564
Gaia      98ce1340a6c27694f3b32a36b772e8da57caf19a
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/bdf9a55b4553
BuildID   20140409164001
Version   28.1
ro.build.version.incremental=eng.cltbld.20140409.202801
ro.build.date=Wed Apr  9 20:28:14 EDT 2014
A duplicate bug of Bug 988136?
Bug 988136 is a very interesting bug.
If you using dial a number via keypad, you can reproduce it.
But, if you used call log(history) to make a phone call, you cannot reproduce it.
The issue has been solved on the latest PAC file.

Thanks! :)
(In reply to William Hsu [:whsu] from comment #19)
> A duplicate bug of Bug 988136?
> Bug 988136 is a very interesting bug.
> If you using dial a number via keypad, you can reproduce it.
> But, if you used call log(history) to make a phone call, you cannot
> reproduce it.
> The issue has been solved on the latest PAC file.
> 
> Thanks! :)

Seems not the same issue as bug 988136. Per John's comment 14, he is able to still get audio through the call, but not able to get DTMF tones to work to navigate the menu.
Thanks for the reminder, and sorry for the typo!
Yes, it is different with bug 988136.

I also can reproduce this bug with latest PAC file when the memory usage is high.
But the reproduce rate is low. (20%~30%)

I will try it later and upload the logs if I still can reproduce it.
Thanks.
Not sure if this bug is similar to Bug 994568. FYI.
Attached file logcat_RIL_enabled.txt
Attaching the logcat with the RIL debug enabled.
We now can update our phones with the latest PAC and still reproduce the bug.

*Tarako pvtbuild:
BuildID: 20140410004001
Gaia: 022b03a57e4b8c697a6066961e7581d07eb99305
Gecko: b9dba13d50a9
Version: 28.1

*base image: sp6821a
Flags: needinfo?(astole)
(In reply to Natalya Kot [:nkot] from comment #23)
> Created attachment 8404814 [details]
> logcat_RIL_enabled.txt
> 
> Attaching the logcat with the RIL debug enabled.
> We now can update our phones with the latest PAC and still reproduce the bug.
> 
> *Tarako pvtbuild:
> BuildID: 20140410004001
> Gaia: 022b03a57e4b8c697a6066961e7581d07eb99305
> Gecko: b9dba13d50a9
> Version: 28.1
> 
> *base image: sp6821a

Hi Natalya,

This log contains RIL messages, but I am sorry that it seems not record the test.
According to the STR, I should be able to grep messages with "Dialing", "starttone", "stoptone" or "DTMF" strings. However, none of them have shown in this log.

Please help provide again, and PLEASE USE THIS command *adb logcat -b radio -b main -v time* 
I do need the *radio log* as well!  Thank you very much for your help :)
Flags: needinfo?(nkot)
William, per comment 21, you are also able to reproduce this bug. Is there any log for Hsinyi per her comment 24?
Flags: needinfo?(whsu)
Thanks for the reminder!

If my assumption is right, it might be a performance issue.
While the memory usage is high and quickly tap the keypad, the bug can be reproduced.
Attach the logs. Thanks!

Radio related log only: Radio_Log_20140411
Full log: Full_Log_20140411
Flags: needinfo?(whsu)
Attached file Full_Log_20140411
Attachment #8405223 - Attachment mime type: text/x-vhdl → text/plain
Attachment #8405224 - Attachment mime type: text/x-vhdl → text/plain
(In reply to William Hsu [:whsu] from comment #28)
> Created attachment 8405224 [details]
> Radio_Log_20140411

Thanks, William.

Per log, everything looks right on gecko. Gecko receives requests from gaia, sends them to modem and gets successful responses from modem. Also, William noticed that this issue seems appear on older hardware. We are unable to see this on the new one I have "v1.0.1(98020)" We need help from our partner to understand if there's difference b/w old and new devices.
Flags: needinfo?(nkot)
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #29)
> (In reply to William Hsu [:whsu] from comment #28)
> > Created attachment 8405224 [details]
> > Radio_Log_20140411
> 
> Thanks, William.
> 
> Per log, everything looks right on gecko. Gecko receives requests from gaia,
> sends them to modem and gets successful responses from modem. Also, William
> noticed that this issue seems appear on older hardware. We are unable to see
> this on the new one I have "v1.0.1(98020)" 
                           ^^^^^^^^^^^^^^^^^^ should be v1.0.1 (9802)  
> We need help from our partner to
> understand if there's difference b/w old and new devices.
James, could you check comment 29 & 30?
Flags: needinfo?(james.zhang)
(In reply to James Ho from comment #31)
> James, could you check comment 29 & 30?

Loop Sam
Flags: needinfo?(james.zhang) → needinfo?(sam.hua)
Attached file log - DTMF works
This is a reference log of the case DTMF works.
As 8405224: Radio_Log_20140411, sometimes "stoptone/DTMF_STOP" fails; however, the DTMF still works.
Attachment #8405309 - Attachment mime type: text/x-vhdl → text/plain
it is audio issue. 
Tarako has the problem of mixing the tone of dtmf or CallWaiting Tone.
Flags: needinfo?(sam.hua)
Change component to Vendcom per comment 34.
Assignee: htsai → nobody
Component: RIL → Vendcom
[POVB], assign to James for now, please reassign as needed. thank you
Assignee: nobody → james.zhang
Whiteboard: [POVB]
Assignee: james.zhang → sam.hua
Flags: needinfo?(sam.hua)
Duplicate of this bug: 994504
Duplicate of this bug: 996187
it is fixed now.

but modem have to be updated to new version.

James,please help to RESOLVED_FIXED, i can't do it.
Assignee: sam.hua → james.zhang
Flags: needinfo?(sam.hua)
(In reply to sam.hua from comment #39)
> it is fixed now.
> 
> but modem have to be updated to new version.
> 
> James,please help to RESOLVED_FIXED, i can't do it.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
seems like we're blocked with bug 997394 now, so will have to retest and verify the fix later
Verified it. The patch works as expected.
But, a problem still needs to fix. (Bug 1003150)
Thanks!

* Build information:
 - Device    Tarako
 - Gaia      b5adc5a943d3abbd6ab070a47c847f2c24891cc5
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/e9890f5d4709
 - BuildID   20140429014002
 - Version   28.1

* Result:
 - Cannot reproduce.
Status: RESOLVED → VERIFIED
Verified issue from Comment 0 does not reproduce on latest 1.3T build. User able to hear after typing an extension and input a conference line. 

Environmental Variables:
Device: Tarako 1.3T
Build ID: 20140609014001
Gaia: adb258b88485ccf1ff2e971de0fda547e4bb7149
Gecko: e8b77a1c7c78
Version: 28.1 (1.3T) 
Firmware Version: SP6821a-Gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
Flags: needinfo?(owen.ouyang)
Flags: needinfo?(owen.ouyang)
You need to log in before you can comment on or make changes to this bug.