Closed Bug 994455 Opened 6 years ago Closed 6 years ago

[Tarako][Dialer]Input any number in keypad will cause hang up phone needs almost 10 seconds

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T verified)

VERIFIED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- verified

People

(Reporter: mlien, Assigned: james.zhang)

References

Details

(Whiteboard: ux-most-wanted, [POVB])

Attachments

(4 files)

Attached file logcat.txt
[Device]
  Tarako
---------------------------------------------
[Reproduction build] - v1.3t
  Gaia      98ce1340a6c27694f3b32a36b772e8da57caf19a
  Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/bdf9a55b4553
  BuildID   20140409164001
  Version   28.1
  ro.build.version.incremental=eng.cltbld.20140409.202801
  ro.build.date=Wed Apr  9 20:28:14 EDT 2014
---------------------------------------------
[Reproduce Steps]
  1. Launch Dialer app
  2. Make any phone call
  3. Invoke number keypad in connected
  4. Hang up phone
---------------------------------------------
[Expected Result]
  Hang up phone then show call ended immediately
---------------------------------------------
[Actual Result]
  Hang up phone then show call ended needs almost 10 seconds
---------------------------------------------
[Reproduce Rate]
  100%
Is this after a PAC reflash of the 04/02 build?
Flags: needinfo?(mlien)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #1)
> Is this after a PAC reflash of the 04/02 build?

yes, my tarako is 0402 PAC + the latest daily pvt build
Flags: needinfo?(mlien)
blocking-b2g: --- → 1.3T?
triage: 1.3T+, 10 sec is too slow 
ni? MIke for logs
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(mlien)
log as attachment
Flags: needinfo?(mlien)
(In reply to Mike Lien[:mlien] from comment #4)
> log as attachment

Hi Mike,

Want to confirm the issue: you said it takes almost 10 seconds to show 'call ended'. But how about the voice call itself? Can you tell that if the voice call is released immediately?

The delay of showing 'call ended' could be a gaia issue but it could also result from that it takes too much time to deliver 'disconnected' event from platform to gaia. We need to investigate more. As the log attachment 8404395 [details] doesn't contain gecko/ril information, could you please refer to bug 993564 comment 9 to enable ril debugger and use "adb logcat -b radio -b main -v time" to capture log again? Thank you.
Flags: needinfo?(mlien)
Attached file logcat with ril.txt
hang up phone with number keypad input can cancel voice call immediately, only MO show "Call Ended" need 10 seconds
Flags: needinfo?(mlien)
Update STR

[Reproduce Steps]
  1. Launch Dialer app
  2. Make any phone call
  3. Invoke number keypad in connected -> Input any number
  4. Hang up phone
Whiteboard: ux-most-wanted
Blocks: 994991
Hi Rik, wonder if you will be able to take a look at this one? Thanks
Flags: needinfo?(anthony)
William told me that it might be a hardware issue. I don't see this on the tarako I have with newer hardware version (v1.0.1(9802)).
Duplicate of this bug: 994547
Thanks for Hsin-Yi's update!

Kai-Zhen and I found the version numbers (sticker) of the new and old Tarako devices are different.
We doubt that it might mean the different hardware specification.
Kai-Zhen is helping on hardware confirmation.
Thanks!
Verify with another hardware version (v1.0.1(9802)) Tarako device, still has this problem.
Wait for Hsin-Yi's update
log snippet:

=== Request Hangup ===
#2910 01-01 00:26:33.220 I/Gecko   (   83): RIL Worker: [0] Received chrome message {"callIndex":1,"rilMessageClientId":0,"rilMessageToken":27,"rilMessageType":"hangUp"}
#2915 01-01 00:26:33.220 D/RILC    (   95): [0095]> HANGUP (1)

=== After 1 second, gecko is notified call state changed ===
#2935 01-01 00:26:33.560 D/RILC    (   95): [UNSL]< UNSOL_RESPONSE_CALL_STATE_CHANGED
#2952 01-01 00:26:33.560 I/Gecko   (   83): RIL Worker: [0] Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED

=== In 1 second, gecko queries the current calls ===
#2953 01-01 00:26:33.560 I/Gecko   (   83): RIL Worker: [0] New outgoing parcel of type 9
#2954 01-01 00:26:33.560 I/Gecko   (   83): RIL Worker: Outgoing parcel: 0,0,0,8,9,0,0,0,96,0,0,0

=== After 10 seconds, modem/RILC responds ===
#2980 01-01 00:26:43.500 D/RILC    (   95): [0096]< GET_CURRENT_CALLS }
#3005 01-01 00:26:43.540 I/Gecko   (   83): RIL Worker: [0] Solicited response for request type 9, token 96, error 0
#3006 01-01 00:26:43.540 I/Gecko   (   83): RIL Worker: [0] Handling parcel as REQUEST_GET_CURRENT_CALLS
#3049 01-01 00:26:43.570 I/Gecko   (   83): TelephonyProvider: handleCallDisconnected: {"state":0,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePri     vacy":false,"number":"0287861100","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false,"started":1325     377586681,"rilRequestType":18,"rilRequestError":0,"failCause":"NormalCallClearingError"}
Sam, 
Per observation in comment 13, I am wondering if something's going wrong on rilc/modem side. Could you please help check?
Flags: needinfo?(sam.hua)
Attached file log - hangup normally
This is the log for the case call screen disappears immediately.
yes,it looks like caused by audio.

please use adb logcat -b radio -b main to catch a log.

http://bugzilla.spreadtrum.com/bugzilla/show_bug.cgi?id=300372
Flags: needinfo?(sam.hua)
(In reply to sam.hua from comment #16)
> yes,it looks like caused by audio.
> 
> please use adb logcat -b radio -b main to catch a log.
> 
> http://bugzilla.spreadtrum.com/bugzilla/show_bug.cgi?id=300372

Log attachment 8405301 [details] |log-hangup-slow - adb logcat -b radio -b main| provided already.
yes,
it's audio issue, we will check it.
01-01 00:26:33.560 D/AT      (   95): Channel2: AT> AT+CLCC
01-01 00:26:33.560 W/audio_hw_primary(   88): VBC_CMD_HAL_CLOSE, got lock
...
01-01 00:26:43.490 W/audio_hw_primary(   88): vplayback write over result is 0,frame_size is 4 in frames 1600, out frames 290
01-01 00:26:43.490 W/AudioFlinger(   88): write blocked for 10059 msecs, 1 delayed writes, thread 0x14d2ec0
(In reply to sam.hua from comment #18)
> yes,
> it's audio issue, we will check it.
> 01-01 00:26:33.560 D/AT      (   95): Channel2: AT> AT+CLCC
> 01-01 00:26:33.560 W/audio_hw_primary(   88): VBC_CMD_HAL_CLOSE, got lock
> ...
> 01-01 00:26:43.490 W/audio_hw_primary(   88): vplayback write over result is
> 0,frame_size is 4 in frames 1600, out frames 290
> 01-01 00:26:43.490 W/AudioFlinger(   88): write blocked for 10059 msecs, 1
> delayed writes, thread 0x14d2ec0

Thanks, Sam. I am changing the component to Vendcom. Feel free to reset if it's not the case!
Component: Gaia::Dialer → Vendcom
Flags: needinfo?(anthony)
hi James, can you have your team take this bug? thanks
Assignee: nobody → james.zhang
Whiteboard: ux-most-wanted → ux-most-wanted, [POVB]
please assign to me,
it is also modem audio issue
Attachment #8405301 - Attachment mime type: text/x-vhdl → text/plain
According to comment 21.
Assignee: james.zhang → sam.hua
it is fixed now.
but modem have to be updated to new version.

James,please help to RESOLVED_FIXED, i can't do it.
Assignee: sam.hua → james.zhang
(In reply to sam.hua from comment #23)
> it is fixed now.
> but modem have to be updated to new version.
> 
> James,please help to RESOLVED_FIXED, i can't do it.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 996415
Duplicate of this bug: 997518
verified and fixed with below build
0417 pac + pvt v1.3t
  Gaia      68e072af2348c46fbff8a35d99ff10caeab16880
  Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/a8cc1aaec6a3
  BuildID   20140420164002
  Version   28.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.