Closed Bug 998100 Opened 6 years ago Closed 5 years ago

[Tarako][Sound] Keypad sound and sound for keyboard UX and disabled settings confusing

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86
macOS
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.0 fixed)

RESOLVED FIXED
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: guigs, Assigned: dkuo)

References

Details

(Whiteboard: [tarako-bug-bash-1.3T] [p=1])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
eragonj
: review+
Details | Review
STR UX Reproduce 
This builed 1.3 nightly has the click sound option in the built in keyboard (Tarako does not)


1. Settings > sound > "Keypad" turns off the keypad number tone off

expected:
turn off sound for all keyboard tapping

Result: 
only turns off tone for number pad

2 In Tarako build 20140417004002: Keyboard > Keyboard settings> options are not showing up in interface: "click sound" "Auto correction" "word suggestion"
In Nightly build: all of these are turned on
Whiteboard: [tarako-bug-bash-1.3T]
back logging, as I would not hold release, but a number of people have expressed that having this would be good.
blocking-b2g: --- → backlog
(In reply to rmcguigan from comment #0)
> STR UX Reproduce 
> This builed 1.3 nightly has the click sound option in the built in keyboard
> (Tarako does not)
> 
> 
> 1. Settings > sound > "Keypad" turns off the keypad number tone off
> 
> expected:
> turn off sound for all keyboard tapping
> 
> Result: 
> only turns off tone for number pad

The virtual keyboard in Gaia would not look at this setting, which is "phone.ring.keypad", instead it would check "keyboard.clicksound" setting. 

> 
> 2 In Tarako build 20140417004002: Keyboard > Keyboard settings> options are
> not showing up in interface: "click sound" "Auto correction" "word
> suggestion"
> In Nightly build: all of these are turned on

This change happened only on Tarako with this bug, bug 991627.
I'm sending this over to UX because this has come up in multiple bug bashes as an annoying papercut. People always seem to get confused what the keypad sound intending to modify...
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Carrie in case this is more of a keyboard issue, and Omega in case it's more specifically Settings. Not blocking.
Flags: needinfo?(ofeng)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(cawang)
My suggestion is:
Change "Settings > Sound > Keypad" to "Settings > Sound > Dial Pad"
It should be clearer now.
Flags: needinfo?(cawang)
Flags: needinfo?(ofeng)
Flags: needinfo?(ofeng)
Attached file quick patch
Just set this review? to owner/peer when we want this fixed.
Please see Bug 991026 for the latest UX spec.
Flags: needinfo?(ofeng)
Blocks: 991026
Comment on attachment 8419890 [details] [review]
quick patch

EJ,

This is a simple patch that added a new string in the sound panel, would you please review it? thanks.
Attachment #8419890 - Flags: review?(ejchen)
Comment on attachment 8419890 [details] [review]
quick patch

r+ based on UX's comment (comment 6)

thanks for your work, Domi !
Attachment #8419890 - Flags: review?(ejchen) → review+
Whiteboard: [tarako-bug-bash-1.3T] → [tarako-bug-bash-1.3T] [p=1]
Thanks EJ!

Landed on master: 6a778cb4c41415e389db5f73441db3dea374a601
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → dkuo
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.