Closed Bug 24113 (table-rules) Opened 22 years ago Closed 20 years ago

<table> frame and rules attributes not handled correctly

Categories

(Core :: Layout: Tables, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla0.9.9

People

(Reporter: bugzilla, Assigned: karnaze)

References

()

Details

(Keywords: html4, testcase, Whiteboard: [awd:tbl])

Attachments

(3 files)

If a table is specified with a rules="groups" attribute, the table is still drawn with rules between every row and column, not respective of row and column groups.

This is contrary to the HTML 4.0 specification:
http://www.w3.org/TR/REC-html40/struct/tables.html
Summary: TABLE rules="groups" does not function [4.xP] → [4.xP] <table rules="groups"> does not function
Setting the keyword all open [4.xp] bugs to 4xp.
Keywords: 4xp
*** Bug 23591 has been marked as a duplicate of this bug. ***
Summary: [4.xP] <table rules="groups"> does not function → <table rules="groups"> does not function
Status: NEW → ASSIGNED
Target Milestone: M16
Moving to M17.
Target Milestone: M16 → M17
*** Bug 38926 has been marked as a duplicate of this bug. ***
*** Bug 38920 has been marked as a duplicate of this bug. ***
*** Bug 38926 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 41262 ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
I should have made a dependency instead of a dup. 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
Depends on: 41262
*** Bug 26846 has been marked as a duplicate of this bug. ***
Blocks: 2068
*** Bug 46141 has been marked as a duplicate of this bug. ***
*** Bug 50056 has been marked as a duplicate of this bug. ***
Changing URL as the original testcase has moved. I think the 4xp should be 
removed (see discussion n.p.m.qa.general 4xp for "competitor products" 
Considered Harmful from 2000-09-06) BTW IE5 handles the rules perfect.
Agreed, re. 4xp.
Keywords: 4xp
Blocks: robin's
*** Bug 65096 has been marked as a duplicate of this bug. ***
This should be changed to Platform=All and OS=All as it's a
platform-independant
problem. I've also attached a testcase that shows that this bug is actually
broader in scope, as the RULES attribute in general is not functioning correctly
for any of the five valid values for it (none, groups, rows, cols and all).

I propose retitling this bug "Incorrect display of tables with any RULES
attribute". Does anyone object?

This testcase also shows that FRAME values aren't being handled properly, but
perhaps it's best to make this bug about RULES in particular.
OS: Windows 98 → All
Hardware: PC → All
Summary: <table rules="groups"> does not function → <table rules="..."> attribute ignored
When I opened this bug, what I really wanted was for Mozilla to handle all values of the "frame" and "rules" attributes correctly, like Internet Explorer. 
Summary: <table rules="..."> attribute ignored → <table> frame and rules attributes not handled correctly
We missed the target milestone of M17. Should we push it up to 0.9?
Marking mozilla1.0 like bug 41262.
Target Milestone: M17 → mozilla1.0
QA contact update
QA Contact: chrisd → amar
 Nominating this bug for the next netscape release because this is needed for 
the feature complete..
The table frame attribute works for me in build 2001070108 win32

The table rules attribute does not.
Blocks: 104166
Whiteboard: [awd:tbl]
Target Milestone: mozilla1.0 → mozilla0.9.8
->m099
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Greg, thanks for the test cases. The last one is quite complete.
Marking nsbeta1+
Keywords: nsbeta1+
Fixed by meta bug 41262.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
Does appear to be Resolved in FizzillaCFM/2002022309.
On my test page http://www.robinlionheart.com/stds/html4/tables.html, Win32 nightly build 20020303 does the rules="groups" table correctly for the row groups, but not for the column groups -- there are rules between all columns, not just the column groups. 

(Portions of the column bars are invisible in the results table on http://www.robinlionheart.com/stds/html4/ for some reason, also, but that's probably a rendering issue rather than a Tables issue.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
that's bug 127798 , or is that a dup of this?
My build from this morning shows several horizontal lines on the last two test
cases that extend the entire browser window. Is this a known issue?
I can't access the urls in comment #29. If they have a colgroup with a span, 
then that is probably bug 127798, which is a problem in table frame 
construction. The test cases in this bug still work ok, so I'm closing it again. 
Please open a new bug if the new test cases are not a dup of bug 127798.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Eric: could that be bug 72979 ?
I don't think so. I'm attaching a screen shot showing some of the over-active
rules. They come and go with repaints, so moving windows over them and
scrolling off screen changes which lines are over extended
Eric: file a new bug and cc me
I think there may be some painting problems involving collapsed borders. A 
new bug and a reproduceable test case would be great.
 Verified.. Fixed from the checkins made.
Status: RESOLVED → VERIFIED
Alias: table-rules
You need to log in before you can comment on or make changes to this bug.