Closed Bug 1011731 Opened 6 years ago Closed 5 years ago

[B2G][RTL][Dialer] Arabic: Dialing a number is inconsistent, showing both RTL and LTR formats in "Dialer" app.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected)

RESOLVED DUPLICATE of bug 1102317
2.2 S1 (5dec)
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected

People

(Reporter: mlivingston, Assigned: gtorodelvalle)

References

()

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(3 files)

Attached file inconsistent dialing
f numbers dialed.

Actual:
Inconsistent RTL and LTR behaviors when dialing a phone number and "*"/"#" symbols.

Expected:
Correct RTL behavior when dialing a phone number and "*"/"#" symbols.

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140516000201
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: v1.2-device.cfg

Repro frequency: 100%
See attached: Video Clip
1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140514024003
Gaia: 96e3fa769a436a2182e6d54088fb41386eb2b5b5
Gecko: 685cf1d0dedb
Version: 28.0
Firmware Version: v1.2-device.cfg

RTL/LTR behavior is inconsistent in Buri 1.3
Mike, would you be someone who could help UX define the correct RTL behavior when dialing a phone number and * and # symbols? We're organizing a list of work to improve the RTL experience right now but could use some details on this point. Thanks!
I must've missed this one..
Hey Stephany,
So I spent the last 6 months working on RTL and as a native Arabic speaker I do think I can help with this one and with RTL behavior in general.
My plan for patching the dialer issue is/was to keep it LTR'ed, which is same as Andoird's approach
Attaching a screenshot
Attached image Android RLT Dialer
So it's basically the same as the LTR screen.. And that's IMO the most correct approach..
Duplicate of this bug: 1041277
Attached file Github pull-request
Sorry for spamming around.
Etienne, can you please review this?
Thanks!
Attachment #8459281 - Flags: review?(etienne)
Attachment #8459281 - Flags: review?(etienne) → review?(anthony)
Comment on attachment 8459281 [details] [review]
Github pull-request

Ahmed: Is this a definitive fix or can we do better? Should we aim to remove this forced LTR in the future?

It's only a feedback+ because we also use a similar keypad in three places. In callscreen and in lockscreen with a code, when you want to place an emergency call. We'll need this attribute there too.
Attachment #8459281 - Flags: review?(anthony) → feedback+
Needinfo for comment 7.
Flags: needinfo?(nefzaoui.ahmed)
Please let me know the status of this work, and if we still wish to pursue this. For 2.2, UX will be doing a spec of what the dialer should look like in RTL, which will include things like not having letters on the keys (per the most recent Arabic bug bash). That 2.2 work may or may not supersede/take care of this. Let me know and thanks!
Blocks: dialer-rtl
Ehsan said in bug 1037603 that he didn't expect the keypad to display "1 2 3" which this bug is proposing. So I don't know what is the best way forward. I think we'll need a spec to make sure we're solving RTL problems rather than just hiding our bugs.
Apologies for this huge delay, rik
Just getting back on track after I finally got my device.

(In reply to Anthony Ricaud (:rik) from comment #10)
> Ehsan said in bug 1037603 that he didn't expect the keypad to display "1 2
> 3" which this bug is proposing. So I don't know what is the best way
> forward. I think we'll need a spec to make sure we're solving RTL problems
> rather than just hiding our bugs.

Actually I don't think so. Looking at how competitor OSes act (they keep the Dialer LTR-ed always) and given what users from the regions where RTL is mostly used, are used to, I don't think we need to have any RTL-specific UI here.
Plus, as a Native Arabic speaker, I find that it does make much more sense to keep it LTR. :)
That is, in my personal opinion of course.

(In reply to Anthony Ricaud (:rik) from comment #7)
> Comment on attachment 8459281 [details] [review]
> Github pull-request
> 
> Ahmed: Is this a definitive fix or can we do better? Should we aim to remove
> this forced LTR in the future?
> 
> It's only a feedback+ because we also use a similar keypad in three places.
> In callscreen and in lockscreen with a code, when you want to place an
> emergency call. We'll need this attribute there too.

Maybe using CSS instead would be a better approach? :)
Flags: needinfo?(nefzaoui.ahmed)
No longer blocks: gaia-rtl
QA Contact: jlorenzo
Whiteboard: LocRun1.4 → [planned-sprint c=?]
Target Milestone: --- → 2.2 S1 (5dec)
Assignee: nobody → gsvelto
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
Assignee: gsvelto → gtorodelvalle
Stephany, are you in agreement on comment 11? Please also see bug 1102496 as the decision here will impact that one.

Note that this isn't mentioned directly in the BiDi Scoping spec. However, the closest reference I can find is the "Grids" section, which would suggest the opposite. I assume we're deferring to Ahmed here, but I'd like to be sure before we begin work on it.
Flags: needinfo?(swilkes)
See Also: → 1102496
Yes, we're deferring to Ahmed here. The Dialer is, similarly to player controls, heavily influenced by hardware legacy, so it's tricky to change things that -- even though not ideal - may still be acceptable and/or familiar. Also, the work here is for Arabic only: I expect that we might specify differently (as with Ehsan's suggestion) for Persian and other bidi languages down the road.
Flags: needinfo?(swilkes)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102317
You need to log in before you can comment on or make changes to this bug.