[Flame][V1.4][Message]Device suddenly appear white screen while editing one message.

RESOLVED WORKSFORME

Status

Firefox OS
Vendcom
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: panda67231, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bamboo)

Attachments

(11 attachments)

(Reporter)

Description

3 years ago
Created attachment 8429833 [details]
WhiteScreen.rar

[1.Description]:
Device suddenly appear white  screen while editing one message.
Attachment video:[20140527_170627.mp4]
Attachment log:[bugreport.txt]&[logcat.txt]
Happen  time:17:09

[2.Testing Steps]: 
1. Launch message
2. Tap one message
3. Type one letter

[3.Expected Result]: 
3. Device should work well, and there is no any error.

[4.Actual Result]: 
3.Device suddenly appear white  screen. Press power key,and screen changes black,then press power key serverl times, and there is no response. Waitting 30 seconds ,press power key again, the device back to normal

[5.Reproduction build]: 
Gaia        7709936aeb21859d1607dbd038489493803bb085
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/5bf038fae0f1
BuildID    20140522160202
Version    30.0

[6.Reproduction Frequency]: Seldom Recurrence,1/10
FWIW I use a Peak on version 1.4 for a few weeks and never saw this, so I think this is a device driver issue.
Blocks: 1015220
Hi Reporter,
    I try to reproduce this bug 20 times, but it could not be reproduced. May I know more details?
    
    (1) The reproduce rate is 1/10. It means issue will happen one time every 10 times testing, or it just happens one time in your testing.

    (2) In step2, the message is existed message or create one new message.
Flags: needinfo?(panda67231)
(Reporter)

Comment 3

3 years ago
Dear hubert,
    1. This bug just happened once, 1/10 means that we repeat the steps 10 times in total after this bug happened.
    2. In step 2, the message is existed message, recipient number is: 10086.

However, we will keep tracking to reproduce this bug, and provide more details.

Thanks.
Flags: needinfo?(panda67231)
(Reporter)

Comment 4

3 years ago
Created attachment 8430728 [details]
WhiteScreen_Verify1.rar
(Reporter)

Comment 5

3 years ago
Hi, we have encountered one same bug, the steps as follows:
1. Launch contact;
2. Tap +, and enter edit contact information view;
**After a while, the screen changes white, and wait for 1 mintue, press power key to screen off, and then screen on, the lock screen appears. For detail ,please see video and log: WhiteScreen_Verify1.rar

Thanks.
I have seen a white screen on Flame before, but no other device. It only happens though when airplane mode wasn't enabled & disabled though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1017256

Updated

3 years ago
Duplicate of bug: 1017526
(Reporter)

Comment 8

3 years ago
We encountered this bug today, reproduce steps as follows:
1. In home screen, tap "I'm thinking of" several times.
2. Let DUT in idle
**After a while, screen changed white. Lock and unlock screen, DUT recovered, but it would appear again after staying idle for a while.  Reboot device, and it could recover completely.

Occurrence time: 8:30AM
Please refer to attachment: WhiteScreen_Verify2
(Reporter)

Comment 9

3 years ago
Created attachment 8434873 [details]
WhiteScreen_Verify2_bugreport.txt
(Reporter)

Comment 10

3 years ago
Created attachment 8434874 [details]
WhiteScreen_Verify2_logcat.txt
So it's not SMS specific.
Component: Gaia::SMS → Gaia
(Reporter)

Comment 12

3 years ago
Created attachment 8438088 [details]
whitescreen.jpg

We repro it again, 
precondtion: timeout is set as 1min
1. in homescreen, let device idle
2. Device screen will change to white after 10~20 seconds.

See attachment WhiteScreen_Verify3.txt & video & screenshot
(Reporter)

Comment 13

3 years ago
Created attachment 8438090 [details]
VID_20140611_093805.3gp
(Reporter)

Comment 14

3 years ago
Created attachment 8438091 [details]
WhiteScreen_Verify3_bugreport.txt
(Reporter)

Comment 15

3 years ago
Created attachment 8438092 [details]
WhiteScreen_Verify3_logcat.txt
panda, what's your device?

Jason, do you know who can at least handle this bug?
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(panda67231)
Flags: needinfo?(jsmith)
Resolution: DUPLICATE → ---
(Reporter)

Comment 17

3 years ago
Julien, my device is flame whose build version is same as this bug.
Flags: needinfo?(panda67231)
(Reporter)

Comment 18

3 years ago
Created attachment 8438267 [details]
WhiteScreen_bugreport_Verify4.txt

This bug just happens again. 
1. Enter Settings-->Bluetooth
2. Switch on BT and tap search for devices
**After a while, device changes to white screen.

I have do these two steps for more than 20 times, and at around 11:00AM(mobile time), this bug happens again. 
Hope that these information is usefull for you.
(Reporter)

Comment 19

3 years ago
Created attachment 8438269 [details]
WhiteScreen_logcat_Verify4.txt
(Reporter)

Comment 20

3 years ago
Created attachment 8438274 [details]
WhiteScreen_Verify4.3gp

After device screen changes to white, press power+home keys to screenshot, and the screenshot file will show the view before it changes to whitescreen.
I'm adding qawanted to see if someone else can reproduce this.
Flags: needinfo?(jsmith)
Keywords: qawanted

Updated

3 years ago
Duplicate of this bug: 1024769
Francis - We're seeing white screens of death with the latest vendor build (no STR in particular). Can you get someone from T2M to look at this to see if this is an issue on their end?
Blocks: 801898
Component: Gaia → Vendcom
Flags: needinfo?(frlee)

Updated

3 years ago
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #23)
> Francis - We're seeing white screens of death with the latest vendor build
> (no STR in particular). Can you get someone from T2M to look at this to see
> if this is an issue on their end?

From the duped bug 1024769, we're pretty consistently seeing problems when running test_settings_wifi on repeat - so if we're still unable to reliably reproduce manually, so that's an avenue available to you, Francis.
hi Jason,

when you mention about the latest vendor build, are you talking about v121-2 and you replace v1.4 gaia/gecko?
Flags: needinfo?(frlee) → needinfo?(jsmith)
Actually looks like the automation is running on old image - I know the bug as filed here was reported on an older image as well. Stephen - Can you upgrade the existing devices running automation to the latest image & retest with 1.4?
Flags: needinfo?(jsmith) → needinfo?(stephen.donner)
All of the Flames should be running on v121-2 right now, and the bug is reproduces occasionally.
Flags: needinfo?(stephen.donner)
Actually, the job that normally causes the error (b2g.flame.mozilla-b2g30_v1_4.adhoc_test_settings_wifi) wasn't run since June 12. Running it through again a couple times I haven't seen the bug crop up.
(In reply to Dylan Chun Wong [:dwong] from comment #28)
> Actually, the job that normally causes the error
> (b2g.flame.mozilla-b2g30_v1_4.adhoc_test_settings_wifi) wasn't run since
> June 12. Running it through again a couple times I haven't seen the bug crop
> up.

Francis, we have a reproducible case with a very simple change to a 1.4 branch; same test as from the duped bug, bug 1024769.  We have logcats from that, if they'd be useful -- anything else we can do (realizing that the phone ends up in this state of white-screen death, and when it does, we can no longer adb shell into it)?
(In reply to Stephen Donner [:stephend] from comment #29)
> (In reply to Dylan Chun Wong [:dwong] from comment #28)
> > Actually, the job that normally causes the error
> > (b2g.flame.mozilla-b2g30_v1_4.adhoc_test_settings_wifi) wasn't run since
> > June 12. Running it through again a couple times I haven't seen the bug crop
> > up.
> 
> Francis, we have a reproducible case with a very simple change to a 1.4
> branch; same test as from the duped bug, bug 1024769.  We have logcats from
> that, if they'd be useful -- anything else we can do (realizing that the
> phone ends up in this state of white-screen death, and when it does, we can
> no longer adb shell into it)?

In particular, this change: https://github.com/mozilla-b2g/gaia/pull/20699/files
Flags: needinfo?(frlee)
hi Stephen,

would you mind to try the latest production build V122 and see if issue can be reproduced?

https://mozilla.app.box.com/files/0/f/1708478428/Foxfone-One
Flags: needinfo?(frlee)
(In reply to Francis Lee [:frlee] from comment #31)
> hi Stephen,
> 
> would you mind to try the latest production build V122 and see if issue can
> be reproduced?
> 
> https://mozilla.app.box.com/files/0/f/1708478428/Foxfone-One

Dylan, tomorrow can you check this out and see if it "fixes" our issue on 1.4, etc.?  Thanks!
Flags: needinfo?(dwong)
Sure thing, do you mean simply flash it on a couple devices in lab and run the tests?
Flags: needinfo?(dwong) → needinfo?(stephen.donner)
(In reply to Dylan Chun Wong [:dwong] from comment #33)
> Sure thing, do you mean simply flash it on a couple devices in lab and run
> the tests?

Lab or locally, yes (shouldn't matter).  Then run that problematic 1.4 Wi-Fi run on it, using --repeat - thanks!
Flags: needinfo?(stephen.donner)
I believe I've found why some devices have been found turned off during tests (e.g. Bug 1027012). When a device white screens it doesn't charge, and so it stays on until it runs out of battery. I've found this when resetting a device that was white screened for awhile and it's battery was at 1% even though it was plugged in the entire duration. 

On another note, after flashing v122 my device wasn't picked up by adb devices on the node or my machine.

Updated

3 years ago
Duplicate of this bug: 1018361
(In reply to Dylan Chun Wong [:dwong] from comment #35)
> I believe I've found why some devices have been found turned off during
> tests (e.g. Bug 1027012). When a device white screens it doesn't charge, and
> so it stays on until it runs out of battery. I've found this when resetting
> a device that was white screened for awhile and it's battery was at 1% even
> though it was plugged in the entire duration. 
> 
> On another note, after flashing v122 my device wasn't picked up by adb
> devices on the node or my machine.

Francis, do you have fixes for either/both of these, in the upcoming base-build version?
Flags: needinfo?(frlee)
hi Youlong,

could you please check comment 30? white screen issue appears when we 'remove remembered networks' in our test, let me know if you need any logs or further information. 

hi Stephen,

in comment 35, i suppose you met a problem under window system? if so, please get the driver and ADB tools from below link, there is a simple guideline for adding ADB Environment Variables in the zip file as well.
https://www.dropbox.com/s/bstb3gvts1o8soj/Driver%26Tools.zip

under linux, v122 works correctly, at least Taiwan team hasn't met any similar issue.
Flags: needinfo?(frlee) → needinfo?(youlong.jiang)
(In reply to Francis Lee [:frlee] from comment #38)

> hi Stephen,
> 
> in comment 35, i suppose you met a problem under window system? if so,
> please get the driver and ADB tools from below link, there is a simple
> guideline for adding ADB Environment Variables in the zip file as well.
> https://www.dropbox.com/s/bstb3gvts1o8soj/Driver%26Tools.zip
> 
> under linux, v122 works correctly, at least Taiwan team hasn't met any
> similar issue.

I believe we haven't seen the white-screen issue under V122 either; thanks!
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.