Closed Bug 1020473 Opened 7 years ago Closed 6 years ago

Make Jetpack meet the TBPL visibility requirements

Categories

(Add-on SDK Graveyard :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Unassigned)

References

Details

At present, Jetpack sadly doesn't meet the visibility requirements for TBPL.

Notably:
https://wiki.mozilla.org/Sheriffing/Job_Visibility_Policy#6.29_Outputs_failures_in_a_TBPL-starrable_format

In the form of bug 1020458 and bug 1020463.

In addition, the intermittent failure rate is quite high at present.

As such Jetpack, has been hidden from the default TBPL view for all trunk trees (it was already hidden on Windows 7 for bug 942111 / bug 981003).
Blocks: 981003
No longer depends on: 1020458
Depends on: 1020458
18:40 <philor> edmorley|sheriffduty: and once they finish timing out, https://tbpl.mozilla.org/?tree=Mozilla-Inbound&jobname=jetpack&showall=1&fromchange=223a185a7ee2&tochange=bf5c893c2733 should show that it was bug 997894 that we didn't see breaking jetpack

I've backed out bug 997894 - however the overall failure rate and the lack of timeout handling/test names given as 'unknown' are still problematic.
Priority: -- → P1
Assignee: nobody → evold
Depends on: 980959, 1030036
Depends on: 873204
No longer depends on: 980959
Depends on: 1035508
Hidden on try to match inbound
Depends on: 883778
Jetpack tests are currently orange on every platform on trunk, was regressed by:
https://tbpl.mozilla.org/?tree=Fx-Team&showall=1&jobname=jetpack&rev=fea2a90e2d22
Depends on: 1055231
No longer depends on: 1055231
For the record, the test-child_process tests have been disabled, https://github.com/mozilla/addon-sdk/commit/8e68d49c71bac4202c689d6d677a8aed77f05dd4

So bug 979675, bug 979334, and bug 979039 should no longer be an issue at the moment, and I think we should remove them as blockers for this now at least.

Does this sound ok to you Ed?
Flags: needinfo?(emorley)
Yeah, if tests have been disabled, the intermittent (or permanent) failure bugs for them are definitely not blockers to this any more :-)

JP is still orange though:
https://tbpl.mozilla.org/?tree=Fx-Team&showall=1&jobname=jetpack
Flags: needinfo?(emorley)
I wanted to try to work on this more, but I'm not sure that I will be able to now.
Assignee: evold → nobody
> JP is still orange though:
> https://tbpl.mozilla.org/?tree=Fx-Team&showall=1&jobname=jetpack

Shu, this sounds like temporal dead zone stuff, right?

TypeError: redeclaration of variable sliceTest
Flags: needinfo?(shu)
(In reply to David Major [:dmajor] from comment #8)
> > JP is still orange though:
> > https://tbpl.mozilla.org/?tree=Fx-Team&showall=1&jobname=jetpack
> 
> Shu, this sounds like temporal dead zone stuff, right?
> 
> TypeError: redeclaration of variable sliceTest

Most of that stuff has already been fixed in github and needs to be uplifted.
Flags: needinfo?(shu)
That's right, if it's a newly surfaced "redeclaration" error, it's almost guaranteed to be TDZ.
Ugh, having tbpl spam this bug is extremely unhelpful
Not arguing with you on that (not sure why he's starring jobs that are supposed to be hidden anyway), but FYI, you can hide the comments entirely using the "Hide TinderboxPushlog Comments" to the right.
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #24)
> Not arguing with you on that (not sure why he's starring jobs that are
> supposed to be hidden anyway), but FYI, you can hide the comments entirely
> using the "Hide TinderboxPushlog Comments" to the right.

The TBPLbot comments are treeherder-style message formatting; https://treeherder.mozilla.org/ui/#/jobs?repo=try&searchQuery=jetpack has jetpack jobs not hidden - could you tweak the profile? :-)
Hidden on Try
Depends on: 1063242
Severity: normal → critical
No longer depends on: 926264
No longer depends on: 942111
I'm going to assert that with mochitest-jetpack we're now at the point where jetpack tests meet the required standards. Opt builds have been green since they were turned on, aside from some windows failures which were actually detecting a regression in mozilla-central. There may still be some intermittents left but they are low enough that I don't think they should block us further at this point. We should start disabling tests if they are too intermittent.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.