[Flame] flicking through images causes screen to go dark between the images

VERIFIED FIXED in Firefox 32

Status

()

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: njpark, Assigned: kats)

Tracking

({regression})

unspecified
mozilla33
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.0+, firefox31 wontfix, firefox32 fixed, firefox33 fixed, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(6 attachments)

(Reporter)

Description

5 years ago
STR:
-Open Gallery (with several pictures already stored) 
- Hold the phone horizontally, and flick through images 
Expected:
image flows normally
Actual:
screen goes dark momentarily when a new image is called.

Video link:
https://www.dropbox.com/s/0iek9b11himf054/VID_20140610_153359.mp4

Version Info (in master branch, after 2.0 branch):
Gaia      f42ebc93554979501d3ac52bcf9e69cb4b310a4f
Gecko     https://hg.mozilla.org/mozilla-central/rev/9dc0ffca10f4
BuildID   20140610040208
Version   33.0a1
ro.build.version.incremental=104
ro.build.date=Fri Jun  6 17:35:09 CST 2014
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 2.1?
(Reporter)

Comment 1

5 years ago
This also happens when the video time slider is moved to earlier in time

Also happens in 2.0 Branch:
Gaia      a0f9f1f41a436daad8a249ce85df80a81a5ba2d5
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/0c0effd600c4
BuildID   20140611091242
Version   32.0a2
ro.build.version.incremental=eng.cltbld.20140610.032245
ro.build.date=Tue Jun 10 03:22:54 EDT 2014
blocking-b2g: 2.1? → 2.0?

Comment 2

5 years ago
Also happening on portrait (when you hold phone vertically too) from yesterdays build (6/10).

Comment 3

5 years ago
is this is a regression issue? adding qawanted
Whiteboard: qawanted

Updated

5 years ago
Keywords: qawanted
Whiteboard: qawanted
Can someone please check this on 1.3 to see if it happens there as well?
No-Jun: Which base image were you using for Flame?
Flags: needinfo?(npark)
Using Flame:

Gaia   a0f9f1f41a436daad8a249ce85df80a81a5ba2d5
SourceStamp 0c0effd600c4
BuildID 20140611091244
Version 32.0a2
Base Image: 121

I don't see the screen going black between pictures using the latest base image.
(Reporter)

Comment 7

5 years ago
(In reply to Marcia Knous [:marcia - use needinfo] from comment #5)
> No-Jun: Which base image were you using for Flame?

I used the latest base image  v121-2, and one before, and it was reproducible on both.
Flags: needinfo?(npark)
(Reporter)

Comment 8

5 years ago
I just tested again with latest 2.0 (below), and the issue is no longer reproducible with the same STR.

Gaia      6aa07ea10420bd77f93d7415b5e34d89acc47a7e
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/c83fdcf0b735
BuildID   20140611160205
Version   32.0a2
ro.build.version.incremental=eng.cltbld.20140610.032245
ro.build.date=Tue Jun 10 03:22:54 EDT 2014

Updated

5 years ago
QA Contact: demerick

Comment 9

5 years ago
This issue does not reproduce on Flame 1.3

Device: Flame 1.3
Build ID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3) 
Firmware Version: v10G-2

User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

The screen does not go dark while holding the phone horizontally and swiping through each image in the gallery.
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: demerick

Updated

5 years ago
QA Whiteboard: QAnalyst-Triage?
Based on Comment 8 this issue may no longer be reproducing

QA-Wanted to check on the latest Flame build using base image v121-2 (don't forget your new memory throttle process after basing).
Flags: needinfo?(jmitchell)
Keywords: qawanted
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
QA Whiteboard: QAnalyst-Triage? → [QAnalyst-Triage+]
Just in case, here are the variables for the base image v121-2 for the following devices that the issue does not occur on: 

Environmental Variables:
Device: Flame 2.0
Build ID: 20140613000203
Gaia: a3a5322692578e0a577fb7fa08e32144b2b05ba3
Gecko: 8897bc43f59b
Version: 32.0a2 (2.0) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame Master
Build ID: 20140612040203
Gaia: 41db6954a67efc55016744bc8f6591ae9e07a285
Gecko: 9e8e3e903484
Version: 33.0a1 (Master) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 1.4
Build ID: 20140613000202
Gaia: 1dae62556e642b0b2e08689e35e24e56daa8c79b
Gecko: 30224c7f5e58
Version: 30.0 (1.4) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140612160201
Gaia: a3a5322692578e0a577fb7fa08e32144b2b05ba3
Gecko: 0293597de41f
Version: 32.0a2 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

no black screen, screen does not go dark momentarily when a new image is called
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
(Reporter)

Comment 12

5 years ago
This happens again in 2.1 (Master branch) and 2.0 branch
Gaia      ccd70903544486bea04e85d8a4aacf63f1de2a72
Gecko     https://hg.mozilla.org/mozilla-central/rev/bdac18bd6c74
BuildID   20140620040204
Version   33.0a1
ro.build.version.incremental=eng.cltbld.20140610.032245
ro.build.date=Tue Jun 10 03:22:54 EDT 2014

Gaia      c5dd47e3f9e18872961946735fdbc071a1656ac9
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/71b1b4b0850c
BuildID   20140620000202
Version   32.0a2
ro.build.version.incremental=eng.cltbld.20140610.032245
ro.build.date=Tue Jun 10 03:22:54 EDT 2014
Status: RESOLVED → REOPENED
blocking-b2g: --- → 2.0?
Resolution: WORKSFORME → ---
QA Wanted - Can someone else confirm what No-Jun is seeing?
Keywords: qawanted
I reconfirmed the findings listed in comment 12 with a Buri and Flame device on the latest 2.1 Master builds. 

Latest base image was installed on both devices, accordingly. 

This bug seems to be a result of a poor transition between Gallery images (in portrait and landscape modes). 

At times, the UI banner at the bottome of the screen will dissappear completely when swipping quickly and slowly between images.   

Environmental Variables:

Device: Flame Master
Build ID: 20140620094247
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 892d7a8eda45
Version: 33.0a1 (Master)
Firmware Version: v121-2

Device: Buri Master
Build ID: 20140620094247
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 892d7a8eda45
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
Flags: needinfo?(jmitchell)
Keywords: qawanted
2.0 branch testing is coming, I asked Dixon to post those first for timeliness.
Flags: needinfo?(jmitchell)
Confirming issue DOES occur in latest 2.0 Flame build and latest 2.0 Buri build.

Device: Flame 2.0
Build ID: 20140620101046
Gaia: 27f07f479e696af304d52e5fdd654317baa8c17d
Gecko: 606653d5d01d
Version: 32.0a2 (2.0)
Firmware Version: v121-2

Device: Buri 2.0
Build ID: 20140620101046
Gaia: 27f07f479e696af304d52e5fdd654317baa8c17d
Gecko: 606653d5d01d
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
Josh - If this is now reproducing & wasn't reproducing on 1.4, then the regression keywords should be flagged.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review-]
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: lmauritson
Blocking because of regression from 1.4 (based on comment 16). 

Diego, could you please take a look and see whats going on?

Thanks
Hema
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(dmarcos)
QA Whiteboard: [QAnalyst-Triage+][lead-review-] → [lead-review-]
I can reproduce the problem but intermittently. See attached video. I reproduce both in landscape and portrait orientations.
Flags: needinfo?(dmarcos)
Created attachment 8444727 [details]
galleryFlicker.MOV
Tested on:

Gaia      41cc1de26e4edbe12add0009cdc0bd292f2e94fe
Gecko     https://hg.mozilla.org/mozilla-central/rev/31de1a84b27f
BuildID   20140623095855
Version   33.0a1

Comment 22

5 years ago
B2G Inbound Regression Window

Last Working
Device: Flame Master
BuildID: 20140609154428
Gaia: d64172b2df8b406183e4d6de0cab2494c6dcf211
Gecko: 7fb68b04c53c
Version: 33.0a1 (Master) 
Firmware Version: v122

First Broken
Device: Flame Master
BuildID: 20140609155654
Gaia: 901646a3279c66daa7621bebb62641779d8ae22c
Gecko: 58cf55af0ec1
Version: 33.0a1 (Master) 
Firmware Version: v122

First_Broken_Gaia_Last_Working_Gecko: Reproduces
Gaia: 901646a3279c66daa7621bebb62641779d8ae22c
Gecko: 7fb68b04c53c

Last_Working_Gaia_First_Broken_Gecko: Does not reproduce
Gaia: d64172b2df8b406183e4d6de0cab2494c6dcf211
Gecko: 58cf55af0ec1

Gaia Pushlog
https://github.com/mozilla-b2g/gaia/compare/d64172b2df8b406183e4d6de0cab2494c6dcf211...901646a3279c66daa7621bebb62641779d8ae22c
QA Whiteboard: [lead-review-] → [lead-review-],[QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Whiteboard: [lead-review-],[QAnalyst-Triage?] → [lead-review-],[QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Broken by bug 1020045.
Blocks: 1020045
Good job Lionel! Confirmed that setting apz.overscroll.enabled to false fixes the issue (attached PR).
We need people to system front end to look into this
Flags: needinfo?(jsmith)
(In reply to Diego Marcos [:dmarcos] from comment #26)
> We need people to system front end to look into this

Are you sure? Overscroll is technically an APZC feature, managed by Milan.

Milan - Where would a bug like this need to be fixed? Gecko or the window manager?
Flags: needinfo?(jsmith) → needinfo?(milan)
QA Whiteboard: [lead-review-],[QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(In reply to Diego Marcos [:dmarcos] from comment #24)
> Good job Lionel! Confirmed that setting apz.overscroll.enabled to false
> fixes the issue (attached PR).

Unexpected, but we could be mistaking it for the overscroll, I guess.  Nice find.
Flags: needinfo?(milan)
Component: Gaia::Gallery → Panning and Zooming
Product: Firefox OS → Core
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
See Also: → bug 1029971
Assignee: nobody → bugmail.mozilla
It looks like what's happening here is that while you're viewing a gallery image, the gallery is still underneath and scrollable. By scrolling vertically on the image currently being viewed, you can scroll the gallery underneath (you can see this if you close the image view and go back to the gallery). When the gallery goes into overscroll the screen blacks.

So one problem is that the gallery underneath is scrolling at all. This is along the same vein as bug 1021413 except as far as I can tell there's no opacity issue here. Might just be bad layerization or something.

The second problem is that instead of displaying the overscroll effect the screen blacks out. Not yet sure why that's happening.
The second problem is because the layer that's scrolling (i.e. the ContainerLayerComposite corresponding to the gallery underneath) is a scroll info layer and has no children. Therefore, after painting the background color at [1] there are no children to paint on top of it, and so we just get black.

[1] http://mxr.mozilla.org/mozilla-central/source/gfx/layers/composite/ContainerLayerComposite.cpp?rev=ae6f7d5a01b3#347
Created attachment 8446177 [details] [diff] [review]
Don't fill background for scrollinfo layers

r? to matt since BenWa is (in theory) away at the moment.
Attachment #8446177 - Flags: review?(matt.woodrow)
Blocks: 1029971
Blocks: 1026683
Attachment #8446177 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/2186f79e926c
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
https://hg.mozilla.org/releases/mozilla-aurora/rev/6d261c1cbe25
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
status-firefox31: --- → wontfix
status-firefox32: --- → fixed
status-firefox33: --- → fixed
No longer blocks: 1029971
Duplicate of this bug: 1029971
No longer blocks: 1026683
Duplicate of this bug: 1026683

Updated

4 years ago
status-b2g-v2.0: fixed → verified

Comment 37

4 years ago
Created attachment 8534157 [details]
video of Flame 2.1

Hi Mike,
Could you help with it, thanks.

This issue has been verified unsuccessfully on Flame v2.1
STR:
1. Launch Gallery app.
2. Hold the phone horizontally, and flick through images
**There is a black area at left/right when you slide left/right to view images.
Found time:14:29
See attachment: Flame 2.1.MP4 and logcat_1429.txt
Reproducing rate: 5/5
Flame 2.1 versions:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141205.035305
FW-Date         Fri Dec  5 03:53:16 EST 2014
Bootloader      L1TC00011880

This issue has been verified successfully on Flame v2.0
See attachment: Flame 2.0.MP4
Reproducing rate: 0/5
Flame 2.0 versions:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/2d0860bd0225
Build-ID        20141209000202
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141209.032456
FW-Date         Tue Dec  9 03:25:13 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(mlien)

Comment 38

4 years ago
Created attachment 8534158 [details]
logcat of Flame 2.1

Comment 39

4 years ago
Created attachment 8534160 [details]
video of Flame 2.0
Verified again with v2.1, this black area is due to the rendering algorithm and performance.
The original problem is while flicking there has a all black screen and it cannot be reproduced with today's build

Gaia-Rev        c226db212db4d824c09617cd6dc407b2d4258d9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/cf8bebfa4703
Build-ID        20141209170126
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141209.212104
FW-Date         Tue Dec  9 21:21:15 EST 2014
Bootloader      L1TC10011880
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
Flags: needinfo?(mlien)
You need to log in before you can comment on or make changes to this bug.