Crash when trying to play YouTube video with MSE

VERIFIED FIXED in Firefox 33

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mithrandi, Assigned: kinetik)

Tracking

(Blocks: 1 bug)

Trunk
mozilla33
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox33 verified)

Details

(crash signature)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140621030204

Steps to reproduce:

1. Set media.mediasource.enabled to true.
2. Request the HTML5 player by way of https://www.youtube.com/html5.
3. Attempt to play a WebM YouTube video such as https://www.youtube.com/watch?v=WAvN0EzEacU.


Actual results:

Firefox crashes after a few seconds.


Expected results:

Video plays without Firefox crashing.
(Reporter)

Updated

5 years ago
Blocks: 778617
Crash Signature: mozilla::MediaSourceReader::RequestVideoData(bool, __int64)
(Reporter)

Comment 1

5 years ago
Crash ID was e939b2dc-8b8e-4926-82fa-8bfd72140622
(Reporter)

Comment 2

5 years ago
Uhm, bp-e939b2dc-8b8e-4926-82fa-8bfd72140622 (sorry for the noise).

Comment 3

5 years ago
No crash on my firefox:
User Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140621004001
(Assignee)

Updated

5 years ago
Blocks: 1000686
(Assignee)

Updated

5 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
Version: 33 Branch → Trunk

Comment 4

5 years ago
I am also getting a lot of crashes, different  signature though

bp-6fe0aba9-bea9-4e9c-b18d-7a4b22140622
(Assignee)

Comment 5

5 years ago
Thanks, it looks like the async readers changes (bug 979104) have caused some breakage and/or revealed some latent issues.

annaeus, would you mind filing a new bug for your crash, please?  It may end up being related, but as you pointed out, it does have a different crash signature.  Thanks!

Comment 6

5 years ago
Ok, filed bug 1028742
(Assignee)

Updated

5 years ago
Depends on: 1028748
(Assignee)

Updated

5 years ago
Depends on: 1028144
(Assignee)

Comment 7

5 years ago
Hopefully fixed by bug 1028144.
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

5 years ago
This crash (and also the one in bug 1028742 which I also saw before sometimes) seems to be no longer reproducible in the latest Nightly, so it looks like it's fixed! (although I can't figure out how to update the bug metadata to indicate this)

Comment 9

5 years ago
Same, no crashes for me so far. 

However the video seems to freeze (stops and never resumes playing) when buffering is triggered. Are there any bugs about that?
(Assignee)

Comment 10

5 years ago
Thanks for confirming, I'll close this as fixed by bug 1028144.

(In reply to annaeus from comment #9)
> Same, no crashes for me so far. 
> 
> However the video seems to freeze (stops and never resumes playing) when
> buffering is triggered. Are there any bugs about that?

Could be bug 1024858, I'm working on a fix for this now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → kinetik
Target Milestone: --- → mozilla33
Marking as Verified based on comment 8 and comment 9. Trying the steps from comment 0 I also did not have any issues in Firefox 33 Beta 1 (BuildID=20140902214533). Also I see no crashes in Socorro over the past 4 weeks: https://crash-stats.mozilla.com/query/?product=Firefox&version=ALL%3AALL&range_value=4&range_unit=weeks&date=09%2F04%2F2014+11%3A00%3A00&query_search=signature&query_type=contains&query=mozilla%3A%3AMediaSourceReader%3A%3ARequestVideoData%28bool%2C+__int64%29&reason=&release_channels=&build_id=&process_type=any&hang_type=any.
Status: RESOLVED → VERIFIED
status-firefox33: --- → verified
You need to log in before you can comment on or make changes to this bug.